Bug #1751

GT-3 Mark II downloading chanels problem

Added by Luca Deidda over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:07/11/2014
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:0.4.1
Chirp Version:daily Platform:All
Model affected:GT-3 Mark II

Description

1. What is the behavior you are seeing?
I plug-in the original BAOFENG cable into USB port.
Follow instructions to DOWNLOAD FROM RADIO.
After CLONING process, nothing happens
2. What is the behavior you were expecting?
I’m expecting to see the downloaded channels list.
3. Can you reproduce the problem all the time?
Yes, every time I repeat the procedure, nothing happens.
4. What are the steps required to reproduce the problem?
Just follow the instructions suggested by the program.
5. Is this specific to a certain radio model (driver) or something that you can reproduce with another radio?-
If I try with a BAOFENG UV-5RS (BFB297), it runs perfectly.
If I try with a BAOFENG GT-3 Mark II (BFB29??), nothing happens.

gt-3_firmware.JPG - Firwmare (24.1 kB) Luca Deidda, 07/11/2014 01:50 pm

GT-3.JPG - Radio Model (2 MB) Luca Deidda, 07/11/2014 01:50 pm

debug.log (4.8 kB) Luca Deidda, 07/11/2014 01:55 pm

uv5r.py (54.1 kB) Jim Unroe, 07/11/2014 06:54 pm

debug.log (22.8 kB) Luca Deidda, 07/13/2014 01:31 pm

error.jpg (22.9 kB) Luca Deidda, 07/13/2014 01:33 pm

uv5r.py (55.4 kB) Jim Unroe, 07/17/2014 05:57 pm

Associated revisions

Revision 2238:73e127bbd981
Added by Jim Unroe over 3 years ago

[UV-5R] Update Firmware Version Detection

Fix firmware version block length (14 characters instead of 16). The
firmware version check was failing on characters outside of the firmware
version block.

Swap the check order for BFB and BFS in the firmware version string so
the first occurance will always be selected. The previous method was
allowing different firmware versions to be detected as being the same.

Related to bug #1751

History

Updated by Luca Deidda over 3 years ago

Pardon, I forgot to attatch the log file :-)

Thanks for your help,
Best Regards,
Luca

Updated by Jim Unroe over 3 years ago

Luca,

The bug appears to be in your firmware. Possibly a bad write from the factory.

From the debug.log: Unable to parse version string BFS311 BFB29Ðÿ

The "BFB29Ðÿ" should be "BFB297 ". CHIRP is choking on the non-numeric character when trying to parse the version number (which should be "297"). Tell me, what do you see on the bottom line when you power the radio on while pressing the [3] key?

Jim KC9HI

Updated by Jim Unroe over 3 years ago

Luca,

Save the attached "uv5r.py" file to the same place that you save your .img files
Launch CHIRP
Click "Help" and then enable "Enable Developer Functions"
Click "File" -> "Load Module" and then load the "uv5r.py" file

Now try to download from your GT-3 and report back the results

Jim KC9HI

Updated by Luca Deidda over 3 years ago

Jim,
thank you a lot for the quick answer.
I loaded the uv5r.py module as you suggested, and the downloading procedure run perfectly, opening the channel list as we expected.

I also tried to modify a channel and upload it back to the GT-3.
It run correctly writing my change.

I ony found an error at the end of uploading process, showed in the attached "error.jpg" file.
thx again :-)
Regards,
LUCA

Updated by Luca Deidda over 3 years ago

...here it is the error popup,
LUCA

Updated by Luca Deidda over 3 years ago

Any news?
Best regards,
Luca

Updated by Jim Unroe over 3 years ago

Luca,
Sorry, I didn't see your reply of 4 days ago.

That error message needs to be toned down. It looks like something serious has happened when it should be more of an information only message.

It is letting you know that the channels and 99.5% of the settings have been successfully transferred. Only the Power-on messages and band limits have not been uploaded. That is the way it is supposed to work when the firmware version of the radio and the firmware version of the CHIRP editor are different.

I'll have to see if I can look into this some more after work today.
Jim KC9HI

Updated by Jim Unroe over 3 years ago

Luca,
Try this and report back.
Jim KC9HI

Updated by Luca Deidda over 3 years ago

Jim,
now it's working (uploading & downloading) without any error message.
thanks a lot for your help...

I hope the new release will include these issues...

Best regards,

LUCA

Updated by Jim Unroe over 3 years ago

Luca,
I will try to submit a patch in the next day or so.
Jim KC9HI

Updated by Jim Unroe over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Chirp Version changed from 0.4.0 to daily
  • Platform changed from Windows to All

Updated by Jim Unroe over 3 years ago

  • Status changed from In Progress to Closed
  • Target version set to 0.4.1
  • % Done changed from 0 to 100

The fix has been added to the latest daily build.
Jim

Also available in: Atom PDF