Feature #1779

[UI] Enable "Hide Unused Fields" by default

Added by Jim Unroe over 3 years ago. Updated over 1 year ago.

Status:Closed Start date:07/22/2014
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:0.4.1
Chirp Version:daily Model affected:(All models)

Description

Update "Hide Unused Fields" in the main application user interface to be enabled by default to make the spreadsheet style memory editor less confusing to new CHIRP users.

Associated revisions

Revision 2237:ee454d2ab681
Added by Jim Unroe over 3 years ago

[UI] Update default for "Hide Unused Fields" - 2nd attempt

Set "Hide Unused Fields" to be enabled by default

#1779

Revision 2697:44e9390fd40d
Added by Tom Hayward over 1 year ago

[UI] Default "Hide Unused Fields" to enabled. Completes #1779

The orignal patch to add this feature missed one place the hide_unused value
is read from. This caused new installs to show the Hide Unused Fields box as
checked, but not actually enable the feature. This patch adds defaut=True to
that last remaining line of code so that this feature is enabled on the first
run of Chirp.

History

Updated by Jim Unroe over 3 years ago

  • % Done changed from 0 to 100

Updated by Tom Hayward over 1 year ago

  • Status changed from New to Feedback

Users have reported this not working after initial install. The behavior is that the UI shows Hide Unused Fields checked, but the unused fields are still displayed. I wonder if this is the cause:

def get_bool(self, key, section=None, default=False):

Note that default=False. The UI defaults to True, so there is a discrepancy.

Updated by Tom Hayward over 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF