Bug #2011

RFinder Query fails on positive one digit Longitude

Added by Bob Greenberg about 3 years ago. Updated over 1 year ago.

Status:Closed Start date:10/31/2014
Priority:High Due date:
Assignee:Tom Hayward % Done:

100%

Category:-
Target version:0.4.1
Chirp Version:0.4.0 Platform:All
Model affected:rfinder

Description

We had several users report this and we confirmed it. this must have been introduced recently.
after analyzing the logs we found the issue...

If the Long is positive single digit the URL is malformed with a " " (space) before the long...here is the errored URL from debug.log...

Query URL: https://www.rfinder.net/query.php?vers=CH0.4.1&*lon= 0.12776*&radius=90&pass=d79c8788088c2193f0244d8f1f36d2db&lat=51.50735&email=bobofthedeep%40gmail.com

See the space after the lon= ?

If you make the Lon negative the URL looks like this...

Query URL: https://www.rfinder.net/query.php?vers=CH0.4.1&lon=-0.12776&radius=90&pass=d79c8788088c2193f0244d8f1f36d2db&lat=51.50735&email=bobofthedeep%40gmail.com

(this one works)

debug.log (18.8 kB) Bob Greenberg, 10/31/2014 11:48 am

Associated revisions

Revision 2280:f2dbc1207696
Added by Tom Hayward about 3 years ago

[rfinder] Fix longitude formatting to work with single-digit longitudes. #2011

History

Updated by Tom Hayward about 3 years ago

  • Status changed from New to Resolved
  • Assignee set to Tom Hayward
  • Target version set to 0.4.1
  • % Done changed from 0 to 100
  • Model affected changed from (All models) to rfinder

I submitted a patch to fix this. The bug has been present since the initial implementation in May 2011.

Updated by Tom Hayward over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF