Bug #2109

Error message programming UV-B5 27 menu version

Added by Henk Groningen almost 3 years ago. Updated 6 months ago.

Status:Resolved Start date:12/16/2014
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:0.5.0
Chirp Version:daily Platform:All
Model affected:UV-B5

Description

When programming an UV-B5 an error occurs at the end: radio nak'd block at address 0xF010.
The HT is however programmed.
This is with the UV-B5 with only 27 menu items, the only one I own.
This radio is missing options COMP and TXAB. Setting these in chirp does not change behavior of radio.
Seems chirp is trying to write settings the HT does not have.

( it turns out there are two versions of the B5, one with 27 menu's and one with 29 menu's.
The 27 type has a slightly lesser quality display and is missing above options. Also the TX of the radio
struggles with too(?) heavy loads on the usb<>ttl, e.g. if you have one of the DX.com CP2102 dongles with a LED on
RX the UV-B5 can't pull it to zero. A buffer transistor is needed. So it seems UV-B5 is not really TTL-compatible )

chirp err uv-b5.jpg (28.8 kB) Henk Groningen, 12/16/2014 04:27 am

my image.img (4 kB) Henk Groningen, 12/16/2014 04:27 am

levelB5.jpg (6.9 kB) Henk Groningen, 03/25/2017 01:18 am

Associated revisions

Revision 2843:4569107adfcc
Added by Jim Unroe 7 months ago

[UV-B5] Address "Radio NAK'd block at address 0x0f10" Error

This patch works around the no ACK issue caused by the Baofeng UV-B5 and
UV-B6 radios with 27 menus that do not support the Service Menu settings.

related to #2109 and others.

History

Updated by Jim Unroe almost 3 years ago

  • Status changed from New to Feedback

Henk,

From what I can tell, the UV-B5/B6 radios with only 27 menus don't allow editing of the "Test Mode Settings". Once the upload gets to the Test Mode Settings (0xF010), the radio decides it needs no more data and stops ACKing the remaining data transfer and CHIRP lets you know.

As far as I know all of the channels as setting were successfully uploaded. It is only the Test Mode Settings that don't get transferred, and they are only useful in a radio with 29 menus anyway.

Jim KC9HI

Updated by Henk Groningen almost 3 years ago

Hi Jim,

You're right. I couldn't adjust squelch and tx power for out-of-limit bands.
So I bought ( without knowing .. ) the wrong HT.

regards,
Henk

Updated by Jim Unroe almost 3 years ago

Henk,

I didn't realize that the band limits were also affected. You are right, they are. The radios with 27 menus stop ACKing the transfer at 0x0F10 and the band limits are at 0x0F30 followed by the squelch and power level settings at 0x0FF0.

Jim KC9HI

Updated by Henk Groningen almost 3 years ago

Just to clarify things:
I can program the bandlimits, and the HT does recieve according to the new limits.
I cannot program the test-values ( squelch and power ). This doesn't work with the original software either.

The thing is that after extending the limits chirp does not display the normal settings-tab anymore, instead the tab is empty. The advanced tree-view is still available.

By the way: the specific log is attached to the other issue, #2111.
The first error during readback is " Exception running RadioJob: Value 100 not in range 136-174". So it seems the limits are read back in but during the valuecheck it throws an exception.

regards

Henk

Updated by Jim Unroe almost 3 years ago

Correct. I create a file that would match your band limits this morning and almost sent it to you to try, but I loaded it here and the settings were still missing. So the problem is more than just the band limits. I didn't get a chance to look into it this evening. It is past my bed time now, so maybe I can find time to look into it tomorrow.

Jim KC9HI

Updated by Henk Groningen almost 3 years ago

If I can be of any assistance in testing or other way please let me know.
( it is of course a shame that Baofeng removed these important options in the HT )

regards

Henk

Updated by Jim Unroe 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee set to Jim Unroe
  • Target version set to 0.5.0
  • % Done changed from 0 to 100
  • Platform changed from Windows to All

CHIRP daily-20170212 should resolve this issue.

Jim KC9HI

Updated by Jonathan Roe 7 months ago

Confirmed, no more error.

Updated by Bryan Davies 6 months ago

Please forgive a question from a complete newbie to this.

I have today purchased a UV-B6 complete with manufacturer's download cable. This connects to my Windows 10 PC via COM3. I have downloaded the latest version of CHIRP - 20170324.

Chirp doesn't offer a UV-B6 option, but from reading the various issue reports I have used UV-B5 however I am getting the much reported "Radio did not ack programming mode" error when I attempt a download. I note that there is a patch mentioned above - do I need to install this manually, and if so how?

Updated by Jim Unroe 6 months ago

Leave the programming cable unplugged from the radio and try it. You will get the same error. You do not have a fully working connection between the radio and the computer.

This is usually caused by to (unrelated to CHIRP) issues.

1. The computer is using Windows and the programming cable has a counterfeit Prolific chip. The device driver auto-installed by Windows when a Prolific chip is detected is intentionally incompatible with counterfeit chips. In this case the driver has to be downgraded to v3.2.0.0 (v2.0.2.1 for Windows XP). See USB Cables and Drivers at miklor.com

2. The 2=pin plug is not fully inserted/connected to the radios socket.

My guess is that it is #1.

Jim KC9HI

Updated by Henk Groningen 6 months ago

Bryan, Jim is right: This is not a chirp issue.
Just to give some additonal hints..

To test your driver/setup connect the middle ring of the 2.5 mm connector to the ground sleeve of the 3.5 mm connector, creating a serial loop. Use any terminal program to see if serial data is echo'd.

--
There is a very, very! slight change that the handset is defective, like mine. My handset was not able to pull down the RX from the the adapter to zero ( measured and confirmed with a scope ), and could not be programmed whatever adapter was used.
I had to work around this by building a level adjuster. But this seems very rare, I haven't heard anyone else about it. I've attached a schematic, but it involves cutting the cable or using a set of male/female connectors and should only be a last resort. Of course at your own risk ...

Updated by Bryan Davies 6 months ago

Thanks Jim and Henk - I'm getting something from the radio now, although I'm still not sure what I'm doing with it!

For the benefit of anyone else with this problem, it was the device driver and it does seem to work with one called CH341S64.sys.

The cable was supplied by Baofeng so I'd be disappointed if it was a 'counterfeit Prolific chip' but I guess you never know.

Also available in: Atom PDF