Bug #2687

Kenwood TH-F6a tone frequencies incorrect

Added by Leonard Pennock about 2 years ago. Updated about 2 years ago.

Status:Closed Start date:07/01/2015
Priority:Normal Due date:
Assignee:Tom Hayward % Done:

100%

Category:-
Target version:0.5.0
Chirp Version:daily Platform:Linux
Model affected:Kenwood TH-F6a

Description

1. What is the behavior you are seeing?
When setting the Tone frequencies above 156.7 (159.8, 162.2...) an incorrect frequencies is set on radio. Likewise when downloading from radio the frequencies shown in CHIRP does not match the set frequency in the radio.

2. What is the behavior you were expecting?
Tone Frequencies should match on radio and CHIRP

3. Can you reproduce the problem all the time?
Problem is reproducable in chirp-0.4.0, chirp-0.4.1 and chirp-daily-20150623. 0.4.0 and 0.4.1 were both tried under Linux and Windows 7 with the same behaviour. Daily was only tried on Linux.

4. What are the steps required to reproduce the problem?
Choose tone frequency greater than 156.7. Then check radio and the tone on radio will be incorrect. Here is the incorrect mappings I got.
chirp/radio
159.8/162.2
162.2/167.9
165.5/173.8
167.9/179.9
171.3/186.2
173.8/192.8

5. Is this specific to a certain radio model (driver) or something that you can reproduce with another radio?
Did not have the same issue with Yaesu VX6, VX7 or Beofang UHV5r or Kenwood V71a.

debug.log - chirp-daily-20150623.log (4.2 kB) Leonard Pennock, 07/01/2015 09:44 am

Associated revisions

Revision 2581:a4eba5650b19
Added by Tom Hayward about 2 years ago

th-f6: fix tone list. #2687

In the process, consolidated tone lists for a couple other Kenwoods.

History

Updated by Tom Hayward about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Tom Hayward

The problem here is pretty obvious. In the TH-F6 manual, they list the set of valid tones. The set Chirp is using is larger (matching tone support from most other manufacturers). The solution, like with many other Kenwoods, is to adopt the shorter, proper list for the TH-F6. I'll work on this.

Updated by Tom Hayward about 2 years ago

  • Status changed from In Progress to Closed
  • Target version set to 0.5.0
  • % Done changed from 0 to 100

Should be fixed in chirp-daily-20150702 and newer. Let me know if this resolves it.

Updated by Leonard Pennock about 2 years ago

Verified the problem is fixed in chirp-daily-20150702. Thank you for the quick response.

Also available in: Atom PDF