New Model #3237

Luiton LT-825UV

Added by Robert Young almost 2 years ago. Updated almost 2 years ago.

Status:Rejected Start date:01/27/2016
Priority:Normal Due date:02/26/2016
Assignee:- % Done:

0%

Category:-
Target version:0.4.1 Estimated time:3.50 hours
Chirp Version:0.4.0 Equipment Loan Offered:No

Description

New dual band radio that the programming program doesn't work 80% of the time if you are lucky. There are many radios that are exactly the same baofeng has one, sainsonic gt-890, tokmate td-8900, juentai jt-6188, btech mini uv-2501 are all the same radio


Related issues

duplicates New Model #3235: Luiton LT-825UV Feedback 01/27/2016

History

Updated by Filippi Marco almost 2 years ago

  • Status changed from New to Rejected
  • Equipment Loan Offered set to No

Dupe of #3235

Also available in: Atom PDF