Bug #685

Cannot import a CSV file on top of a Yaesu VX-6R image

Added by Brad Rupp over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:03/12/2013
Priority:Normal Due date:
Assignee:Tom Hayward % Done:

100%

Category:-
Target version:0.3.1
Chirp Version:daily Platform:All
Model affected:Yaesu VX-6R

Description

I cannot import a CSV file on top of an existing Yaesu VX-6R image. When I try to do so, the import attempts to succeed, but the imported memory locations are not brought into the image file.

STD:
- Start Chirp
- Open vx-6r.img
- In Chirp, go to File | Import | Import the master2.csv file
- In the Import from File dialog, keep the defaults and press OK

The import appears to succeed (no errors reported) but the memory locations from the CSV file are not imported into the VX-6R image file.

I am running on Windows 7 Home Edition (64-bit).

vx-6r.img - Image file for VX-6R (31.8 kB) Brad Rupp, 03/12/2013 10:01 pm

master2.csv - CSV file for import (8.9 kB) Brad Rupp, 03/12/2013 10:01 pm

debug.log - c:\chirp\debug.log (6.5 kB) Brad Rupp, 03/12/2013 10:01 pm

vx-6r_fixed.img (31.8 kB) Tom Hayward, 03/13/2013 08:57 am


Related issues

duplicates Bug #687: Cannot import memories into a Yaesu VX-6R HT Rejected 03/12/2013

Associated revisions

Revision 1929:98964bbb011c
Added by Tom Hayward over 4 years ago

[vx6] Fix valid/used flag logic so new memories are valid and unmasked. #685

Revision 1968:61d2a3bd8536
Added by Tom Hayward over 4 years ago

[vx6] Fix valid/used flag logic so new memories are valid and unmasked. #685

History

Updated by Tom Hayward over 4 years ago

I marked these as a duplicate because I think they're caused by the same thing, despite having different symptoms. Is the following correct?

  • In #685, you import the CSV and the imported channels do not display in the Chirp editor.
  • In #687, you paste channels into the VX6 editor. They channels display in Chirp, but not on the radio. If you save the .img and reopen it, the pasted channels don't display (as with the import).

Updated by Tom Hayward over 4 years ago

  • File vx-6r_fixed.img added
  • Status changed from New to Resolved
  • Assignee set to Tom Hayward
  • Target version set to 0.3.1
  • % Done changed from 0 to 100
  • Chirp Version changed from 0.3.0 to daily
  • Platform changed from Windows to All

I have found and fixed the bug. I'll send the patch to chirp_devel for inclusion in an upcoming daily build, but for now you can try loading this fixed img.

Updated by Tom Hayward over 4 years ago

  • Status changed from Resolved to Rejected

Updated by Tom Hayward over 4 years ago

  • Status changed from Rejected to Resolved

Oops, last status change was an error.

Updated by Tom Hayward over 4 years ago

  • Status changed from Resolved to Needs Backport

Updated by Brad Rupp over 4 years ago

Verified that the new image fixes the problem. Thanks!

Updated by Dan Smith over 4 years ago

  • Status changed from Needs Backport to Closed

Also available in: Atom PDF