Bug #769

Copy/Paste including blank memories yields error

Added by John Gorena over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:04/07/2013
Priority:Normal Due date:
Assignee:Dan Smith % Done:

0%

Category:-
Target version:0.4.0
Chirp Version:daily Platform:Windows
Model affected:vx6r, FT8900

Description

I am trying to copy and paste data to FT8900 IMG file from VX6R Data file... The power column changes from HI to LOW power. I also noticed that the columns that display in chirp do not display when exporting to CSV... Power is one of them.

Also, if data line is blank, I get an error that says frequency cannot be 0.00000

Associated revisions

Revision 1962:a7c11650b9bb
Added by Dan Smith over 4 years ago

Do not attempt to set empty memories during copy/paste operations

Fixes #769

Revision 1971:50b7d2e82820
Added by Dan Smith over 4 years ago

Do not attempt to set empty memories during copy/paste operations

Fixes #769

History

Updated by Dan Smith over 4 years ago

  • Subject changed from Columns of data not the same as Chirp, CSV to Copy/Paste including blank memories yields error

John,

Please one issue per ticket. I think you only actually have one valid issue here, so lets clean this up.

First, the power level conversion is as intended. The VX6's High power is closest to the FT8900's Low power, which is why you're seeing the flip. Second, the CSV driver's lack of support for some features is known and documented (see #371).

The final thing mentioned here may be valid. Are you saying that if you copy a group of memories which include some empty memories, that you get errors on paste for those memories being 0.0000 ? If so, then that should be fixed, yes.

Updated by John Gorena over 4 years ago

Dan Smith wrote:

John,

Please one issue per ticket. I think you only actually have one valid issue here, so lets clean this up.

First, the power level conversion is as intended. The VX6's High power is closest to the FT8900's Low power, which is why you're seeing the flip. Second, the CSV driver's lack of support for some features is known and documented (see #371).

The final thing mentioned here may be valid. Are you saying that if you copy a group of memories which include some empty memories, that you get errors on paste for those memories being 0.0000 ? If so, then that should be fixed, yes.

Thanks for working on this issue... But I want to address your other comments... I figured a way around this Hi/Low setting change but it seems that it would be best if a Copy/Paste would work. The work around is to export the FT8900 to a CSV file, I created a column called Power, set them all to Hi in Excel, then imported. Worked fine. A routine to import/export all the columns as they appear in Chirp would be good.

Again, thanks for working on the 0.0000 Error.

John

Updated by Dan Smith over 4 years ago

John,

The reason you're seeing the power moving to high is because that's the default when one isn't specified. It is not a matter of making chirp "export all the columns". The change required is more significant than that, but it will be some at some point.

Again, the copy/paste going from hi->low is working as designed because the relative power levels of the two radios are being considered. 5W is "high" on the VX6 and "low" on the FT8900.

Updated by Dan Smith over 4 years ago

  • Status changed from New to Resolved
  • Assignee set to Dan Smith
  • Target version set to 0.4.0

Fixed in r1962

Updated by Dan Smith over 4 years ago

  • Status changed from Resolved to Needs Backport

Updated by Dan Smith over 4 years ago

  • Status changed from Needs Backport to Closed

Also available in: Atom PDF