How to use CSV files

Introduction

It is important to note that CSV stands for "Comma Separated Values" and is a method of encoding and not a strict file format. Any kind of record data can be stored in a CSV file, which is why spreadsheet applications such as Microsoft Excel and LibreOffice Calc support it. If you create a CSV file without a specific format, CHIRP will not be able to extract the needed data from it,

A Clean Start

If you want to get an empty CHIRP-compatible CSV file, the easiest way is to let CHIRP create one for you. Here are the approximate steps for creating an empty file, editing it in an external editor and opening it back up in CHIRP:

  1. Start CHIRP
  2. Go to File > New to create an empty CSV file
  3. Add a memory to the first row, by entering a frequency such as 146.52
  4. Go to File > Save As to save the template file to something ending with a .csv extension
  5. Open the file in your spreadsheet or external application of choice, make edits and save
  6. Re-open the file in CHIRP to validate that the format is still correct, by going to File > Open and choosing your file
  7. Optionally use File > Import to import the contents of your CSV file into another radio image

Tips To Avoid Breaking The Formatting

CHIRP relies on the CSV file's formatting to be intact in order for it to read and understand the data inside the file. Observe the following rules to ensure that CHIRP can continue to read the file:

  1. You must maintain the header row in its original format so that CHIRP knows which column corresponds to which value
  2. You may re-order the columns as long as the header row matches
  3. You may delete columns for which there are sane defaults and CHIRP will assume those defaults upon opening or importing the file
  4. You may place double quote marks (i.e. " not ' or '') around column values that contain spaces or commas
  5. Field values must be in the original format and one of the accepted values for the column type. For example, the Duplex field may be either blank, an plus sign (+), a minus sign (-), or the word "split". The ToneMode field may be either blank, the words "Tone", "TSQL", "DTCS", or "Cross", and so on. If there is ever a question, use CHIRP to create a file with a given value and observe what it puts into the CSV file as a result.

Getting The Data Back Into A Radio

CSV files are generic, radio-independent text files. This means that you cannot upload them directly into a radio. In order to get the information into your device, you must go through some sort of an Import operation. There are two basic ways to do this, depending on what you are trying to accomplish:

Method #1: Importing the CSV file into a radio

This method should be used when you want to import the entire contents (or some large portion) of the CSV file into the destination radio. Follow these steps:

  1. Open a .img file of your radio, or download one from it using Radio > Download From Radio. Make sure that the tab at the top says something like "Yaesu FT-7800" or "Icom IC-880" to indicate that you're operating on a radio-specific driver.
  2. Go to File > Import from file and choose your CSV file.
  3. An import dialog box will appear, which lets you preview the memories that can and will be imported. Make your selections or corrections, if necessary, and then click OK.
  4. The memories stored in the CSV file should now be visible in your editor.
  5. If you have a clone-mode radio, upload the changes back to your device using Radio > Upload To Radio. If you are using a live-mode radio, wait until all of the changes finish synchronizing back to the device by watching the status bar in the lower right corner of the main window.

Method #2: Manually copying memories into a radio

This method should be used when you want selectively import a few memories from a CSV file into the destination radio. Follow these steps:

  1. Open your CSV file using File > Open and choosing your file.
  2. Open a .img file of your radio, or download one from it using Radio > Download From Radio. Make sure that the resulting tab at the top says something like "Yaesu FT-7800" or "Icom IC-880" to indicate that you're operating on a radio-specific driver.
  3. Select the tab containing your CSV file at the top, and select memories from the CSV file you want to copy over. You can select multiple rows by holding the Shift or Control keys while making your selections.
  4. After selecting one or more memories, copy them to the clipboard by going to Edit > Copy.
  5. Next, select the tab corresponding to your actual radio at the top
  6. Select a spot in the radio's memory to paste the new memories and then go to Edit > Paste.
  7. If you have a clone-mode radio, upload the changes back to your device using Radio > Upload To Radio. If you are using a live-mode radio, wait until all of the changes finish synchronizing back to the device by watching the status bar in the lower right corner of the main window.