Bug #3527

Problem with BTECH UV-2501+220

Added by Chris Bates about 3 years ago. Updated almost 2 years ago.

Status:Closed Start date:03/28/2016
Priority:Normal Due date:
Assignee:Pavel Milanes % Done:

100%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:BTECH UV 2501+220

Description

I have been in contact with Baofeng Tech about the BTECH UV-2501+220 which you recently included support for. I get an error in CHIRP when I try to use the latest version that includes BTECH support. I am able to downlaod from the radio but when I try to upload to the radio I get an error saying "Radio did not respond to magic string, check cable." CHIRP does not give an error at all when I enable developer functions and use the latest btech.py file that Baofeng Tech sent me which I have attached. With this method I am able to download from and upload to the radio without any errors however it does cause a problem within the radio. For some reason it sets the receive CTCSS to a weird character, which cannot be changed in the radio. I have attached a picture of the characters that are displayed. It is as though there is no actual "off" option in the receive CTCSS section of CHIRP. The biggest problem here is that this makes the radio unusable. The radio then has to be reset, and all the channels re entered manually.

Thanks
Chris Bates

547.JPG (1.8 MB) Chris Bates, 03/28/2016 05:52 pm

debug.log (40.2 kB) Chris Bates, 03/28/2016 05:52 pm

btech.py (33.3 kB) Chris Bates, 03/28/2016 05:52 pm

First Programming UV-2501 220 03272016.img (16 kB) Chris Bates, 03/28/2016 05:52 pm

debug.log (27 kB) Chris Bates, 03/28/2016 06:18 pm

debug.log (19.8 kB) Ken Stone, 04/13/2016 05:09 pm

debug.log (32.8 kB) augie pagan, 04/14/2016 07:12 am

btech.py - proposed driver for test, will fix the "Radio Identification failed" with the BTECH UV-2501+220 and add Sainsonic GT-890 (51.6 kB) Pavel Milanes, 04/15/2016 08:41 am

debug_UV2501 220.log (17.9 kB) Carlos Marquez, 04/22/2016 08:21 pm

Associated revisions

Revision 2691:9750752a6ac0
Added by Pavel Milanes about 3 years ago

[BTECH UV-2501+220] Add a new generation of this radios, fixes #3527

A new variant or generation for the BTECH UV-2501+220 was found, this
has new ID.

Also cleaning of some comments out of place now.

This is related to #3015 also

73

History

Updated by Chris Bates about 3 years ago

Last attempt to program with CHIRP daily 20160328 resulted in both transmit and receive CTCSS being set to the characters seen in attached image 547.JPG.

Updated by Pavel Milanes about 3 years ago

Hi Chris,

There is a problem with the uploads for the BTECH 2501+220 due to a more stable IO procedures being implemented on the driver (the first release has a resource intensive routine that lead to certain instabilities), probably the btech.py version you get from BTECH is the beta we are testing internally to fix that, and of course it may contain bugs like the one you found now with the CTCSS.

Please wait, we are working on the issue now.

73 CO7WT

Updated by Chris Bates about 3 years ago

Sounds great, thank you. I have discovered a work-around that has had some success. I have found that if I start with a new csv in the latest CHIRP daily, I am able to either input the frequencies manually or copy and paste them from a previous csv and upload them to the radio by first unplugging and re inserting the cable into the computer just before uploading the file to the radio. If I do this, I don't get the "Radio did not respond to magic string, check cable." error. For some reason starting with the new csv from the latest daily does not input the odd characters into the CTCSS memory.

Updated by augie pagan about 3 years ago

I also received a new BTECH UV 2501+220 yesterday including Btech program cable ...radio responds with ..."Radio did not respond to magic string check cable." error....also when try to download radio shuts off and restarts ...yet responds fine when trying the Btech2501(+220)_CPS program .

Updated by augie pagan about 3 years ago

also get this message ....This driver is experimental.

Updated by Brent Haberer about 3 years ago

I just received the Btech2501+220 a few days ago.

I have a similar problem except I can not download from the radio. I have version 20160402 of the software and the latest driver 2.12.16.0. I tried Btech's program and I can download from the radio just file. I have not tried to upload with either software. I have 3 frequencies set in the radio. Chan 0,1,199

I get the following error:
An Error has occurred. Radio identification failed.

Then the radio reboots.

Thanks,
Brent

Updated by Pavel Milanes about 3 years ago

Hi to all.

This is a bug of the BTECH 2501+220 and also affects the QYT KT8900, it's about a timeouts chaining under certain circumstances and the radio timeout.

I have it solved on the dev branch, a patch will follow soon.

73 and thanks for reporting.

Updated by Ken Stone about 3 years ago

With today's build (4/12/16) which appeared to have at least some BTECH 2501+220 fixes in it, I still get the error:
An error has occurred. Radio Identification failed.
followed by a radio reboot ....

Is it safe to just assume that this issue will get updated when Pavel's fix mentioned above goes in ?

73's and thanks for all the hard work ...

Updated by Ken Stone about 3 years ago

Or am I barking up the wrong tree and is issue #3015 closer on the Radio ID failing problems ?

Sorry if I tagged on to the wrong issue ....

Updated by augie pagan about 3 years ago

new build gives me same error.... BTECH 2501+220 I still get the error:
An error has occurred. Radio Identification failed.
followed by a radio reboot ....

Updated by Pavel Milanes about 3 years ago

Ken, Augie, check your emails.

I have a request for help from your side about the problem.

73, Pavel.

Updated by Ken Stone about 3 years ago

Hi Pavel ...

No luck ...
Start chirp
enable developer functions
load btech.py module
connect cable to radio
power up radio
download from radio
first popup appears to be all good, green progress bar
then first popup goes away and 2nd popup appears
2nd popup is "An error has occurred. Radio Identification failed."
radio beeps and appears to reboot
close popup
close chirp
grab attached log

73, Ken N4CEI

Updated by Jim Unroe about 3 years ago

  • Status changed from New to Feedback

This is because your radio has a fingerprint that we have not encountered before, BTG211. Once it added you should be good-to-go.

Jim

Updated by Pavel Milanes about 3 years ago

It's exactly as Jim mentions.

Your radio has a different ID from what we have found so far (and the count keep growing), I dare to speculate by the numbers that it's a second generation of UV2501+220, maybe the Augie is hiting the same problem.

I will include it and send a new driver to test with this ID, and once confirmed it works as expected it will be included in Chirp.

Check your inbox 73.

Updated by augie pagan about 3 years ago

loaded the the new driver and similar to Ken's comments listed above except I don't get any progress bar..
see attached debug log thanks so much for all your work
73, Augie KD6AEA

Updated by Pavel Milanes about 3 years ago

  • Status changed from Feedback to In Progress
  • % Done changed from 0 to 100

A patch is on the queue to solve this issue. This must fix all the "Radio Identification failed." issues.

Please report back once you test the new version of Chirp.

73 CO7WT.

Updated by Pavel Milanes about 3 years ago

  • Assignee changed from Chris Bates to Pavel Milanes

Updated by Ken Stone about 3 years ago

Pavel ...

Driver you sent today works great ... was able to read/write multiple times to radio with no issues

Thanks for the good work !

73, Ken N4CEI

Updated by Pavel Milanes about 3 years ago

Good to know Ken and thanks to you for colaborate in the Chirp community.

Changes in the driver you have are not yet on the daily, and the starter of this issue (Chris Bates) haven't the oportunity to test it and comment about.

Let's wait for the changes being official and the Chris opinon to close this issue.

73

Updated by John Ryan about 3 years ago

Hello,

I just tried the newest version (CHIRP daily-20160415) and I'm still getting "Radio Identification failed". So I'm still unable to read my radio via Chirp.

I am able to program my radio with the software from BTECH so I know my cable is working.

If there is any information you need from me, please let me know.

Thank you ALL for the work you do.

John - N1PCE

Updated by Pavel Milanes about 3 years ago

John, the changes Ken speaks was managed internally by email. The changes are now on the developers queue, is just a matter of time for Dan to review them and (if agree) then approve it, and we will have a new version the other day.

I'm attaching the driver to this post for the users who want to test it before the official release. This driver will fix the "Radio Identification failed" error for the BTECH UV-2501+220, but just if you have the new gen2 version.

Tip: this driver adds the Sainsonic GT-890 too.

Instructions for use this driver:
1. Download the attached file and save the "btech.py" file to where you keep your chirp radio image files
2. click "Help"
3. enable "Enable Developer Functions"
4. click "File"
5. click "Load Module"
6. find and load the "btech.py" file that was saved in step 1

Note: This special test module only temporarily changes your CHIRP. In order to use it again you must load this module every time you load CHIRP.

In the error remains, here you can find instructions on how to find the debug.log to upload to this issue for me to analyze. http://chirp.danplanet.com/projects/chirp/wiki/How_to_report_issues

73 Pavel CO7WT

Updated by shelby kostelac about 3 years ago

I tested this on a kt-8900 and it still did not work selecting QYT KT-8900. However I was able to upload and download to and from radio if i selected Sainsonic GT-890. The only issues I see with it are having to use the Sainsonic selection (not a big deal). Also, I had to copy and paste my channels one at a time (again, not a big deal). Third issue is that when in channel mode and scanning after a short time it switches itself to frequency mode and starts scanning there. That is an issue that I would think needs addressed. Maybe all three of these issues are because of selecting Sainsonic and not QYT… But still isn't working when selecting QYT

Updated by shelby kostelac about 3 years ago

UPDATE I turned off priority scan and its been scanning correctly for over an hour. It has been receiving good. With priority scan on, it will stop scanning and switch to freq. mode and start scanning there..

I apologize if this is posted in the wrong place, only posting here because of the beta above

Updated by Mike Montalvo about 3 years ago

The py file worked and I was able to program the radio after having the Invalid Identifier error.

But I now have two peculiar problems. Not sure if they are related to programming or just the low quality of the radio.

https://youtu.be/U8RPHYYuyvo
https://youtu.be/_hGOwl9jvyg

Updated by John Ryan about 3 years ago

The current release (CHIRP daily-20160419) works for me. I'm not seeing any issues at this time.

Thank you for the hard work that you all do.

John - N1PCE

Updated by Mike Montalvo about 3 years ago

I figured out one of my issues. I imported the listings from an IMG file for another radio. Turns out it defaulted to having the scramble on for all the stations I imported.

Now to figure out why the signal gets stronger whenever I hit any button.

Also confirm today's release works without the btech.py file whereas yesterday's did not. Thank you all that helped in making this happen!

Updated by Carlos Marquez about 3 years ago

I hope I'm putting this in the right place. UV2501+220; Chirp 20160419 worked perfectly in windows 10 but I got "invalid header error" using Ubuntu. See log attached. Thanks.

Updated by Jim Unroe about 3 years ago

The download/upload routines for this driver are still a work in progress. I have the same issue here. I just keep trying and usually after 3 or 4 tries it will go. Using Windows 7 running in a virtual machine it goes nearly 1st time every time.

Jim KC9HI

Updated by Pavel Milanes over 2 years ago

Carlos Marquez wrote:

I hope I'm putting this in the right place. UV2501+220; Chirp 20160419 worked perfectly in windows 10 but I got "invalid header error" using Ubuntu. See log attached. Thanks.

We have possibly found a solution, please take a peek here http://chirp.danplanet.com/issues/3993#note-12 and comment about your results.

73 Pavel CO7WT

Updated by Pavel Milanes almost 2 years ago

  • Status changed from In Progress to Resolved

Updated by Pavel Milanes almost 2 years ago

  • Status changed from Resolved to Closed

Main issue is solved, side issue of "invalid header error" in ubuntu was later solved on issue #3993.

So this issue is closed.

Also available in: Atom PDF