Bug #3743

Error when importing NOAA stock config

Added by Pieter Viljoen over 4 years ago. Updated 8 months ago.

Status:Closed Start date:06/13/2016
Priority:Normal Due date:
Assignee:Tyler Tidman % Done:

100%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:(All models)

Description

Error when importing NOAA stock config
CHIRP daily-20160611
Win10 x64

Steps to reproduce:

Launch Chirp
[File][Open stock config][NOAA Weather Alert]
Error: Column number mismatch on line 2

Launch Chirp
[Radio][Import from stock config][NOAA Weather Alert]
Error: Column number mismatch on line 2

Expected behavior: Import without error

I suspected the problem could be the NOAA CSV file, so I re-exported the NOAA file after import, replaced the stock file in the stock_configs directory, restarted Chirp, but same problem.
The NOAA stock config is the only config that shows this error, I tried all the other stock configs, and they import without error.

Associated revisions

Revision 2758:bf777f74e276
Added by Dave Allan about 4 years ago

Remove spurious newline causing stock config import error. Fixes #3743

History

Updated by Tyler Tidman almost 4 years ago

  • Status changed from New to Resolved
  • Assignee set to Tyler Tidman
  • % Done changed from 0 to 100

Looks like this was probably caused by something I did for #2697. Oops.

Thanks for the fix, Dave.

Updated by Bernhard Hailer 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

prevent spam