Bug #8179

Icom IC-V86

Added by Anthony Bowyer 5 months ago. Updated 5 months ago.

Status:Closed Start date:08/13/2020
Priority:Normal Due date:
Assignee:Kosta A. % Done:

100%

Category:-
Target version:-
Chirp Version:daily Platform:All
Model affected:IC-V86

Description

Chirp seems to be sending the derived transmit freq (desired rec freq -/+ 600hz) rather than the receive freq to the handheld. For example, if 146.67 is entered for a channel and neg offset, 146.07 shows up on the handheld when the data is transfered.

If data is then downloaded from radio, Chirp shows a freq of 167.67. If the freq is manually entered on the radio and verified to be correct, then data is downloaded from radio, Chirp shows 146.67. If this is then sent to the radio, it will show 146.07.

If no offset is selected for the channel in Chirp, then the freq is correct on the radio, but then there is no offset.

v86-test.img (5.5 kB) Anthony Bowyer, 08/13/2020 04:46 pm

Associated revisions

Revision 3398:974d8d8bcaba
Added by Kosta A. 5 months ago

[ic-v86] Adds reverse duplex memory setting for ICom IC-V86. Fixes #8179

History

Updated by Rudolph Gutzerhagen 5 months ago

Please see "In case you ran into a problem with Chirp" on the chirp homepage.
Also see How to report an issue for information to include.
Please include a debug log from the session in which you experience the issue. I believe the driver for this radio has been developed recently. Would you be able to include an image img file?
I'm not familiar with that radio. Is there a setting that controls whether "duplex" frequency is stored as offset, or specific Tx freq.?
From reading your report, it is difficult to determine if your first step was to download an image from your radio. If not, please try that, and advise.

Updated by Anthony Bowyer 5 months ago

Img file was downloaded first, then updated. I am attaching the img and the log file. The V86 has auto-offset. That was the first thing I wondered about. However, I see no way to turn that off. You can set it to + - or none, but there doesn't seem to be a global setting. I even tried setting the one channel I was testing to none before transferring the data, but it made no difference.

The steps for this was:
1. Downloaded from the HT.
2. Added 146.67 to channel 1.
3. Uploaded to HT.

V86 shows 146.07. Transmitting shows a freq of 146.67.

Updated by Anthony Bowyer 5 months ago

I think I've found the problem. Looking further in the manual (what there is of one), there is a reverse offset setting. If I manually turn it off, what had been sent to the HT works correctly. However, if I send the img file again, that setting gets turned back on.

Chirp doesn't have an option to change it (that I can find). Under Settings there is "LCD Backlight", "Mic Gain", "Dial Assignment" and "Display Type".

Updated by Anthony Bowyer 5 months ago

Interestingly, if I manually add a memory channel, download this to Chirp, and modify a setting for this channel, then send it to the HT, the setting will change but Rev Offset does not get turned on.

However, if I add a channel in Chirp (using the same img file), send it to the HT, Rev Offset gets turned on for that channel.

If I manually turn off Rev Offset, download this file into Chirp, modify the new channel in some way, and send it back, Rev Offset gets turned back on.

Updated by Kosta A. 5 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90
  • Platform changed from Windows to All

From ICOM's manual:

"Reverse Duplex function
When the Reverse Duplex function is ON, the receive and
transmit frequencies are reversed."

The Reverse Duplex function is applied on a per Memory Channel basis; as such setting it in the 'Set Menu' only applies it to the VFO channel, and this subsequently is applied when it is it written into a Memory Channel.

Most ICom HT's are Clone Mode radios, so a write from Chirp is effectively the same procedure as "copying" the entire contents of another radio. As a side effect of Icom's firmware, a write/clone also results in the contents (and settings) of the VFO channel being reset.

I have a patch pending which adds the "Reverse Duplex" setting on a per Memory Channel basis; to access it you do not use the "Settings" tab, but rather the "Memory Properties" dialog (right click on a Memory Channel -> select Properties -> select Others tab).

I'm not sure how the author got into the state they did, however their Image contains a single Memory Channel with Reverse Duplex enabled - as such the software and radio are performing as designed, granted there is no method in Chirp in which to alter this flag so it will be written as whatever happens to be in memory at this location - a confusing situation to say the least...

Updated by Kosta A. 5 months ago

  • Assignee set to Kosta A.
  • % Done changed from 90 to 100

Updated by Anthony Bowyer 5 months ago

Good to know the reason. I assume the default will be "off" on each channel, unless the user explicitly sets one or more to on (forcing it off on all other channels if an updated upload is done)?

Thank you for your efforts at getting this resolved.

Updated by Tony Partain 5 months ago

I'm having the same problem, waiting for the update.

Updated by Tony Partain 5 months ago

I found a work around until the patch is completed. Only enter the downlink frequency, Set tone and duplex to none on each channel. Then after uploading to radio turn on the auto repeater function. Works like a champ.

Updated by Kosta A. 5 months ago

  • Status changed from In Progress to Closed

Applied in changeset 974d8d8bcaba.

Also available in: Atom PDF