Bug #8813

UV-9R+ connectvity issue

Added by Arno Nomad over 1 year ago. Updated over 1 year ago.

Status:Closed Start date:02/12/2021
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:All
Model affected:Baofeng UV-9R+

Description

Hi,

I have a brand-new set of Beofeng UV-9R+ and have tried to connect to both with Chirp

Somehow I'm getting the same connectivity error for both models;

"Error reading data from radio: not the amount of data we want."

The display of the UV-9R lights up shortly after wich the error appears.
This after trying to save an image.

Attached the Debug.log file.

A bit of background info;

UNXNOM cable with CP210x chip
Driver version 10.1.10.103

I've looked at the connection to the UV-9R+, it seems to be ok
No mis-allignment of the pins as far as I can see.

The UV-9R+ units are in factory state

Windows 10 Pro with all latest updates
Lenovo T480 brand-new out of the box.

Any idea's what might be the issue?

Thx

Arno

debug.log (27.4 kB) Arno Nomad, 02/12/2021 07:09 am

SHmlv.jpg (57.7 kB) Arno Nomad, 02/13/2021 06:07 am

MayNeedModifiedToFitProperly.jpg (61.1 kB) Jim Unroe, 02/13/2021 10:41 am

Should_Work_As-Is.jpg (33.8 kB) Jim Unroe, 02/13/2021 10:41 am

History

Updated by Jim Unroe over 1 year ago

  • Status changed from New to Feedback
  • Platform changed from Windows to All

It is either one of the following

1. you are choosing the wrong port
2. a bad connection between the programming cable's connector and the radio

If you leave the programming cable's connector unattached from the radio, the error will be the same.

A programming cable vendor had the same issue a few weeks ago. He sent me a pair of programming cables and I purchased a radio. When I received the cables and radio I tried them both out. Neither would work but my Retevis programming cable that I had for my Retevis RT6 radio worked fine. I examined that connection and it was clear that the connector did not fit the radio properly. I studied the issue and then filed on the connector as needed to allow it to fit properly and it finally began working 100%.

Jim KC9HI

Updated by Arno Nomad over 1 year ago

Hi Jim,
Thanks for your look at this issue.

When the cable is not attached, the error is "Radio does not respond".
When the wrong COM port is selected, the error is "Error reading data from radio: not the amount of data we want."

As the display lights up to purple during start of communications there seems to be some kind of connectivity. at least

I tried the WP970 tool from Beofeng - also here the display lights up shortly.
No full communications there as well.

So far I think the problem is at least double layered.
Mechanical and of electronic/software nature.

I have a headset with the same connector brand-new.
The wedge at the opposite of the screw is simply a bit too long.
After reducing the length with approx. 1 mm with a file the headset came to live.
Also the mic button seems to work now.

The programming cable connects to the same part connector interface as the head-set.
The programming cable has a K type connector.

With this part solved and the clue that there is some kind of communication I suspect either the UNXNOM programming cable / chip or a CP210X software issue.

Not so much fun to start with so far with all new out of the box equipment.
The cable / connector manufacturers seem to be a bit too loose with following specs.

Any thoughts appreciated.

Thx

Arno

Updated by Jim Unroe over 1 year ago

Arno Nomad wrote:

The programming cable connects to the same part connector interface as the head-set.
The programming cable has a K type connector.

This is your issue. I have a similar K type to M type adapter so that I can use a typical Kenwood style speaker/mic having a 2-pin plug with my Retevis RT6 and Baofeng UV-9R M type connection radios. These adapters only have internal connections for the speaker audio and microphone audio. They do not have the connections that are required for programming data. This means that you cannot use a K type programming cable with these adapters to program your radio. You must use a programming cable with the appropriate M type connection.

Jim KC9HI

Updated by Arno Nomad over 1 year ago

Thx for the help!

After some fiddling with a multi-meter and connectors I discovered the Adapter connector is the wrong type.
Based on the picture I found below the (Chinese) adapter seems to have the audio Mic / Speaker pins but not the RxD / TxD pins.

https://ham.stackexchange.com/questions/15172/baofeng-uv-9r-chirp-pinout
Picture also attached for the record of pin-outs.

I've ordered the official Baofeng cable now.

Cheers
Arno

Updated by Jim Unroe over 1 year ago

Arno,

Thank you for the link to the picture with the pin-outs.

Note that there are two types for Baofeng labeled programming cables with the "M" type connection.

The first type has shell that sticks out past the surface that the pins stick out of by almost the same distance as the pin do. The shell surrounds the boss on the radio that it attaches to. I found that to use this connector with my UV-9R I had to modify it in similar fashion as you described above.

The second type has a shell that is flush with the surface that the pins stick out of. This connector fit perfectly as-is. My Retevis programming cable that I received with my Retevis RT6 is like this. I recently ordered the Baofeng branded cable with the same type of "flush" connector. It should be arriving any day now. I am hoping it has the WCH CH340 USB-to-Serial chip.

I have attached pictures that show the difference between the two types.

Jim KC9HI

Updated by Bernhard Hailer over 1 year ago

  • Model affected changed from (All models) to Baofeng UV-9R+

Please let us know whether the new cable resolves your issue. Thank you!

Updated by Bernhard Hailer over 1 year ago

  • Status changed from Feedback to Closed

No more feedback by submitter

Also available in: Atom PDF