Bug #9874

Baofeng UV9R Plus Settings Blank

Added by Dan Ames about 1 month ago. Updated about 1 month ago.

Status:Closed Start date:05/13/2022
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:(All models)

Description

Hi,

I have a weird issue and would be grateful if anybody could lend me some assistance.

I have two new Baofeng UV9R Plus. They both worked perfectly when the arrived. I got into a bit of a muddle with them while programming directly. To start from a clean slate, I factory reset both of them.

One of them still works perfectly (after programming). The other one, does not transmit at all and when i change menu items directly on the radio, some of them do not persist (such as band choice).

I thought that the next thing to try would be checking settings in CHIRP to see if anything is disabled. THe problem is, for both of the radios, the settings are blank after a successful CHIRP download.

I saw another issue that indicated that there might be an issue with new settings or out of range values with certain new radios when reading settings in CHIRP. Could this be the case for me?

I have attached an IMG file that I successfully downloaded. Would somebody be able to help me view/edit settings in CHIRP?

Thanks,

Dan

Baofeng_UV-9R_20220513.img (8.2 kB) Dan Ames, 05/13/2022 08:26 am

debug.log (127 kB) Dan Ames, 05/13/2022 09:51 am

Dan Ames(UV-9R no settings tab)_Baofeng_UV-9R_20220513.img.png (48.4 kB) Jim Unroe, 05/14/2022 06:26 pm

History

Updated by Dan Ames about 1 month ago

Apologies, took me a while to find debug.log

Updated by Jim Unroe about 1 month ago

Hi Dan,

Usually this is caused by 1, 2 or possibly 3 settings being invalid/out-of-range. In your case, except where the 128 channels (0-127) are stored, the memory of your is virtually blank. See attached screen capture. The first 8 bytes of row 000007F0 is the last memory channel (channel 127). Nearly everything after this is all zeros (00). There are no settings, no channel names, no band limits. This is definitely a hardware problem. I have never see another radio that had its memory trashed in this manner. If it was my radio, I would try to get it replaced.

I assume that you have performed a menu 40 (RESET) on your radio. That would explain why there are only 2 channels programmed into your radio (0 and 127). A RESET erases all 128 channels and programs channels 0 and 127 to the firmware defaults.

If for some reason you can't return your radio for replacement, or you just want to give it a go, I would suggest that you try to program the memory using a CHIRP Radio Images (*.img) file from a similar radio model. To do this would take a special CHIRP file to do the upload. I don't have an image from a UV-9R Plus but I do have one from a plain UV-9R (no Plus, no +, no Pro, no ERA, etc). If you want to contact me direct, I can help you do this.

Jim KC9HI

Updated by Dan Ames about 1 month ago

Hi Jim,

Thank you very much indeed for your help on this. I think you have hit the nail on the head with regard to it being a hardware problem. One of the biggest warning signs for me is that memory does not seem to be persistent and values in registers can change to weird values when the power is cycled on the radio. The other warning sign was that the radio had the plastic removed and had finger prints on so I expect it was a warranty return that somehow made it into the "good" pile.

Baofeng are sticking by their product and offering me a replacement.

Apologies for posting a bug when the issue was with my radio. CHIRP is awesome, looking forward to using it in future.

All the best and thanks again,

Dan

Updated by Dan Ames about 1 month ago

Oh and you were quite correct...I couldn't view settings because some values were out of range. Annoyingly, because of the memory problem, different values were becoming out of range each time I powered the radio on!!!

Updated by Jim Unroe about 1 month ago

Dan Ames wrote:

Hi Jim,

Thank you very much indeed for your help on this. I think you have hit the nail on the head with regard to it being a hardware problem. One of the biggest warning signs for me is that memory does not seem to be persistent and values in registers can change to weird values when the power is cycled on the radio. The other warning sign was that the radio had the plastic removed and had finger prints on so I expect it was a warranty return that somehow made it into the "good" pile.

Baofeng are sticking by their product and offering me a replacement.

Apologies for posting a bug when the issue was with my radio. CHIRP is awesome, looking forward to using it in future.

All the best and thanks again,

Dan

I am glad to see that you are getting a replacement for this oddly defective radio. Hopefully the "new" one will be satisfactory.

Jim KC9HI

Updated by Jim Unroe about 1 month ago

  • Status changed from Feedback to Closed

The radio has internal memory issues. The owner is getting the radio replaced. This support ticket is now closed.

Jim KC9HI

Also available in: Atom PDF