Bug #1139

Error pulling channels from D72A

Added by Eric Christensen about 9 years ago. Updated about 9 years ago.

Status:Rejected Start date:09/18/2013
Priority:Normal Due date:
Assignee:Tom Hayward % Done:

0%

Category:-
Target version:0.4.0
Chirp Version:0.3.0 Platform:All
Model affected:D72A

Description

I just noticed that when I read my D72A I get errors on some channels. This occurs in both live and clone mode.

I'm seeing this error in the terminal window:

Job Args: (676,)
Job KWArgs: {}
Job Called from:
File "/usr/bin/chirpw", line 136, in <module>
gtk.main()
File "/usr/lib/python2.7/site-packages/chirpui/mainapp.py", line 449, in cb_clonein
self.do_open_live(radio, tempname="(" + _("Untitled") + ")")
File "/usr/lib/python2.7/site-packages/chirpui/mainapp.py", line 379, in do_open_live
eset = editorset.EditorSet(device, self, tempname=tempname)
File "/usr/lib/python2.7/site-packages/chirpui/editorset.py", line 74, in init
self.editors["memedit"] = memedit.MemoryEditor(self.rthread)
File "/usr/lib/python2.7/site-packages/chirpui/memedit.py", line 1231, in init
self.prefill()
File "/usr/lib/python2.7/site-packages/chirpui/memedit.py", line 925, in prefill
job = common.RadioJob(handler, "get_memory", i)

Exception running RadioJob: list index out of range
-- Exception: --
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/chirpui/common.py", line 97, in _execute
result = func(*self.args, **self.kwargs)
File "/usr/lib/python2.7/site-packages/chirp/thd72.py", line 284, in get_memory
mem.skip = chirp_common.SKIP_VALUES[int(flag.skip)]
IndexError: list index out of range

16.png - Screenshot showing the error (72.7 kB) Eric Christensen, 09/19/2013 06:02 pm

debug.log - Debug Log (556.2 kB) Eric Christensen, 09/19/2013 06:02 pm

error.img (64 kB) Eric Christensen, 09/19/2013 06:49 pm

fixed.img - Cleansed memory image (64 kB) Tom Hayward, 09/20/2013 07:35 am


Related issues

related to Bug #697: D72 does not scan past channel 136 Closed 03/14/2013

History

Updated by Tom Hayward about 9 years ago

  • Status changed from New to Rejected

Looks like a dupe of #697. This was fixed in 0.3.1.

Updated by Eric Christensen about 9 years ago

I'm seeing this in 0.3.1.

Updated by Eric Christensen about 9 years ago

I'm not seeing the error on the radio but rather in CHIRP, itself. It doesn't look like the same error as you pointed out (based on my quick scan of the other bug ticket).

Updated by Tom Hayward about 9 years ago

  • Status changed from Rejected to In Progress
  • Assignee set to Tom Hayward
  • Priority changed from High to Normal

I'm going to need more information. See how to report issues.

Updated by Eric Christensen about 9 years ago

1. What is the behavior you are seeing?
When reading from the radio some channels are showing up as ERROR in the frequency and none of the other channel information is displayed.

2. What is the behavior you were expecting?
For the channel information to be displayed.

3. Can you reproduce the problem all the time?
Yes.

4. What are the steps required to reproduce the problem?
Radio -> Download from Radio
Select /dev/ttyUSB0, Kenwood, D72 (Clone Mode) or (Live Mode)
Watch the channels get downloaded
Note the errors.

5. Is this specific to a certain radio model (driver) or something that you can reproduce with another radio?
Kenwood D72A
I don't have another radio to test with right now.

Updated by Tom Hayward about 9 years ago

Please save and upload the img file associated with the screenshot.

Updated by Eric Christensen about 9 years ago

What img file are you talking about?

Updated by Eric Christensen about 9 years ago

Updated by Tom Hayward about 9 years ago

  • Target version set to 0.4.0
  • Platform changed from Linux to All

Thanks for uploading the img file. Now I see the same error you see! This is very helpful.

Eric Christensen wrote:

2. What is the behavior you were expecting?
For the channel information to be displayed.

Can you elaborate here? Chirp is erroring on an unknown skip value, but I've never seen this particular value out of my TH-D72.

What is the "Lockout" value on channels 427, 514, and 515 as displayed in the radio? (menu 142)

Did you originally program these channels with Chirp, MCP-4A, or the radio itself?

Updated by Eric Christensen about 9 years ago

What is the "Lockout" value on channels 427, 514, and 515 as displayed in the radio? (menu 142)

The lockout value for 427 and 515 is just gobbly-gook. It appears as some random symbol characters. Lockout value for 514 appears normal (it is "on").

Did you originally program these channels with Chirp, MCP-4A, or the radio itself?

I programmed these channels with Chirp a while back. I'm not exactly sure what version of Chirp I used. I did keep the original .img file so I could try to reprogram the radio using that file and see if it programs the radio correctly now.

Updated by Tom Hayward about 9 years ago

  • File fixed.img added
  • Status changed from In Progress to Rejected

This is a dupe of #697. Here's a cleansed img removing the "gobbly-gook" introduced by the original Chirp bug.

Also available in: Atom PDF