Bug #10014

TYT UV-88 Settings tab blank

Added by dashie lag about 1 month ago. Updated 26 days ago.

Status:Closed Start date:08/30/2022
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:TYT UV-88

Description

I have a TYT UV-88 with the "old" CPU, firmware is reporting "MCU BQ1.46".

Gettings infos from the radio works and write for channels, but the Settings tab stays empty.

There is an traceback in the debug log (full file attached) regarding get_settings.

Tried with daily-20220823.

Also attached the .img if useful.

debug.log (262.1 kB) dashie lag, 08/30/2022 09:20 am

TYT_TH-UV88_20220830.img (8.8 kB) dashie lag, 08/30/2022 09:20 am

TYT_TH-UV88_20220830(vox_lvl_1).img (8.8 kB) Jim Unroe, 08/30/2022 04:49 pm

vox-1-to-7-img.zip (12.4 kB) dashie lag, 08/30/2022 07:51 pm

th_uv88_fix_vox_1.py (33.3 kB) Jim Unroe, 08/30/2022 08:26 pm

Associated revisions

Revision 3735:5fa6259f0668
Added by Jim Unroe 27 days ago

[TH-UV88] Fix 'VOX Level' Setting

The VOX Level setting is incorrectly implemented in CHIRP. Valid settings
programmed from the radio's keypad or using the OEM software can cause the
Settings tabs of CHIRP to not display.

This patch fixes the VOX Level setting.

Models affected: TYT TH-UV88, Retevis RT85 and their variants.

Fixes #10014

Revision 3742:b4f2a9ae219c
Added by Dan Smith 27 days ago

Fix style issues in fix for #10014

Revision 3746:d7d3e7f84270
Added by Jim Unroe 26 days ago

[TH-UV88] Driver Cleanup

This patch removes some commented lines that were supposed to have been
removed in the previous patch.

fixes #10014

History

Updated by Jim Unroe about 1 month ago

This usually happens when 1 or more settings in the radio are out-of-range. In this case the VOX Level setting is set to 0 and CHIRP only expects/supports values from 1 to 7.

This could be do to TYT updating the radios to include a 0 (or OFF) choice to the VOX Level setting. It could also be a bug in the CHIRP programming that took this long for someone to discover.

You could probably fix this yourself by changing the VOX Level setting to a different value using the radio's built-in menus. Once the VOX Level value is changed in the radio, download the change into CHIRP and see if the Settings tab will now be displayed.

Another "fix" would be to use the CHIRP Radio Images (*.img) file that I have attached. It is a duplicate of the "image" that you attached with the VOX Level changed to 1. Load it into CHIRP and then change the VOX Level to whatever value you would like it to be and then upload it to your radio.

Jim KC9HI

Updated by dashie lag about 1 month ago

Thanks for the modified file, it worked as expected, and reading again from radio too.

I have checked a bit more about the VOX Level.
1 in the radio menu cause blank settings tab
2 too
3 is shown as 1 in chirp
4 as 2
7 as 5

looks like they might have changed something, or a bug somewhere. as long as the VOX level is >=3 reading settings is ok.

Updated by Jim Unroe about 1 month ago

dashie lag wrote:

Thanks for the modified file, it worked as expected, and reading again from radio too.

I have checked a bit more about the VOX Level.
1 in the radio menu cause blank settings tab
2 too
3 is shown as 1 in chirp
4 as 2
7 as 5

looks like they might have changed something, or a bug somewhere. as long as the VOX level is >=3 reading settings is ok.

Nice detective work. Would you mind creating 7 "image" files and attaching them to this issue. One for each of the radio's VOX Level setting. I don't have a TYT TH-UV88 here, but I do have the Retevis equivalent radio that I can compare them to. That would help with figuring out if it was a change in the radio or a bug in CHIRP.

Thanks in advance,
Jim KC9HI

Updated by dashie lag about 1 month ago

Here are the 7 in a zip archive for less mess with the attachments.
They all corresponds to the level in the radio menu.

Updated by Jim Unroe about 1 month ago

  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily
  • Platform changed from Linux to All

dashie lag wrote:

Here are the 7 in a zip archive for less mess with the attachments.
They all corresponds to the level in the radio menu.

Thanks. Found the bug. Standby.

Jim KC9HI

Updated by Jim Unroe about 1 month ago

Please test this custom driver module to see if it works for your TYT TH-UV88. It works for my Retevis RT85.

Here is how you use the custom driver module.
  1. save the custom driver module to a convenient location (DO NOT RIGHT-CLICK THE LINK. Left-click the link and then on the page that loads, left-click the download link near the top left corner.)
  2. click Help
  3. enable Enable Developer Functions
  4. click File
  5. click Load Module
  6. locate and load custom driver module that was saved in step 1

The CHIRP background will now be red to indicate it is running with a externally loaded driver module. You can now test the custom driver module.

Note: The test driver module does not permanently change your CHIRP installation in any way. Every time you load CHIRP you must load this driver module to have access to its fixes or added features.

Jim KC9HI

Updated by dashie lag about 1 month ago

I have changed vox level to 1 and download from radio is OK.
Tried 4 or 5 times by changing from chirp or the radio and everything looks ok!

Thanks for the fix !

Updated by Jim Unroe about 1 month ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

A patch has been submitted. Support will be in the next CHIRP daily build following acceptance.

Jim KC9HI

Updated by Anonymous 27 days ago

  • Status changed from Resolved to Closed

Applied in changeset 5fa6259f0668.

Updated by Jim Unroe 27 days ago

  • Status changed from Closed to In Progress

Re-opened in order to perform some overlooked cleanup.

Jim KC9HI

Updated by Jim Unroe 27 days ago

  • Status changed from In Progress to Resolved

Some stray comments were removed. Patch submitted.

Jim KC9HI

Updated by Anonymous 26 days ago

  • Status changed from Resolved to Closed

Applied in changeset d7d3e7f84270.

Also available in: Atom PDF