Project

General

Profile

Actions

Bug #10664

closed

[errno 2] could not open port Help me. ...

Added by Mike Wittek 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/21/2023
Due date:
% Done:

100%

Estimated time:
Chirp Version:
next
Model affected:
Yeasu FT-65R
Platform:
Linux
Debug Log:
I read the instructions above:

Description

I have been trying to download the information off my Yaesu FT-65R, since I don't know what port to use, I use the HELP ME function. When I do I get the following error:
[errno 2] could not open port Help me....[Errno 2] No such file or directory:Help Me...
I have checked the internet, and found this to be a Python error code.

Now according to your website you support the FT-65R, and I followed the install instruction for Linux. When I ran the LSUSB command in the CLI I found the cable that I wad using:
Bus 001 Device 011: ID 2100:9055 RT Systems CT55 Radio Cable

I have supplied my system info below to help things along.
*OS: Ubuntu MATE 22.04.2 LTS x86_64
Kernel: 5.15.0-73-generic
Uptime: 5 hours, 59 mins
Packages: 3030 (dpkg), 29 (snap)
Shell: bash 5.1.16
Resolution: 1920x1080, 1920x1080
DE: MATE 1.26.0
WM: Metacity (Marco)
Theme: Yaru-blue-dark [GTK2/3]
Icons: Yaru-blue-dark [GTK2/3]
Terminal: mate-terminal
Terminal Font: Monospace 12
CPU: 11th Gen Intel i9-11900K (16) @
GPU: AMD ATI Radeon RX 470/480/570/5
Memory: 3592MiB / 31942MiB
*

Any suggestion would be helpful. I am not sure how to find ports for Linux nor fix Python. Thanks for your time.

Mike W.
Meridian, Idaho


Files

debug.log (6.04 KB) debug.log Mike Wittek, 06/21/2023 09:02 PM
debug.log (2.82 KB) debug.log Requested debug.log file Mike Wittek, 06/21/2023 09:16 PM
kernel.log (248 KB) kernel.log Requested kernel.log file Mike Wittek, 06/21/2023 09:32 PM
Actions #1

Updated by Dan Smith 6 months ago

  • Assignee set to Dan Smith
  • Target version set to chirp-py3

Need a debug log Mike. That error is definitely a problem in CHIRP (which means we can fix it) but a debug log is needed. See How_To_Report_Issues . If you're running from the command line, run with --log debug.log and attach that file.

Actions #2

Updated by Dan Smith 6 months ago

Ah, Mike I think I see the problem. I still want to see a debug log, but I think the problem is that it wasn't able to determine your port and then didn't clean up. Did it say "Unable to determine port" as the last step? If that's the case, you might need to find the port in a different way. Also, RTSystems cables are sometimes not compatible with non-RTSystems software without reprogramming the firmware in the cable. I'd definitely recommend a generic cable instead of that one, but I suspect that's the problem.

In your port box, do you have only "Custom" and "Help Me" options? If so, that's almost definitely the problem - that your RTSystems cable isn't actually exposing a port.

Actions #3

Updated by Dan Smith 6 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
Actions #4

Updated by Mike Wittek 6 months ago

Hello Mr. Dan Smith,
I have attached the DEBUG.LOG to this ticket for your perusel. Does it backup your belief as to the cable issue?

Actions #5

Updated by Dan Smith 6 months ago

Yes, it looks like I would expect if the cable does not expose a serial port. Note that I've fixed (for tomorrow) the bug that causes it to give you a cryptic error message. However, that won't fix your actual problem, of course.

I can give you a more definitive answer if you do the following:

  1. Unplug your cable
  2. Plug in your cable
  3. Immediately run journalctl -k > kernel.log

Attach the kernel log and I can tell you for sure.

Actions #6

Updated by Mike Wittek 6 months ago

Hello Dan,

the answer to your question is yes, I only had the choice between "Custom..." and "Help Me..." on the Port drop down menu. When I do follow the "Help Me..." option the next error in the USP Port Finder window comes up with the error "Unable to determine port for your cable. Check your drivers and connections." Once I try to do the option again, I get the [errno 2] could not open port Help me....[Errno 2] No such file or directory:Help Me... error. Once you look over my debug.log, and since you stated it is my cable is the issue, and get another "generic cable". Where can I purchase one generic cables for my Yaesu FT-65R and an old Baofeng UV-5R?

Thanks Again,
Mike W.
Meridian, ID

Actions #7

Updated by Mike Wittek 6 months ago

Here is the kernel.log you requested.

Actions #8

Updated by Dan Smith 6 months ago

Hi Mike,

Yep your kernel log confirms it: no serial port from that cable. You could ask on the mailing list, but if you're willing to get a different cable that will absolutely be easier. I recommend cables from https://bluemax49ers.com/ . They have a cable finder, they use top-quality USB chips, and they will make sure you get sorted.

Actions #9

Updated by Mike Wittek 6 months ago

Hey Dan,
Thanks for your help, and the information on the cable company. I am going to purchase a couple of new cables. You can close this ticket.

--
Thanks,
Mike W.
Meridian, ID

Actions

Also available in: Atom PDF