Bug #1859

Wouxun KG-UV2D Radio not responding

Added by Robin Marks almost 6 years ago. Updated about 1 month ago.

Status:Closed Start date:08/22/2014
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Linux
Model affected:Wouxun KG-UV2D

Description

In the "front page" list of supported radios, the KG-UV2D is listed as supported along side the KG-UVD1P.

Chirp will read/write to a UVD1P without issue. However, the KG-UV2D fails with the message "Failed to communicate with radio: Radio Not Responding".

It should be noted, the KG-UV2D is readable using Linux based "owx" tool, which should eliminate the radio itself as part of the equation.

This radio, the KG-UV2D, is (generally) identical to the KG-UVD1P and as listed, again, on the front page in supported radios, shown as "KG-UVD1P/UV2D/UV3D". However, it is not specifically listed in the software menu. The selection of the KG-UVD1P was tried with the assumption of a like model, based on how the radio was listed as supported by Chirp.

OS:
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

Software:
Chirp 0.4.0
GTK 2.24.23
PyGTK 2.24.0
Python 2.7.6

Is this model simply not yet supported in the Linux Release?

debug.log (11.7 kB) Robin Marks, 08/22/2014 03:03 pm

debug.log (5.3 kB) Robin Marks, 08/23/2014 09:58 am

History

Updated by Robin Marks almost 6 years ago

As Per Requested, attached debug.log

Updated by Jens Jensen almost 6 years ago

Hi Robin,
I see some editing of the radio settings, but I do not see any attempts to upload in that debug.log.

Can you please provide a debug.log of the session where you are only doing the following two things:
1. download image from radio
2. upload same image back to radio

Updated by Robin Marks almost 6 years ago

OK, I think perhaps we need to ensure we are on the "same page".

There are two radios involved here. The first one, a working KG-UVD1P, for which the software is performing flawlessly. My "control radio" for the testing.

And...

The second radio, a working KG-UV2D, for which I am experiencing the problems with Chirp.

To that point, I am assuming you wish for me to attempt to download the image for that radio. I will do this, and it will fail. As such, there will not be any image for me to then attempt to upload back to the radio. Also, please again note that I can/have only selected in the software, the KG-UVD1P radio, as there is no selection for a KG-UB2D, as per my original posting.

Attached is the latest debug.log file for that read attempt, which as expected, failed. However, debug.log does appear to indicate the failure.

Hopefully, this will help. :)

Updated by Bernhard Hailer 3 months ago

  • Tracker changed from New Model to Bug
  • Subject changed from Wouxun KG-UV2D Supported? to Wouxun KG-UV2D Radio not responding
  • Status changed from New to Feedback
  • Target version set to chirp-daily
  • Chirp Version changed from 0.4.0 to daily
  • Model affected set to Wouxun KG-UV2D
  • Platform set to Linux

Have you been able to resolve this on your own since you submitted this?

This looks like a cable / driver / connector issue. Please refer to these Wiki articles:
CableGuide
CableGuide FTDI OEM Cables

Linux notes: Linux generally is quite good with USB to Serial converter drivers. Therefore I would focus on electrical contact integrity (connector fully inserted, etc.)

Updated by Bernhard Hailer about 1 month ago

  • Status changed from Feedback to Closed

No more feedback by submitter.

Also available in: Atom PDF

prevent spam