Project

General

Profile

Actions

Bug #209

open

need py27-suds for osx

Added by Rob Walker over 11 years ago. Updated over 3 years ago.

Status:
Blocked
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/08/2012
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
(All models)
Platform:
MacOS
Debug Log:
I read the instructions above:

Description

I am using the daily build from 2012.06.08 on OSX.

When I try to use the radioreference.com importer, I get the following error:

"

Suds library required for RadioReference.com import. Try installing your distribution's python-suds package.

"

I suspect that this error message would make perfect sense, and would be easy to fix, if I were using an awesome OS, like linux. However, I am stuck on OSX for now. :-) I am using the kk7ds python package, and even though I have done "[617]rwalker@a:~$ sudo port install py27-suds" , I continue to get the same error from chirp. Maybe chirp could point to my local python27 install instead?

Thanks,
Rob


Files

CHIRP-suds.zip (465 KB) CHIRP-suds.zip Files needed to add suds to the CHIRP unified build Barry Nelson, 04/20/2020 01:34 PM
Screen Shot 2020-04-20 at 4.27.10 PM.png (53.1 KB) Screen Shot 2020-04-20 at 4.27.10 PM.png Premium account required? Barry Nelson, 04/20/2020 01:34 PM

Related issues

Related to Bug #4801: Suds library required for RadioReference.comFeedback05/07/2017

Actions
Has duplicate Bug #491: RR.com import error - SUDS needed? (on Mountain Lion)Rejected02/03/2013

Actions
Has duplicate Bug #1929: Query Data Source RadioReference Rejected09/23/2014

Actions
Actions #1

Updated by Rob Walker over 11 years ago

I think I may have solved this.

cd
mkdir src
cd src
wget https://fedorahosted.org/releases/s/u/suds/python-suds-0.4.1.tar.gz
tar -zxvf python-suds-0.4.1.tar.gz
cd python-suds-0.4.1
sudo /opt/kk7ds/bin/python2.7 ./setup.py install

restart chirp
get new error about not being a premium subscriber at radioreference.com :-)

Actions #2

Updated by Tom Hayward over 11 years ago

  • Status changed from New to Blocked

I'm glad you found a workaround. The plan was to eventually include suds in the Python Runtime distribution. The new plan is to replace the Python Runtime with a solution that will use the system's python. Once this is implemented, installing suds normally (like with port install py27-suds) will work.

Actions #3

Updated by Sean Petrow over 9 years ago

Here's what I did to get this working without building it myself, if anyone else runs into this:

Context: since the KK7DS python runtime gets installed to /opt/kk7ds on my machine, I was thinking that I could just copy my suds module over and it would work, since I installed Python 2.7 as a system framework in OSX 10.7.5 ( http://wolfpaulus.com/jounal/mac/installing_python_osx/ has info if you're interested in doing this), and it did.

sudo pip install --install-option="--prefix=/opt/kk7ds" suds

(note that I'm using Python 2.7.8)

Here's a more manual way if you already have suds installed for Python 2.7:

cd /opt/kk7ds/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages
cp -R /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/suds ./  # note the difference in /System vs /opt/kk7ds
# Quit and re-launch CHIRP

+1 for a solution that can use system python and fail back to the custom runtime if required, and thanks for the very helpful software :)

Actions #4

Updated by Joe chiarelli over 5 years ago

This helped me thanks

Actions #5

Updated by Barry Nelson over 3 years ago

I have attached a zip file, I believe if these files are added to the unified CHIR build for OS X it should fix this issue, but I have not been able to fully test since the import feature seems to require a premium account.

Actions #6

Updated by Barry Nelson over 3 years ago

Ok, radioreference granted me premium access so I could resolve this issue, and I was able to connect successfully after adding the extra files in the previously attached zip file were added to the package.

Actions #7

Updated by Bernhard Hailer over 3 years ago

Looks like we can close this issue?

Actions #8

Updated by Barry Nelson over 3 years ago

Do not close it yet. I just tested the most recent Mac package and it is still missing the suds python package. I have sent another email to Dan Smith with the files that need to be included asking him to please include it by default. Once it is fixed in the default Mac build then we can close this.

Actions #9

Updated by Barry Nelson over 3 years ago

This is STILL not fixed in the latest build, which I just tested, even though I attached a fix to this thread a month ago! Who can I contact to get this added??

Actions #10

Updated by Bernhard Hailer over 3 years ago

  • Target version set to chirp-legacy

Barry, thanks for working on this! You might want to join the developers mailing list as described in Developers and push it there.

Actions

Also available in: Atom PDF