Project

General

Profile

Actions

Bug #27

closed

Kenwood auto-detect only supports 9600 baud

Added by kelsey hudson about 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
11/13/2011
Due date:
% Done:

0%

Estimated time:
Chirp Version:
0.1.12
Model affected:
Kenwood (TM-V71)
Platform:
Windows

Description

The Kenwood auto-detect feature only supports 9600 baud communications between the radio and CHIRP. Setting the radio to a higher speed will result in CHIRP hanging indefinitely while trying to communicate with the radio. Verified with two radios, both TM-V71.

Serial port speed should be a user-selectable feature as baud rate is problematic to determine automatically.

Actions #1

Updated by kelsey hudson about 11 years ago

Platform is OS X, not windows. (oops!)

Actions #2

Updated by Dan Smith about 11 years ago

The autobaud routine has worked well in the past, and I don't plan to remove it. Kenwood radios are the only ones that support different speeds, and thus the UI has no need or provision to support choosing a baudrate. I will take a look at this and figure out what's going on.

Thanks!

Actions #3

Updated by Dan Smith about 11 years ago

Hi,

Sorry for the delay in looking at this. I just tried with the latest code on my D700 and the autobaud routine seems to work just fine. Have you tried the latest daily development version (at the bottom of the downloads page)? If not, could you please?

If you're still seeing this, then I'll try to get access to a V71 and re-test although I don't see why it would be any different.

Thanks!

Actions #4

Updated by kelsey hudson about 11 years ago

OK - I'll give that a shot tonight and let you know how it goes.

As a side note, if it doesn't fix my problem I could probably just box up one of mine and send it to you if you think that'd help - as long as I get it back at some point! :)

Actions #5

Updated by Dan Smith about 11 years ago

Thanks for the offer, but there is one at my local fire station that I have access to, it's just not within reach of my development desk. If you can still reproduce it on the current build then I'll just go sit at the station for a bit and futz with it.

Thanks!

Actions #6

Updated by kelsey hudson about 11 years ago

The latest daily build as of the 18th still doesn't function properly. In fact, it doesn't even work at 9600 baud now, either. It appears to autodetect the radio only at 9600 baud, but doesn't proceed with downloading any memories. At baud rates other than 9600, when clicking, 'OK,' chirp hangs indefinitely.

I've tried this with two serial converters, one a Keyspan USA-49WG and the other a USA-19HS.

Actions #7

Updated by Dan Smith almost 11 years ago

Okay, sorry this took me so long to resolve. I finally got the fire station and used the V71 there. It was quickly apparent what the problem was. I've fixed it up and the result will be in tomorrow's daily build. If you could please confirm and report back here so we can close the bug, I'd appreciate it.

Thanks!

Actions #8

Updated by Dan Smith almost 11 years ago

  • Status changed from New to Closed
  • Target version set to 0.2.0

Marking this as done in r1321. Please re-open if there are any issues.

Actions

Also available in: Atom PDF