Project

General

Profile

Actions

Bug #45

closed

FT-8900R Upload memory issue

Added by Fabio Rusconi IZ2QDH about 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
01/09/2012
Due date:
% Done:

0%

Estimated time:
Chirp Version:
0.1.12
Model affected:
(All models)
Platform:
Windows

Description

Does not upload memories to Yaesu FT8900R with the "stable" version.
Using latest dev build it works but some memories' names are not copied.


Files

debug_FAILED.log (1.3 KB) debug_FAILED.log Fabio Rusconi IZ2QDH, 01/09/2012 01:49 AM
FT8900_-_BEFORE.img (14.4 KB) FT8900_-_BEFORE.img Fabio Rusconi IZ2QDH, 02/16/2012 02:25 AM
FT8900_-_AFTER.img (14.4 KB) FT8900_-_AFTER.img Fabio Rusconi IZ2QDH, 02/16/2012 02:25 AM
Actions #1

Updated by Fabio Rusconi IZ2QDH about 11 years ago

Debug log of failed memory upload

Actions #2

Updated by Dan Smith almost 11 years ago

  • Status changed from New to Feedback

I believe that over email, we tracked this down to programming the name, but not enabling the flag to show it. I really thought this was fixed and confirmed with another user. Can you confirm that indeed some memories are not having their name properly enabled?

Can you:

  1. Please send me some sample images
  2. Please send me before/after images where you turn the name on and off (and make no other changes)

Thanks!

Actions #3

Updated by Fabio Rusconi IZ2QDH almost 11 years ago

Hi Dan,
except that 2 times out 3 the clone process ends in "Error" i've made a video to show the name issue better than photos.
Sorry for my voice...i hope it will explain!
Video Link (Youtube): http://www.youtube.com/watch?v=vebf9K48zuo

Actions #4

Updated by Dan Smith almost 11 years ago

Hi Fabio,

Thanks for the video, I think that helped.

Can you upload an image from chirp to the radio that has the problem, then "fix" one of the memories that doesn't properly show the name, and then immediately download an image from the radio? If you send me those two images (before/after) then I can try to figure out what the problem is.

Also, which hypermemory do you have active on the radio?

Thanks!

Actions #5

Updated by Fabio Rusconi IZ2QDH almost 11 years ago

Hi Dan,
i've done what you've asked, here are the BEFORE image (the one that i've uploaded) and the AFTER image (the one that i've downloaded after having fixed the names).
Hypermemories: i don't program them with CHIRP, after i've uploaded the image i program the HyMs i program them directly from the front panel.

Actions #6

Updated by Dan Smith almost 11 years ago

Fabio,

Thanks for the images. It's easier for me to see what changed if you only fix one memory at a time. However, I'll take a look at them later and see what I can figure out.

Also, can you try today's daily build to see if it makes the upload process more reliable?

Thanks!

Actions #7

Updated by Dan Smith almost 11 years ago

Hi Fabio,

I know you have something else very important to work on right now, so please focus on that and only read this after you're done! :)

I think the problem you are experiencing is related to the fact that you created the image with 0.1.12, which had a bug in the ft8900 driver. That bug caused the behavior you're seeing. Just opening that image with the new development version of chirp and uploading to the radio will not correct the things that the old version did incorrectly. I have tested with your images and the current version and I believe it is doing the right thing. So, if I am correct, I think we just need to fix your existing image. To do that:

  1. Open your image (for example, the "before" image above)
  2. Import that same image into itself (File->Import, choose the same image)
  3. Make sure all the memories are selected in the import window
  4. Click OK to do the import
  5. Upload to the radio

Please let me know if that sets the names properly. Looking at the image, I think it should.

Thanks and good luck!

Actions #8

Updated by Fabio Rusconi IZ2QDH almost 11 years ago

Hi Dan,
GREAT NEWS! I've installed the latest dev build (February 25th) and it uploaded the memories at FIRST ATTEMPT! And there's no problems with the names!

Actions #9

Updated by Dan Smith almost 11 years ago

  • Status changed from Feedback to Closed
  • Target version set to 0.2.0

Great, glad to hear it :)

I'll close this bug. Thanks for your help!

Actions

Also available in: Atom PDF