Project

General

Profile

Actions

Bug #49

closed

Kenwood TM-V7 - cannot upload channel

Added by David Hagood about 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
01/28/2012
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
Kenwood TM-V7
Platform:
Linux

Description

I can download the radio's data, but when I attempt to change a channel (or create a new channel), the radio refuses it.

Steps to reproduce:
1) Connect radio
2) Start chirp
3) Download from radio. Select appropriate serial port (/dev/ttyUSB0) and type (Kenwood, auto-detect).
4) Modify a channel, e.g. change from no tone to 103.5 Hz tone
Expected results:
Radio updates
Actual results:
Radio refuses the channel update.
5) Attempt to create a new channel in a blank location: set frequency to 146.000
Expected results:
Radio updates
Actual results:
Radio refuses the channel update.

Reproducability: every time.


Files

chirp.config (730 Bytes) chirp.config Chirp config David Hagood, 01/28/2012 02:33 PM
chirp.log (12 KB) chirp.log Log of session demonstrating the issue David Hagood, 01/28/2012 02:33 PM
chirp.log (14.4 KB) chirp.log David Hagood, 01/28/2012 02:37 PM
Actions #1

Updated by David Hagood about 11 years ago

Whoops, didn't actually demonstrate the issue. uploading new file.

Actions #2

Updated by David Hagood about 11 years ago

It looks like the memory write command is not correct:

PC->D7: MW 0,0,012,012,00146000000,0,0,0,0,0,0,09,000,09,,0
It looks like the channel # is being given twice.

Actions #3

Updated by David Hagood about 11 years ago

Yes, the problem is in the class for the Kenwood V7 Radio:

class TMV7Radio(KenwoodLiveRadio):
MODEL = "TM-V7"

def _make_mem_spec(self, mem):
    spec = ( \
        "%011i" % mem.freq,
        "%X" % STEPS.index(mem.tuning_step),
        "%i" % rev(DUPLEX, mem.duplex),

Remove the redundant mem.number, and all is well.

Actions #4

Updated by Dan Smith about 11 years ago

Okay, thanks for tracking that down. Can you verify that tomorrow's build is correct before we close this?

Thanks!

Actions #5

Updated by Dan Smith almost 11 years ago

  • Status changed from New to Closed
Actions #6

Updated by Dan Smith almost 11 years ago

  • Target version set to 0.2.0
Actions

Also available in: Atom PDF