Bug #5781

CHIRP won't start in windows xp SP3

Added by Tom McCullough 7 months ago. Updated 7 months ago.

Status:Rejected Start date:05/09/2018
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:0.4.1
Chirp Version:daily Platform:Windows
Model affected:windows XP SP3

Description

After multiple tries to install CHIRP on windows XP SP3 laptop, chirpw.exe gives this message after application launch.

"This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."

I have uninstalled chirp and made sure there were no config files on the hard drive. All files were uninstalled including directory. Reinstalled and launched program with identical results.

I thought program was supposed to be compatible with windows XP?

Hope someone can provide advise on how to make program work.

History

Updated by Dan Smith 7 months ago

  • Status changed from New to Feedback

CHIRP works fine on XP, and in fact the exe you're using is built daily on XP.

The error message you post is not a CHIRP one, but comes from Windows itself. I don't know what it means, but it doesn't have anything to do with CHIRP's configuration (and I doubt it has anything to do with re-installing).

Please make sure you're downloading from this website (there are other counterfeit/malicious websites out there attempting to get chirp users to download from their site instead). You might also try the .zip (assuming you're trying the installer now) or vice versa.

Either way, I'm not sure what else to do to help you -- lots of people run it on XP without an issue. You might try posting on the mailing list as there are a lot of windows users there that may know more about what windows is trying to tell you.

Updated by Tom McCullough 7 months ago

After a few more hours of research I found some help on the BaoFeng web site. https://baofengtech.com/download

"Windows XP users may need to follow the instructions here if you have trouble starting CHIRP."

It appears that Windows XP SP3 was missing some drivers. See the information below:

I get "application configuration is incorrect" when I try to run CHIRP
The full error message as seen by the user is: "Application cannot run because application configuration is incorrect"
This is a problem with your Windows XP machine and its standard libraries. Most users seem to be able to resolve this issue by downloading the Microsoft Visual C++ 2008 SP1 Redistributable Package.
If the above does not help you, Google for this error message and you will find many such problem reports with myriad other applications, as well as suggested fixes, depending on what the root cause of your problem is.

After installation of the Visual C++ software CHIRP actually works with Windows XP SP3.

Updated by Dan Smith 7 months ago

  • Status changed from Feedback to Rejected

Ah, if I had seen the full error it would have jogged my memory and remembered we have this in our FAQ:

https://chirp.danplanet.com/projects/chirp/wiki/FAQ#I-get-application-configuration-is-incorrect-when-I-try-to-run-CHIRP

Sorry about that :)

I'm going to close this since it's known and not really a chirp bug.

Thanks!

Also available in: Atom PDF