Bug #6579

CHIRP can no longer import from Repeaterbook.com

Added by Garrett Dow over 3 years ago. Updated over 3 years ago.

Status:Rejected Start date:03/08/2019
Priority:Urgent Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:(All models)

Description

Repeaterbook.com recently added CloudFlare CDN and that has broken importing from CHIRP. I have tried to do what I can on my side, even disabling the web application firewall (WAF) and creating a rule to ignore the WAF rules when accessing chirp.php, but to no avail. It appears that CloudFlare is blocking CHIRP due to the browser-type (default Python). CloudFlare is seeing this as a hack attempt.

The owner of this website (www.repeaterbook.com) has banned your access based on your browser's signature (4b2e67c69a3f39be-ua48).

I believe the user-agent is going to need to be changed to make it work again. I know nothing about Python, but stackoverflow suggests using Request_add_header. You can also pass the headers as a dictionary when creating the Request itself, as the docs note:

headers should be a dictionary, and will be treated as if add_header() was called with each key and value as arguments. This is often used to “spoof” the User-Agent header, which is used by a browser to identify itself – some HTTP servers only allow requests coming from common browsers as opposed to scripts. For example, Mozilla Firefox may identify itself as "Mozilla/5.0 (X11; U; Linux i686) Gecko/20071127 Firefox/2.0.0.11", while urllib2‘s default user agent string is "Python-urllib/2.6" (on Python 2.6).


Related issues

related to Bug #6563: cannot import from data source - repeaterbook Closed 03/03/2019

History

Updated by Dan Smith over 3 years ago

  • Status changed from New to Rejected

Closing as dupe of an already-open issue.

Also available in: Atom PDF