Project

General

Profile

Actions

Bug #6655

closed

Unable to connect/download data from Icom IC-91AD

Added by Jeff Lane over 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
03/30/2019
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
Icom IC-91AD
Platform:
Windows

Description

I used Chirp before to program my IC-91AD but I had to rebuild my VM running Ubuntu and so I've re-installed the latest Chirp and cannot connect my IC-91AD now. I select "Download from Radio" and configure it for /dev/ttyUSB0, Make=Icom. If I leave Model at Detect, I get this traceback:

ERROR: --- Exception Dialog: 'Serial' object has no attribute 'setBaudrate' ---
ERROR: Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/chirp/ui/clone.py", line 175, in run
cs.radio_class = detect.DETECT_FUNCTIONSvendor
File "/usr/lib/python2.7/dist-packages/chirp/detect.py", line 76, in detect_icom_radio
result = _detect_icom_radio(ser)
File "/usr/lib/python2.7/dist-packages/chirp/detect.py", line 42, in _detect_icom_radio
ser.setBaudrate(9600)
AttributeError: 'Serial' object has no attribute 'setBaudrate'

ERROR: ----------------------------

And if I set the model to IC-91AD I get a completely different traceback:

Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/chirp/ui/mainapp.py", line 1406, in mh
self.do_download(*args)
File "/usr/lib/python2.7/dist-packages/chirp/ui/mainapp.py", line 679, in do_download
radio = settings.radio_class(ser)
File "/usr/lib/python2.7/dist-packages/chirp/drivers/ic9x.py", line 103, in init
self.pipe.setTimeout(0.1)
AttributeError: 'Serial' object has no attribute 'setTimeout'

but no data is downloaded from the radio.

I edited the file and commented out the setTimeout lines from the traceback and this time it seemed to at least talk to the radio but dumped a bunch of errors like this when reading the memory:
`ERROR: ----------------
ERROR: Job Args: (774,)
ERROR: Job KWArgs: {}
ERROR: Job Called from:
File "/usr/bin/chirpw", line 145, in
gtk.main()
File "/usr/lib/python2.7/dist-packages/chirp/ui/mainapp.py", line 1406, in mh
self.do_download(*args)
File "/usr/lib/python2.7/dist-packages/chirp/ui/mainapp.py", line 687, in do_download
self.do_open_live(radio)
File "/usr/lib/python2.7/dist-packages/chirp/ui/mainapp.py", line 406, in do_open_live
eset = editorset.EditorSet(radio, self, tempname=tempname)
File "/usr/lib/python2.7/dist-packages/chirp/ui/editorset.py", line 143, in init
self.make_device_editors(device, devrthread, index)
File "/usr/lib/python2.7/dist-packages/chirp/ui/editorset.py", line 78, in _make_device_editors
memories = memedit.MemoryEditor(devrthread)
File "/usr/lib/python2.7/dist-packages/chirp/ui/memedit.py", line 1383, in __init
_
job = common.RadioJob(None, "get_memory", i)

ERROR: Exception running RadioJob: 'Serial' object has no attribute 'getBaudrate'

The version I have installed from the Ubuntu PPA:
bladernr@arcadiaVM:~$ chirpw --version
CHIRP daily-20160110 on Linux - Ubuntu 16.04.6 LTS (Python 2.7.12)


Related issues

Is duplicate of Bug #3847: IC92AD - ErrorsFeedback07/19/2016

Actions
Actions #1

Updated by Jeff Lane over 3 years ago

This only seems to be an issue with Linux. I also downloaded the daily for OSX and that one works OK with my IC-91AD.

Actions #2

Updated by Bernhard Hailer about 2 years ago

  • Status changed from New to Closed
  • Priority changed from High to Normal
  • Model affected changed from IC-91AD to Icom IC-91AD

Duplicates #3847. Please follow and post there. Thanks!

Actions

Also available in: Atom PDF