Project

General

Profile

Actions

New Model #6701

closed

TYT MD-9600 (= Retevis RT90)

Added by Richard Benfatto over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/12/2019
Due date:
% Done:

0%

Estimated time:
Equipment Loan/Gift Offered:
No
I read the instructions above:

Description

Retevis radios are made by TYT and re bdged


Related issues

Is duplicate of New Model #5811: Retevis RT90Feedback05/18/201807/31/2018

Actions
Actions #1

Updated by Bernhard Hailer about 4 years ago

  • Subject changed from TYT MD9600 (Same as retevis RT 90) to TYT MD-9600 (= Retevis RT90)
  • Target version set to chirp-legacy
Actions #2

Updated by Bernhard Hailer almost 4 years ago

  • Status changed from New to Closed

Duplicates #5811. Please follow and post there. Thanks!

Actions

Also available in: Atom PDF