Bug #6705

mac 'The application "chirp-daily-20190412.app" can't be opened'

Added by Jim DeLaHunt almost 2 years ago. Updated 11 months ago.

Status:Closed Start date:04/13/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:MacOS
Model affected:(All models)

Description

chirp-daily-20190412.app, freshly installed on Mac OS X 10.11.5, was refusing to run. Finder showed an alert reading, 'The application "chirp-daily-20190412.app" can't be opened'.

This is a different problem than Mac OS Application Security as described in <https://chirp.danplanet.com/projects/chirp/wiki/MacOS_Tips#Application-Security-in-109x>. I was right-clicking on the application, selecting "Open" from the pop-up menu, and then the failure alert appeared. Past versions of chirp have opened fine on this particular machine and OS with this method.

I worked around the problem by setting the "execute" file mode on /Applications/chirp-daily-20190412.app/Contents/MacOS/chirp. I did this from the Terminal, with the commands:

sudo chmod a+x /Applications/chirp-daily-20190412.app/Contents/MacOS/chirp

(Mac OS asks me to enter my administrator password.)
/Applications/chirp-daily-20190412.app/Contents/MacOS/chirp

The chirp app runs. I quit the app.

Then, I repeated right-clicking on the application, selecting "Open" from the pop-up menu. This time Chirp started up.

Interestingly, once I got Finder to start chirp successfully once, it didn't matter if I reset the "execute" mode on the /Applications/chirp-daily-20190412.app/Contents/MacOS/chirp file. The app still runs. However, I will observe that four earlier daily versions of chirp had the "execute" mode set on that MacOS/chirp file.

History

Updated by Bernhard Hailer 11 months ago

  • Status changed from New to Feedback
  • Target version set to chirp-daily

It looks like you were able to resolve this on your own.
Have you seen this with newer versions of Chirp again? Thanks.

Updated by Jim DeLaHunt 11 months ago

Thank you for checking in. I had not tried a new version of Chirp until you reminded me just now.

I was able to Chirp.app from chirp-unified-daily-20200430.app.zip in the expected way. The alert, 'The application "chirp….app" can't be opened' did not appear. I had upgraded to macOS High Sierra 10.13.6, since I filed the above report, for what it's worth.

I suspect the problem was an isolated build problem, and that this issue can be safely closed.

Updated by Bernhard Hailer 11 months ago

  • Status changed from Feedback to Closed

Thanks for your feedback!

Also available in: Atom PDF