Feature #6761

FT-4XR, 4/29/2019 version of CHIRP

Added by David Behar over 1 year ago. Updated 7 months ago.

Status:Closed Start date:05/01/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Model affected:Yaesu FT-4XR

Description

Note that the receive range for all versions of this radio is 65-108 MHz, 136-174 MHz, and 400-480 MHz. This build seems to only accommodate receive (and transmit) frequencies in the U.S. transmit range (144-148 MHz, 430-450 MHz).

Also, this radio has three versions: Asian, European, and USA. MARS members (like myself) use the Asian version, which transmits 136-174 MHz and 400-480 MHz. It would be nice if transmit frequencies for any of the three versions could be accommodated in CHIRP.

The following Yaesu link (numbered page 30, PDF page 32) shows the frequency ranges of the various versions of this radio: http://www.yaesu.com/downloadFile.cfm?FileID=14688&FileCatID=151&FileName=FT%2D4XR%5FXE%5FOM%5FENG%5FEH069M201%5F1805M%2DBC.pdf&FileContentType=application%2Fpdf

FT-4X Frequency Coverage.pdf - Yaesu FT-4X Frequency Coverage (for each version) (119.6 kB) David Behar, 05/01/2019 02:58 pm


Related issues

duplicated by Bug #6873: Yaesu FT-4XR out of range frequency issues Closed 06/19/2019

Associated revisions

Revision 3298:d841aaba1977
Added by Bernhard Hailer 8 months ago

[ft4] driver restructure (#7615)

While implementing two more radios of the Yaesu FT-4 family (the FT-25, see #7543, and the FT-4V, see #7387), I found that with some moderate reorganization, implementation of new radios will become easier. The proposed reorganization implements one more interstitial layer of inheritance to support the sub families of FT-4 (containing the FT-4X and FT-4V) and FT-65 (containing FT-65 and FT-25). Also, some variable assignments have been moved from the individual radio classes to the SCU-35 base class and to the interstitial classes named above.

This change also adds the infrastructure for adding European or Asian models, and as such prepare for addressing a number of currently open issues (6.25kHz tune step issues on EU models, frequency limitations; see #6619, #6651, #6677, #6761, #6869). It will also make it easier for a few additional fixes for issues which were found during my work on this driver (#7601, #7603, #7605). I will submit these fixes in additional patches.

Fixes: #7615

History

Updated by David Behar over 1 year ago

I had marked this issue as a "Feature", but I suppose it could also be considered a bug. In the olden days, we used to always say "it's not a bug, it's a feature!"

Separately, as a temporary work-around I find that I can prepare a CSV file with the desired frequencies (outside the U.S. amateur allocations), and then import the CSV file.

This YouTube video shows how to unlock a radio for testing (or for use if you are authorized, e.g., MARS members): https://www.youtube.com/watch?v=vPnmmz3xjbc

Updated by Bernhard Hailer 7 months ago

  • Status changed from New to Closed
  • Target version set to chirp-daily
  • Model affected changed from (All models) to Yaesu FT-4XR

This should work now.

Also available in: Atom PDF

prevent spam