Bug #6875

New to CHIRP - Having issues

Added by Nathan Bright 12 months ago. Updated 18 days ago.

Status:Rejected Start date:06/20/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:Baofeng UV-5XP

Description

Hello All,

I seem to be having a common problem with programming a Baofeng. My UV-5XP allows me to pull data from it when i call it a UV5R but doesnt allow me to upload the data back into it citing a firmware issue. Its my understanding the software is working as designed but I simply dont know how to fix the issue. Any and All help is appreciated. I have attempted to upload the CHIRP file I want to upload to my radio if that helps in your prognosis.

V/R

Nathan
KN4OVL

CHIRP.img - "Firmware does not match" with UV5XP Baofeng (6.3 kB) Nathan Bright, 06/20/2019 05:32 pm

History

Updated by Bernhard Hailer 18 days ago

  • Status changed from New to Rejected
  • Target version set to chirp-daily
  • Model affected changed from (All models) to Baofeng UV-5XP

If you're trying to upload the image of one radio into another, and that fails, then that other radio has a different firmware version than the first one.
If the upload fails on the same radio you downloaded from, then that radio doesn't report its firmware version, and Chirp can't do the job.

The issue is that if Chirp uploads data to such a radio, it could potentially destroy it with data going into incorrect memory locations in the radio.
To prevent this, Chirp refuses to write data if it can't determine whether it's ok to do so - it needs the firmware version first.

Therefore, this request must be rejected. Sorry :-(

Also available in: Atom PDF