Project

General

Profile

Actions

New Model #6929

closed

Tera TR-590

Added by Austin Cole over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/22/2019
Due date:
% Done:

0%

Estimated time:
Equipment Loan Offered:
Yes
I read the instructions above:

Description

I would be willing to loan a dev radio. We are looking to be able to easily program across multiple radio types for Emcomm, and now have these as cache radios.


Related issues

Is duplicate of New Model #2573: Tera TR-590Blocked05/07/2015

Actions
Actions #1

Updated by Bernhard Hailer over 3 years ago

  • Status changed from New to Closed
  • Target version set to chirp-legacy

Duplicates #2573. Please leave further feedback there. Thanks!

Actions

Also available in: Atom PDF