Bug #6995

Wouxun KG-UV9D-Plus

Added by John Mock 27 days ago. Updated 18 days ago.

Status:Closed Start date:08/19/2019
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Linux
Model affected:Wouxun KG-UV9D Plus

Description

On my new KG-UV9D-Plus, 'Download from Radio' shows 'Cloning from radio' and completes.
But all channel memories show as empty.

An examination of the log which show what has been read back into 'config' memory matches
the description of 'config_map' given in 'kguv9dplus.py'. That is, i can find the correct
frequencies for the first 5 channels starting at 0x0A00 and their channel names at 0X4900.

I'm wondering why the results on the screen are essentially blank.

This is running Debian Linux 'Stretch' [amd64] on a MacBook Pro.

-- KD6PAG

chirpw-UV9D-2.log - chirpw log for start up (201.4 kB) John Mock, 08/19/2019 05:55 pm

UV9D-radio.jpg - photo of radio (36.8 kB) John Mock, 08/19/2019 05:55 pm

UV9D-label.jpg - box label with bar code (33.6 kB) John Mock, 08/19/2019 05:55 pm

UV9D-box2.jpg - shipping box (68.9 kB) John Mock, 08/19/2019 05:55 pm

Wouxun_KG-UV9D Plus_20190822.img - IMG file for KG-UV9DPlus (32.2 kB) John Mock, 08/22/2019 08:17 pm

KG-UV9D _modification.png (56.5 kB) GA-2S User, 08/23/2019 07:00 pm

Associated revisions

Revision 3250:c5cee7491245
Added by GA-2S User 21 days ago

[kguv9dplus] Memories tab completely blank
Fixes #6995 https://chirp.danplanet.com/issues/6995
Changes based on values in the uploaded IMG file

History

Updated by GA-2S User 24 days ago

John,

Can you perform the Download from Radio again, and save the IMG file and upload it here?

If I can reproduce what you are seeing with the IMG file I can try to debug the root cause.

Tony

Updated by John Mock 24 days ago

Here's the results of 'Save as...', which is hopefully the .img file you are looking for.

Updated by GA-2S User 24 days ago

Hi John,

The image you posted does show the same behavior you described (the "Memories" tab is blank / all zero frequencies).

I'll do some debugging of the driver code over the next few days, but nothing immediately "errors out" like I thought it would on loading the IMG file.

Tony

Updated by GA-2S User 23 days ago

Hi John,

I made a small modification to the UV9D driver, I'm not sure it's technically valid as I'd like to follow up with the developers but can you confirm if you have channels 199, 200 and 800 programmed as seen in my screenshot?

After that confirmation I can email the developers channel.

Tony

Updated by John Mock 22 days ago

That .png is correct. I added channels 199 and 800 to help diagnose this, as they duplicate
existing and could be readily identified in hex. Once I had the .img file, the command

% od -xci -Ax --endian=big KG-UV9D.img

made it much easier to see what was store there. Thanks and I'm looking forward to the 'daily'
update. -- KD6PAG

Updated by GA-2S User 21 days ago

John,

I've sent the email to the chirp devs, http://intrepid.danplanet.com/pipermail/chirp_devel/2019-August/005570.html

We'll see what they say.

Tony.

Updated by GA-2S User 20 days ago

Hi John,

I heard back from Jim, who authored and .aintains the driver. He is on vacation but would like to know the following (his words)

1. Where and from whom did they get the radio.
2. Version of the windows prog app.

He mentions that he got his radio from powerwerx and that it was a special version.

Updated by GA-2S User 18 days ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset c5cee7491245.

Updated by GA-2S User 18 days ago

Hi John,

My proposed code change was accepted and should enable you to see the frequencies in CHIRP now but it would be immensely helpful for Jim (author of the driver) to know where the radio came from and how it was progrsmmed and the porgram version.

Thanks,
Tony

Also available in: Atom PDF