Bug #7031

IC-2730A occasional bank index errors

Added by Rick DeWitt 3 months ago. Updated 2 months ago.

Status:Closed Start date:09/03/2019
Priority:Normal Due date:09/24/2019
Assignee:Rick DeWitt % Done:

100%

Category:-
Target version:chirp-daily Estimated time:2.00 hours
Chirp Version:daily Platform:Windows
Model affected:ICOM IC-2730A

Description

After downloading from the IC-2730A, when using a stereo extension cable, some of the bank index values have corrupted upper bits set. The lower x1F values are intact so a simple mask will fix the errors. The cause appears to be related to the high-speed clone when using an extension cable.

Associated revisions

Revision 3252:71eca0d98e42
Added by Rick DeWitt 3 months ago

[ic2730] Fix for corrupted bank index, fixes issue #7031
Apply a low-order mask in _get_bank module. Issue #7031

History

Updated by Rick DeWitt 3 months ago

Fix in work.

Updated by Rick DeWitt 2 months ago

  • Status changed from New to Closed
  • % Done changed from 10 to 100

Fixed in 20190905 release. If problems with download persist; try turning off High Speed Clone mode in Settings > Other Settings. Then upload your best configuration. It should take about 28 seconds with High Speed Clone disabled. That setting can only be changed in CHIRP, not in the radio.

Also available in: Atom PDF