New Model #7613

QYT KT-8R

Added by Craig Duffield 2 months ago. Updated about 1 month ago.

Status:Closed Start date:01/26/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:No

Description

Please Can you please Add the New Radio QYT-KT-8R. The Programming Software for this Radio isn't very good. So is it please possible to Add this For CHIRP. Thanks

History

Updated by Bernhard Hailer 2 months ago

  • Subject changed from New Radio QYT-KT-8R to QYT KT-8R

Duplicate of #6843. Please add any comments regarding the QYT KT-8R there. Thanks!

Updated by Bernhard Hailer about 1 month ago

  • Status changed from New to Closed
  • Priority changed from Urgent to Normal

Also available in: Atom PDF