Bug #7663

Mac OSX 10.15.3 Catalina file access denied with chirp 20200226, worked with previous version

Added by Frank Gurnee over 2 years ago. Updated over 2 years ago.

Status:Closed Start date:02/26/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:MacOS
Model affected:(All models)

Description

Installed yesterday then current version, set up full disk access and could access files ok. Had a problem accessing the radio through USB-serial. Today I found chirp-unified-daily-20200226.app available so I installed that. Setup full disk access the same. Now I could access radio, upload/download just fine, hooray, BUT now I can't access files.

Reinstalled, restarted, added, subtracted, etc., all to no avail. Get error opening directory msg, operation not permitted.

Work around putting files in home directory.


Related issues

related to Bug #7731: CHIRP is damaged and can't be opened. You should move it ... Closed 03/24/2020
duplicated by Bug #7743: Issues with Macos Catalina ... What I've Tried and Doesn'... Closed 03/27/2020

History

Updated by Frank Gurnee over 2 years ago

It seems that even without setting Privacy, Full Disk Access, CHIRP can read and write the the user home director, so just put the files there. Done.

Updated by Bernhard Hailer over 2 years ago

  • Status changed from New to Closed
  • Platform changed from Windows to MacOS

Resolved by submitter.
This is an issue which has been reported multiple times, apparently it has to do with how privileges are set in MacOS.

Also available in: Atom PDF