Project

General

Profile

Actions

Bug #7765

open

upload fail on Yaesu VX-8R

Added by Greg Alvarez over 2 years ago. Updated about 2 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Target version:
Start date:
04/04/2020
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
Yaesu VX-8R
Platform:
MacOS

Description

New to me radio. Downloaded correct drivers and app. Radio sends data to Chirp fine. I added my local repeaters via Chirp and when attempting to upload to radio I get a ERROR message. My debug file is huge and i don't know how to attach it


Files

debug.log (680 KB) debug.log Greg Alvarez, 04/07/2020 12:09 PM
Actions #1

Updated by Bernhard Hailer over 2 years ago

  • Status changed from New to Feedback
  • Target version set to chirp-daily

Hello Greg, "huge" is relative. Start a new session with your radio and test your problem. Then attach the resulting debug log here: Click "Update", then you will find a button "Browse..." on the left side under the edit area. There you can attach a file. Armed with that file, we might be able to find out what's wrong.

Actions #2

Updated by Greg Alvarez over 2 years ago

Actions #3

Updated by Greg Alvarez over 2 years ago

Debug log uploaded

Actions #4

Updated by Bernhard Hailer over 2 years ago

Ok, if I see that right, then it works sometimes, and sometimes it fails during write?
The errors I saw vary from "Failed to communicate with the radio: write failed: (9, 'Bad file descriptor')" to "Failed to communicate with the radio: Attempting to use a port that is not open". My best guess is trouble with the USB driver - which wouldn't be a surprise with the operating system you're using.

Does any of these documents help?
CableGuide
CableGuide FTDI OEM Cables
RTSystemsCablesAndMavericks

Actions #5

Updated by Greg Alvarez over 2 years ago

Tried everything in the wiki guides. No luck. Where i was once able to upload to Chirp, I cannot even do that now. Tried going back to a previous setting and that didn't work either. Im not the most computer literate person so I'm lost.

Actions #6

Updated by Bernhard Hailer over 2 years ago

Unfortunately I'm not a Mac user myself. Hopefully someone with experience on USB to Serial converters under MacOS can give some advice here?

Actions #7

Updated by Bernhard Hailer over 2 years ago

Some MacOS notes: this OS is apparently very picky about USB to Serial cables. From what I heard, only (genuine) FTDI-based cables can be made work.
You also must have the KK7DS Python runtime for Mac OSX installed.

Actions #8

Updated by Bernhard Hailer about 2 years ago

Any luck?
There's another Wiki article which could help: MacOS Tips.

Actions

Also available in: Atom PDF