Bug #7863

Failed to communicate with radio: Radio did not ack block 0 [FT-818 w/ Bluetooth]

Added by Daniele IW9HOJ 18 days ago. Updated 15 days ago.

Status:Feedback Start date:05/08/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:Yaesu FT-818ND

Description

A known (yet unsolved) issue is ruining my day. My brand new (tx opened) Yaesu FT-818ND got a perfectly functioning Bluetooth CAT adapter, which can seamlessly run HRD, unfortunately CHIRP can read from radio but cannot write into it. The software reports "Radio did not ack block 0" just a few seconds after pressing C (Rx) button on the radio panel.

debug.log (34.4 kB) Daniele IW9HOJ, 05/08/2020 02:54 pm

debug.log (95.7 kB) Daniele IW9HOJ, 05/11/2020 02:36 am


Related issues

related to Bug #2933: Uploading to FT-857D - "Radio did not ack block 0" via B... New 10/20/2015

History

Updated by Bernhard Hailer 17 days ago

  • Status changed from New to Feedback
  • Assignee deleted (Dan Smith)
  • Priority changed from High to Normal
  • Model affected changed from (All models) to Yaesu FT-818ND

Indeed, your radio doesn't hear Chirp for some reason.
Does HRD write to the radio, can you switch bands etc.?
I've heard of issues with Bluetooth adapters before - any chance you could try a cable connection with the radio?

Updated by Daniele IW9HOJ 17 days ago

Bernhard Hailer wrote:

Indeed, your radio doesn't hear Chirp for some reason.
Does HRD write to the radio, can you switch bands etc.?
I've heard of issues with Bluetooth adapters before - any chance you could try a cable connection with the radio?

From HRD I can do everything, no issues at all. I've tried the adaptor on both my PC's with the very same result. The driver seems nicely working. I also tried to vary the Rx button pressure timing, as stated in #2933, but got no success. Eventually I just ordered an FTDI chip cable, then I'll be able to try it.

Updated by Bernhard Hailer 17 days ago

Thanks Daniele. #2933 offers important clues, hopefully that helps to bash the Bluetooth bug. Looking forward to your report with the cable.

Updated by Daniele IW9HOJ 16 days ago

The FTDI cable has arrived, I installed its genuine driver from https://www.ftdichip.com/Drivers/VCP.htm and it worked as expected, no issues at all with Chirp. Please find the debug file alleged to this message.

Updated by Bernhard Hailer 15 days ago

Ok, then we will leave this report (and also #2933) open until one of the developers has a chance to look into the Buetooth timing issue. Thanks for your feedback!

Also available in: Atom PDF