Bug #8119

FTM-7250 BUG - AM MODE

Added by Felipe Hoffens 9 months ago. Updated 4 months ago.

Status:New Start date:07/22/2020
Priority:High Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:FTM-7250

Description

Hello

A few days ago a Bug was corrected that did not allow the entry of the full range of the RX of this radio.

However, after the correction it appears that the AM mode option was not added in the configuration sheet.

Especially for the air band segment.

CHIRP_BUG_AM.JPG - IMAGE OF THE BUG (49.8 kB) Felipe Hoffens, 07/22/2020 07:30 am

Yaesu_FTM-7250D_20200724.img - Downloaded image file with AM (63.9 kB) John Owens N6JSO, 07/24/2020 03:31 pm


Related issues

related to Bug #8059: Yaesu FTM-7250D Frequency Range Error Closed 07/12/2020

History

Updated by Rudolph Gutzerhagen 9 months ago

looks like the reference is to Issue #8059 Yaesu FTM-7250D Frequency Range Error r7e8fde02da74

Updated by John Owens N6JSO 9 months ago

The bug is that the "Mode" field only allows choices "FM" and "NFM", but also needs to allow "AM" to support receive-only channels such as the airband. Attached is an image file I downloaded from an FTM-7250DR which has 3 channels (197,198,199) that were manually saved on the radio and show as AM on the radio screen, but show "FM" in Chirp. Hopefully it saved the actual radio value so you can see what it's supposed to be.

Updated by Iain White 9 months ago

Looks like a simple fix.
Change:
MODES = ["FM", "NFM"]
to
MODES = ["FM", "NFM", "AM"]

Updated by Felipe Hoffens 9 months ago

Iain White wrote:

Looks like a simple fix.
Change:
MODES = ["FM", "NFM"]
to
MODES = ["FM", "NFM", "AM"]


This BUG must resolved ONLY in the AIR BAND. 108.000 to 136.999

I think that in other band´s dont work.

Updated by Rudolph Gutzerhagen 9 months ago

Update: the issue is being investigated. A patch has been submitted that addresses the issue in your image. Further work is required to update the settings.

Updated by Felipe Hoffens 7 months ago

Rudolph Gutzerhagen wrote:

Update: the issue is being investigated. A patch has been submitted that addresses the issue in your image. Further work is required to update the settings.

Thanks in advance!
I encourage you and congratulations for the great work that you do!

Updated by Felipe Hoffens 4 months ago

Hi team!
Thanks for your development!

Have any news about this issue?

73´s

Felipe
CE3RMI

Updated by Rudolph Gutzerhagen 4 months ago

the patch that was submitted unfortunately only dealt with the dropdown box presentation. I volunteered to work on the code to carry that change through. I had some success in identifying candidate memory locations and settings but things weren't clear enough to be sure. I don't have this radio, so working without hands on became too difficult to cycle through the steps quickly and reliably. As far as I understand, the driver that was submitted was only put forward with a very minimal amount of functionality, basically to get a set of FM frequencies up to the radio. At the moment, I am not actively working on this issue and I'm not aware of anyone else who is working on it.

Also available in: Atom PDF