Bug #9005

BTECH GMRS-V1 original version

Added by john quinn 22 days ago. Updated 16 days ago.

Status:Closed Start date:04/21/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:GMRS-V1

Description

I'M trying to download a radio file form a BETCH GMRS-V1 radio to chirp and I'm getting an error message ( incorrect model selected ) when I have VENDOR as BTECH and MODEL as GMRS-V1. These radios were programed with an earlier version of CHIRP 6/14/2020 and I am now using the latest version 4/21/2021. I copied the file i used on the earlier version of chirp and i can change the file and download to the radio but i still cant get that file to load in the new version of CHIRP any help would be appreciated.

BTECH_GMRS-V1_20200614 with node.img (8 kB) john quinn, 04/23/2021 08:58 am

debug.log - debug file (49.3 kB) john quinn, 04/23/2021 10:19 am

gmrsuv1_US32412.py (33.8 kB) Jim Unroe, 04/23/2021 10:52 am

BTECH_GMRS-V1_20210424 issue.img (8.2 kB) john quinn, 04/24/2021 08:49 am

Associated revisions

Revision 3500:277f58349e5c
Added by Jim Unroe 19 days ago

[GMRS-V1] Add Missing FileID For BTECH GMRS-V1

This patch adds the US32412 fingerprint to the "_fileid" list.

fixes #9005

History

Updated by Jim Unroe 21 days ago

  • Status changed from New to Feedback

Attach the CHIRP Radio Images (*.img) file that you are trying to "upload" to the radio. Also attach a freshly downloaded CHIRP Radio Images file from the radio that you are trying to upload to.

Jim KC9HI

Updated by john quinn 20 days ago

The file is the one I saved from 6/14/2020 and installed in with the CHIRP files that I could open in the program and use to make changes and install into the radio.

The problem is I can’t get CHIRP to download the file from the radio the program says ( incorrect model selected ) but I have the correct model input in the program. I have pasted the saved file that is in the radio from when I last programed it 6/14/2020 into the chirp files and I can change and use it to download to the radio, and even after doing this I still get the same error trying to download from the radio to the program. I have also tried this on another computer running WIN XP and get the same error.

Updated by Jim Unroe 20 days ago

Then attach a clean debug.log file. To create one...

1 close CHIRP
2 open CHIRP
3 cause the error
4 close CHIRP

To locate the debug.log file use the instructions found on the How To Report Issues page.

Jim KC9HI

Updated by john quinn 20 days ago

debug file

Updated by Jim Unroe 20 days ago

john quinn wrote:

debug file

Perfect. It appears that the radio's fingerprint was added to CHIRP but it didn't get added to the radio's "_fileid" list.
Try this test driver module to see if it resolves your issue. Here is how you do it.

1 save the attached "gmrsuv1_US32412.py" test driver to a convenient location

Important: left click the file name and then click the "download" link on the page that loads.

2 open CHIRP
3 click "Help" in the menu bar and enable "Enable Developer Functions"
4 click "File" in the menu bar and select "Load Module" in the list of selections
5 locate and load the file that was saved in step 1

The CHIRP background should now be red. Attempt to download from your radio. If it works (it should), attached the downloaded file to this issue.

Note: This test driver does not permanently change your CHIRP installation. If you close CHIRP and later on need to access your radio, you will have to load this test driver first.

Jim KC9HI

Updated by john quinn 19 days ago

this is the file downloaded after your instructions using the test driver file

Updated by Jim Unroe 19 days ago

  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe
  • Model affected changed from (All models) to GMRS-V1
  • Platform changed from Windows to All

john quinn wrote:

this is the file downloaded after your instructions using the test driver file

Thank you.

Jim

Updated by Jim Unroe 19 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Patch submitted. Continue to use the test driver module until the patch is accepted into CHIRP.

Jim KC9HI

Updated by Anonymous 16 days ago

  • Status changed from Resolved to Closed

Applied in changeset 277f58349e5c.

Also available in: Atom PDF