Bug #9231

Cannot Set Duplex to "off" for Baofeng P10-UV (Radioddity GA-510)

Added by Young G 4 months ago. Updated about 1 month ago.

Status:Closed Start date:07/18/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Baofeng P10-UV

Description

When using Chirp to program Baofeng P10-UV (with radio model set to Radioddity GA-510 as instructed), the duplex mode cannot be set to "off". Doing so will trigger an error message and the duplex mode will be reset. This is caused by incorrect set_raw method call on arrayDataElement instance in line 397 of /chirp/drivers/ga510.py.

Line 396:397 of /chirp/drivers/ga510.py:

elif mem.duplex 'off':
_mem.txfreq.set_raw(b'\xff\xff\xff\xff')

Replacing it with the following code fixed the problem:

elif mem.duplex 'off':
for i in range(0, 4):
_mem.txfreq[i].set_raw("\xFF")

This is because _mem.txfreq is an arrayDataElement instance, therefore the method set_raw should not be called.

Associated revisions

Revision 3593:658428bdee62
Added by Jim Unroe about 1 month ago

[P10-UV] Driver maintenance: ga510.py

This patch adds the ga510.py driver into the cpep8.manifest
and performs cpep8 cleanup prior to addressing issue #9231

Revision 3594:0095bef840de
Added by Jim Unroe about 1 month ago

[P10-UV] Cannot set Duplex to 'off' for Radioddity GA-510

This patch addresses the bug that prevents the Duplex field from being
set to 'off' (which is needed to be able to disable TX on a channel).

Also affects: Tidradio TD-H6 and variants such as Baofeng BF-H6, P10-UV.

fixes #9231

History

Updated by Jim Unroe about 1 month ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily
  • Platform changed from MacOS to All

I will see if I can get a patch submitted to address this bug.

Jim KC9HI

Updated by Jim Unroe about 1 month ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Patches submitted. Support should be in the next CHIRP daily build following acceptance.

Note: Also affects Tidradio TD-H6 and other variants such as Baofeng BF-H6

Jim KC9HI

Updated by Anonymous about 1 month ago

  • Status changed from Resolved to Closed

Applied in changeset 0095bef840de.

Also available in: Atom PDF