Bug #9255

Illegal offset programming possible, and apparently not fixable in Chirp

Added by Mel McMurrin about 1 month ago. Updated about 1 month ago.

Status:Closed Start date:08/01/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Radioddity UV 5G

Description

Programming UV 5G (X) via latest chirp I made mistake and programmed a .5 mhz offset. The radio transmitted in the 463 mhz band. Not legal for this radio. Additionally the programming could not be undone even when uploading a fixed 5.000 Mhz offset. Manufacturer software resolved.

Firmware: P51UV01 CHIRP Version daily-20210724

BTECH_GMRS-V1_20210802 Cut_Paste source.img (8.2 kB) Mel McMurrin, 08/02/2021 10:40 am

Radioddity_UV-5G_20210802 Uploaded.img (6.5 kB) Mel McMurrin, 08/02/2021 10:41 am

Radioddity_UV-5G_20210802 Downloaded.img (6.5 kB) Mel McMurrin, 08/02/2021 10:41 am

Radioddity_UV-5G_20210802 Uploaded.img (6.5 kB) Mel McMurrin, 08/02/2021 10:43 am

Radioddity_UV-5G_20210802 Downloaded.img (6.5 kB) Mel McMurrin, 08/02/2021 10:43 am

BTECH_GMRS-V1_20210802 Cut_Paste source.img (8.2 kB) Mel McMurrin, 08/02/2021 10:43 am

Associated revisions

Revision 3535:fa8552860154
Added by Jim Unroe about 1 month ago

[UV-5G] Fix Incorrect Offset for Repeater Channels

This patch updats the driver with the correct offset for the repeater
channels 23-30.

#9255

History

Updated by Jim Unroe about 1 month ago

  • Status changed from New to Feedback

The 8 repeater channels should come with the correct +5.0 MHz offsets preset.
Why would you try to change them?
Which channel did you change?
What steps did you take to change the offset?
Can you attach the CHIRP Radio Images (*.img) file with the incorrect offset?

Jim KC9HI

Updated by Mel McMurrin about 1 month ago

Hi Jim,
Thanks for your attention to this and the vital service Chirp provides. I think this may be bigger than what I assumed was my slip of the hand. All 8 repeater channels now have the .5 offset...I definitely did not do that! Attached is the IMG as uploaded and then as downloaded. I see 5 MHz offset on upload but radio ends up with .5 and writes that back when I download.

I was originally trying to program a smaller offset (4.775 MHz) on Repeater 8 in order to TX on a lower input channel (I bought radios ]assuming from what I read that programming extra repeater channels was possible [apparently it is not...yet anyway.]) The channel setup was cut/pasted from a Btech GMRS V-1 Chirp image by the way, also attached.

At least one other user on mygmrs.com has seen same or similar behavior. I'll reach out to them. I assume they can add to this report if a member?

I've also reported to Baofeng/Radioddity as I would guess it's something off in the firmware.

If you cannot duplicate, let me know how I can best test on this end. Other miscellaneous things I did in Chirp was tweak the squelch settings and expand receive to include 220 Mhz.

Thanks again,
Mel
KK6TMN WREK301

Updated by Mel McMurrin about 1 month ago

Upload/Download images attached.

Updated by Jim Unroe about 1 month ago

  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe
  • Platform changed from Windows to All

Mel,

Thanks for sending the 3 (+2) files. I've located the bug and will be working to submit a formal patch.

Thanks,
Jim KC9HI

Updated by Steven Garrett about 1 month ago

Can confirm my UV-5G does this as well. Moving channels around caused the offsets on channel 23-30 to flip from 5MHz to 0.5MHz. The fix was to read with the factory tool, then write with it, then read with CHIRP. Otherwise I was stuck with a non-5MHz offset.

Updated by Mel McMurrin about 1 month ago

Jim: On behalf of the 6 newly licensed folks eagerly waiting programmed radios a big thanks.
Steve: Thanks for chiming in.

I too sorta fixed things with the factory software. But the hard-wired NOAA channels, no cut-paste and truncated channel field made that option less than adequate.

So glad there's CHIRP.

I'm now a patron,
Mel

PS Jim, since CHIRP seems to override the fixed NOAA channels is there any hope of programming GMRS frequencies on channels above 30 in the future? Just have to ask.

Updated by Steven Garrett about 1 month ago

I too would love to be able to program additional GMRS repeater configurations into other channels on the UV-5G. I want to say I saw another "Issue" topic where Jim mentioned the static 30 channels are by design. Bug 9235. I know it's a soft limitation though as I've figured out how to TX on channels above 30 programmed to GMRS freqs. Can probably TX on others as well, but that would be illegal and I have no need to. Unsure if Chirp devs are willing/ to implement the ability to push additional channels with TX on them.

To ensure my words aren't taken the wrong way. I only want to TX on GMRS freqs, but I would like to save those freqs with their associated tones to channels above 30 to make reprogramming occur less and make accessing repeaters on the same freq as easy as changing channels.

Updated by Jim Unroe about 1 month ago

  • Status changed from In Progress to Resolved
  • Target version set to chirp-daily
  • % Done changed from 0 to 100

Patch submitted. Support for the correct offset will be in the next CHIRP daily build following acceptance.

Jim KC9HI

Updated by Mel McMurrin about 1 month ago

Hate to be a pest, but wondering when next build might be released (so I can manage expectations of those receiving radios.)
Thanks!

Updated by Jim Unroe about 1 month ago

Contact me via email...

Jim

Updated by Jim Unroe about 1 month ago

  • Status changed from Resolved to Closed

Patch accepted. Support will be in the next CHIRP daily build.

Jim KC9HI

Also available in: Atom PDF