Bug #9469

Incorrect implementation of validate_memory() in uv5r.py driver.

Added by Jim Unroe about 1 month ago. Updated 22 days ago.

Status:Closed Start date:10/21/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:(All models)

Description

The validate_memory() helper recently added to the uv-5r.py driver was intended to only validate channels certain GMRS radio models. It was discovered today that a mistake in its implementation validates all radio models.

Associated revisions

Revision 3610:209e73baad50
Added by Jim Unroe 23 days ago

[uv-5g] Fix validate_memory() inplementation bug in uv5r.py driver

The validate_memory helper as implemented applies to all radios supported
by the uv-5r.py driver. It was only intended to validate channels in specific
GMRS radio models. This patch corrects the mistake.

Fixes #9469

History

Updated by Jim Unroe about 1 month ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Patch submitted.

Jim KC9HI

Updated by Anonymous 22 days ago

  • Status changed from Resolved to Closed

Applied in changeset 209e73baad50.

Also available in: Atom PDF