New Model #9489

Wouxun KG-935G

Added by Benjamin Cordingley 11 months ago. Updated 13 days ago.

Status:Closed Start date:10/26/2021
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:Yes

Description

Dual radio GMRS handset sold by buytwowayradios.com. I am happy to work with the developers and loan my handset.

https://www.buytwowayradios.com/wouxun-kg-935g.html
https://www.buytwowayradios.com/downloads/dl/file/id/1465/product/5434/wouxun_kg_935g_programming_software.zip

kg935g test.py (42.5 kB) Mel Terechenok, 04/15/2022 12:43 am

kg935g MRT test b1.1.py (42.6 kB) Mel Terechenok, 04/18/2022 09:23 pm

kg935g MRT test b1.3.py - KG935G Beta 1.3 driver (45.3 kB) Mel Terechenok, 07/27/2022 10:43 pm

KG935G CHIRP Driver Beta1.3.docx - KG935G Beta 1.3 documentation (1.2 MB) Mel Terechenok, 07/27/2022 10:43 pm

kg935g MRT test b1.4.py (76.7 kB) Mel Terechenok, 08/01/2022 07:34 pm

KG935G CHIRP Driver Beta1.4.docx (1.6 MB) Mel Terechenok, 08/01/2022 07:34 pm

KG935G CHIRP Driver Beta1.4.1.docx (1.6 MB) Mel Terechenok, 08/02/2022 03:38 pm

Screenshot 2022-08-06 110456.png (408.8 kB) Patrick Larkin, 08/06/2022 04:16 pm

Wouxun_KG-935G_20220806-ChErrors-MRT_b1-4-py.img - Downloaded from radio via CHIRP (32.2 kB) Patrick Larkin, 08/06/2022 06:40 pm

2022-August-preCHIRPtest.kg - Downloaded from radio via OEM software (32 kB) Patrick Larkin, 08/06/2022 06:40 pm

rx tone error 1.jpg (149.9 kB) Mel Terechenok, 08/07/2022 05:28 pm

rx tone error 2.jpg (146 kB) Mel Terechenok, 08/07/2022 05:28 pm

rx tone error 3.jpg (158 kB) Mel Terechenok, 08/07/2022 05:28 pm

rx tone error 4.jpg (139.9 kB) Mel Terechenok, 08/07/2022 05:28 pm

2022-August-preCHIRPtest corrected by MRT.kg - Corrected Wouxun CPS image file (32 kB) Mel Terechenok, 08/07/2022 05:28 pm

kg935g MRT test b1.5.py (77.1 kB) Mel Terechenok, 08/07/2022 05:55 pm

kg935g MRT test b1.6.py (61 kB) Mel Terechenok, 08/13/2022 12:00 am

Wouxun_KG-935G.img - Test Image for Chirp Development testing (32.2 kB) Mel Terechenok, 08/20/2022 05:23 am

Associated revisions

Revision 3741:75ed6daea5a4
Added by Mel Terechenok 22 days ago

[KG-935G] Add Support for Wouxun KG-935G GMRS Radio - New Model #9489

New Driver addressing new model request

New Model #9489

History

Updated by Joseph Poe 8 months ago

Benjamin Cordingley wrote:

Dual radio GMRS handset sold by buytwowayradios.com. I am happy to work with the developers and loan my handset.

https://www.buytwowayradios.com/wouxun-kg-935g.html
https://www.buytwowayradios.com/downloads/dl/file/id/1465/product/5434/wouxun_kg_935g_programming_software.zip

I'm open to helping too, just got my 935G :)

Updated by Patrick Larkin 7 months ago

FYI: The beta driver for the KG-UV8H mostly works on KG-935G, but it still needs some work. Perhaps it can be used as a basis by some coders to work on KG-935G specifically.

https://chirp.danplanet.com/issues/8803

I'm willing to do testing and provide feedback with my KG-935G.

Updated by Mel Terechenok 6 months ago

Attached is a modified and renamed UV8H file for the KG-935G based on the UV8H file from Pavel Milanes CO7WT <> located here:
https://chirp.danplanet.com/attachments/6765/kguv8h.py

It does communicate with 935g.
Updates include:
-Correcting the power level to 2 bits to handle the 935G's L-M-H options
-Correcting the decoding of the tone decoding to handle DCS tones and Polarity without showing an error in the memories tab.

This file correctly downloads and displays the contents of my radio where the UV8H driver would show an error on channels with DCS tones and show only L or H Power settings.

The mods were intended to address issues with downloading and decoding only.
I have not tested anything for uploading to the radio.
Use at your own risk.

Updated by Mel Terechenok 5 months ago

beta 1.1

Correct error to properly handle Split tones ( Cross Tones ) with CTCSS Tx and DCS RX or DCS Tx and CTCSS Rx.

Updated by Alex Martin 4 months ago

Mel Terechenok wrote:

I have not tested anything for uploading to the radio.
Use at your own risk.

Any testing done on writing to the radio yet? I don't want to brick my radio or anything

Updated by Mel Terechenok 2 months ago

I have started testing the write to radio. In general, writes work... but I can't confirm all settings are working properly yet. Testing will be ongoing thanks to support from BuyTwoWayRadios.com.

Stay Tuned.

Updated by Mel Terechenok 2 months ago

Here is Beta 1.3 of the KG935G Chirp Driver
Reads(Downloads) and Writes(Uploads) are working.

Channel editing is best done in the Memories tab
Configuration setting editing is done in the Browser tab.
The settings are displayed in HEX/DEC/BIN/CHAR representations - decoding described in the attached document
The User Interface for human readable display of values still needs alot of development.

Attached is a document with my warnings and a description of the settings by name and what the values represent.
Please read this document before changing values.

HINT: There are some EASTER EGGS (bonus configuration settings) that you may find useful. ;)

SAVE A COPY OF YOUR RADIO SETTINGS WITH WOUXON KG935G PROGRAMING SW BEFORE ATTEMPTING TO USE THIS DRIVER.
THIS DRIVER IS STILL EXPERIMENTAL AND MAY CONTAIN BUGS: USE AT YOUR OWN RISK
HOWEVER, I have read from and written to the KG935 about 100 times with this driver and have not had any issues to note.

Thanks to Danny @ BuyTwoWayRadios.com for his support in getting to this point!!!!

Updated by Mel Terechenok 2 months ago

KG935G CHiRP - Beta 1.4

Added User Interfaces for ~80% of settings.
See attached beta 1.4 document for sample screenshots as well as information on the settings not yet implemented.

READ/SAVE A COPY OF YOUR RADIO SETTINGS WITH WOUXON KG935G PROGRAMING SW BEFORE ATTEMPTING TO USE THIS DRIVER.

DOWNLOAD/SAVE A COPY OF YOUR RADIO SETTINGS WITH CHIRP BEFORE MODIFYING SETTINGS WITH CHiRP.

SOME SETTINGS THAT CHIRP CAN CHANGE ARE NOT CHANGED BY WOUXUN CPS OR FACTORY RESET AND WILL NEED TO BE RESTORED WITH A CHiRP SAVED COPY IF SO DESIRED.

THIS DRIVER IS STILL EXPERIMENTAL AND MAY CONTAIN BUGS: USE AT YOUR OWN RISK
HOWEVER, I have read from and written to the KG935G 100+ times with this driver and have not had any issues to note.

Thanks to Danny @ BuyTwoWayRadios.com for his support in getting to this point!!!!

Updated by Patrick Larkin about 1 month ago

Mel,
Congratulations and thank you for all the effort you've put into this! I'm just now testing Beta1.4 and noticed an issue. Per your instructions I downloaded into OEM software and then into CHIRP and discovered something strange with channels 1-7 not being loaded into chirp, and having the name "Error". I'm attaching a screenshot of CHIRP in upper left, with OEM software in lower right foreground. Is there anything I can do to help troubleshoot this?

Windows 10 Pro - Build 19041.vb_release.191206-1406
Chirp: daily-20220726
OEM software: KG-935G Commander versionV1.02 (20210831)

Updated by Mel Terechenok about 1 month ago

Patrick,
Thanks for sharing.. I have not seen this. Can you post the Chirp img file as well as the Wouxun software file so I can test them on my radio and debug?

Mel

Updated by Patrick Larkin about 1 month ago

My pleasure to do so. Please see attached.

Updated by Mel Terechenok about 1 month ago

Patrick - Thank you for the files. I found 2 problems... both problems are within the image file from the Wouxun Programming SW (CPS), which seems to be corrupted, and not with the Chirp Beta1.4 driver.

When CHiRP displayed an Error in the channel memory location the issue was always one of the following 2 issues:

1. Invalid Value stored in the Channel Power Level setting. The 935G uses values 0,1,2 for Low,Med,High. However the CPS was writing a value of 3. CHiRP is not expecting this value and errors out. Also when I looked at the power level on the 935G in the Menu... it showed a value of "Both". The fix was to simply change the power level to a different value in the CPS and then back to the desired value.... CPS then corrects the value to a proper one.

2. The 2nd problem was a corrupted Rx or Tx tone value in the CPS file. I saw 2 different types of corruption. the first was when CPS showed a value of OFF. It should be None when a tone is not used.
I also saw completely invalid tone values shown in the CPS.. example: a tone of 1031.8 - which is not a valid value.

By correcting the values in the CPS and then downloading to the radio, CHiRP reads all channels properly.

I have no idea how the CPS file got corrupted, but at this point, I don't see any issues that were caused by the beta1.4 driver.

I have attached the corrected CPS file of your file for you to try and confirm proper operation with CHiRP.
I have also attached screen shots of the Rx/Tx Tone errors that I saw in the CPS channels.

Mel

Updated by Mel Terechenok about 1 month ago

KG-935G Beta 1.5 -

MRT Beta 1.5 Updates Include:
- Corrected minor typos found in previous versions
- Made pri_ch,work_ch_a,work_ch_b U16 instead of U8 to fix errors when specifying channel values > 255
- Changed node_sw_pwd to mode_sw_pwd
- Added Compander to VFOA and VFOB settings
- Added Scan Group Upper/Lower to Scan Settings
- changed group_x_lower and upper to group_lowerx to support for loop use
- Added Call Names to the Call Settings
- Added Mode SW Pwd and Reset Pwd to Config Settings
- Display FM Radio Presets in proper format / units (MHz)
- Display VFOA/VFOB/Rx Freq and RX Freq limits in units of MHz
- VHF rx freq Limit range is 30 - 299.999999 MHz
- UHF rx freq Limit range is 300 - 999.999999 MHz
- VFOA/VFOB Freq Range is 30 - 999.999999 MHz

- SETTINGS NOT IMPLEMENTED

VFOA/VFOB RxTone and TxTone

- NOTE:
For channels shown on Memories tab
Compander, Descramble and SP Mute are not currently modifiable through the Memories tab.
If any changes are made to a channel's settings, they are always defaulted to Off, Off, QT respectively.

Thanks to Danny at BuyTwoWayRadios.com for his support in developing this driver.

Updated by Mel Terechenok about 1 month ago

MRT Beta 1.6 - FULL FUNCTIONALITY
ALL KNOWN SETTINGS IMPLEMENTED

ADDED Current Call Group to Call Group settings
ADDED VFOA/B rxtone and txtone to VFOA/B Settings
ADDED VHF/UHF Tx Freq Limits back into Limit Settings

Radio does not use the Tx values to extend transmit capability
However, the Wouxun CPS uses the Rx/Tx limit values to limit check entries so I added them back in to help maintain
compatibility between CHiRP and Wouxun CPS by allowing the range to be extended to make Wouxun CPS happy when necessary
I recommend keeping the Rx and Tx ranges the same unless all your non-GMRS channels have Tx set to OFF

REMOVED PTT Delay option value of 0ms to match Wouxun CPS
REMOVED option to select OFF for Active display brightness to match Wouxun CPS
REMOVED DTMF transmit time and DTMF Interval time options below 50ms to match Wouxun CPS
CORRECTED bug with Transmit Power Level settings to prevent Tx signal strength bar display corruption
and to ensure radio displays proper Power Level when accessing through radio MENU button after
creating a new entry into a previously empty Channel Memory location
Update Channel Memory to force Unknown parameters to a default value to match what Wouxun CPS
uses when adding a new channel.
CHANGED Memories tab freq limit checks to 30-999.999999 MHz to support ability to change VHF/UHF Rx Freq Limit settings-

If value specified is outside of VHF/UHF Rx Freq Limit values, a default value will be used by radio

General code cleanup

utilize for loops on the call group settings
remove some outdated code and comments

- NOTE:
For channels shown on Memories tab
Compander, Descramble and SP Mute are not currently modifiable through the Memories tab.
If any changes are made to a channel's settings, they are always defaulted to Off, Off, QT respectively.

Thanks to Danny at BuyTwoWayRadios.com for his support in developing this driver.

Updated by Patrick Larkin about 1 month ago

Mel Terechenok wrote:

Patrick - Thank you for the files. I found 2 problems... both problems are within the image file from the Wouxun Programming SW (CPS), which seems to be corrupted, and not with the Chirp Beta1.4 driver.

When CHiRP displayed an Error in the channel memory location the issue was always one of the following 2 issues:

1. Invalid Value stored in the Channel Power Level setting. The 935G uses values 0,1,2 for Low,Med,High. However the CPS was writing a value of 3. <snip>

2. The 2nd problem was a corrupted Rx or Tx tone value in the CPS file. I saw 2 different types of corruption. <snip>
I have attached the corrected CPS file of your file for you to try and confirm proper operation with CHiRP.
I have also attached screen shots of the Rx/Tx Tone errors that I saw in the CPS channels.

Mel

Thanks Mel, I'm only just now getting back to this... and trying it with your 1.6 beta. Some other things I noticed: Using your corrected CPS file, I reset my radio, wrote it to the radio, then downloaded to CHIRP. I still had errors on many channels, but those channels all showed "Middle" for TX Power in the CPS. Setting them to Low or High in CPS, writing to radio, then downloaded to CHIRP, they were fine. If I set them back to "Middle" in CPS and repeat, the resulting CHIRP download properly showed "M" in power. Another thing I noticed was that I had some MURS channels in there, and the CPS showed 151.820 for TX, which of course is "illegal" in the radio; when I click the field in CPS, I see None and GPS frequencies as available options (as one would expect).

How did it get this way, well I must admit: Last year I was messing around with a KGUV8H beta module for CHIRP to be able to rearrange and mass-edit channels. I would imagine it wrote some stuff that probably doesn't make sense on a KG935G.

As you mentioned, neither of these has anything to do with your module. These are clearly flaws within CPS ... which is even more reason I totally appreciate your effort (And support from BuyTwoWayRadios) to make this device work with CHIRP!

Updated by Jim Unroe 15 days ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Support for the Wouxun KG-935G is now included in the CHRIP daily builds.

Jim KC9HI

Updated by Patrick Larkin 14 days ago

Jim Unroe wrote:

Support for the Wouxun KG-935G is now included in the CHRIP daily builds.

Jim KC9HI

Congratulations, and Thank You!

Updated by Jim Unroe 14 days ago

Patrick Larkin wrote:

Jim Unroe wrote:

Support for the Wouxun KG-935G is now included in the CHRIP daily builds.

Jim KC9HI

Congratulations, and Thank You!

Just to be clear, the developer to thank is Mel Terechenok.

Jim KC9HI

Updated by Mel Terechenok 13 days ago

And thanks to Pavel Milanes CO7WT for providing the base UV8H communications driver.

Also available in: Atom PDF