New Model #9607

Retevis RB-27 GMRS

Added by David Billcheck 7 months ago. Updated 6 months ago.

Status:Closed Start date:12/14/2021
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:No

Description

Programming thru CHIRP would be nice

30 GMRS (8 repeater)
11 NOAA
Hi/lo power
5 Watt max
VOX
DualWatch
24 DIY channels

bf-t8_2 rb27 - gmrs.py (28.9 kB) Jim Unroe, 12/20/2021 02:11 pm

bf-t8_2 rb27 - gmrs.py - test driver #2 (29 kB) Jim Unroe, 12/20/2021 07:03 pm

bf-t8_2 rb27 - gmrs.py - test driver #3 (29 kB) Jim Unroe, 12/22/2021 01:53 pm

Associated revisions

Revision 3641:a28c7838346f
Added by Jim Unroe 6 months ago

[RB27] Add Retevis RB27

This patch adds support for the Retevis RB27 GMRS radio.

addresses #9607

History

Updated by Jim Unroe 7 months ago

  • Status changed from New to Feedback

I just received a set of RB27 radios (RB27, RB27B, RB27V and RB627) from Retevis so I will be looking into it.

Jim KC9HI

Updated by David Billcheck 7 months ago

Thanks Jim.

Updated by Jim Unroe 6 months ago

  • File bf-t8_2 rb27 - gmrs.py added
  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily

I have created a test driver module for the Retevis RB27 (GMRS) radio. It uses the Vendor: Retevis / Model: RB27 selections. Here is how you use it.

1. Download the bf-t8_2 rb27 - gmrs.py test driver module and save it to a convenient location.

Note: Be sure to left-click the link and then click the download link near the top of the page that loads. Right-clicking the link to download the test driver module will not work.

2. Load CHIRP
3. Click Help in the menu bar and enable Enable Developer Functions
4. Click File -> Load Module to locate and load the test driver module that was saved in step 1

At this point CHIRP will have a red background to indicate that it is running with an external driver module loaded. This does not permanently change your CHIRP installation in any way. Once you close CHIRP, you will have to reload the test driver module again before you can program the Retevis RB27. Note: The RB27 test driver module also supports the RB27B.

Before doing any editing, be sure to save your first successful download as a CHIRP Radio Images (*.img) file to be kept as a backup. Once you have your backup saved, test whatever you care to test. Let me know if you find something that doesn't work.

Jim KC9HI

Updated by David Billcheck 6 months ago

Hi Jim.
Thanks for the quick work.

Download worked OK.
Changed Squelch MR channel and TO and saved OK when loaded back to radio.

Setting FM freq on settings page does not load back to radio.
NOAA channels/freq do not show up on memories page. can you
get them to show.
Settings page NOAA select only has first 7 out of 11 NOAA channels.

Dave

Updated by Jim Unroe 6 months ago

David Billcheck wrote:

Hi Jim.
Thanks for the quick work.

Download worked OK.
Changed Squelch MR channel and TO and saved OK when loaded back to radio.

Setting FM freq on settings page does not load back to radio.

Gook catch. This has been broken since the BF-T8 driver was created. It saves to the radio but it is an invalid value. I had the variable type incorrectly defined. Fixed and working now.

NOAA channels/freq do not show up on memories page. can you
get them to show.

No. But you can add them to the RB27 GMRS radio if you want. The RB27 had 99 channels. Like the "factory" software you can add any frequency from 136-174 MHz and 400-520 MHz (RX only). Unlike the "factory" software, if you add any of the GMRS frequencies they should (I hope, please test) work just like channels 1-30.

Settings page NOAA select only has first 7 out of 11 NOAA channels.

Good catch. These have been missing from the list since the BF-T8 driver was created. Missing frequencies added to the list.

Dave

Jim KC9HI

Updated by David Billcheck 6 months ago

Jim,
Copy and pasted 14 GMRS freq to Channela 55-68.
TX OK.

Put in off freq 463.1250 on ch69. No TX
Dave

Updated by David Billcheck 6 months ago

Driver2 everything OK
Thanks,
Dave

Updated by Jim Unroe 6 months ago

OK. I have to convert these test drivers into patches so I can submit them. Part of that process is running it through a test suite without any errors. Unfortunately what I have for the RB27 GMRS radio fails.

The problem is that CHIRP isn't really designed to handle radios that have channels that technically can't be deleted. The test suite complains that it cannot delete the channels and fails. This only seems to be a problem for the radios that have extra channels (99 for the RB27) beyond the 30 GMRS channels. This isn't an issue for the RB27B which is 22 channels with not "extra" channels.

I wrestled with this all day yesterday (21DEC) and the only thing I could come up with is basically the same thing that I had to do for the Baofeng UV-5G GMRS radio. If you tap the [Delete] key on memory row 1-30, that memory row will be empty. to return it back to use you just have to enter a valid frequency (400. for example) and then click the [Refresh] button. The memory row will be restored with the correct frequency based on the service (GMRS in this case).

In this driver I also did the same thing for the RB27B FRS selection. What I am trying to determine now is whether I should do the FRS (and eventually MURS and PMR446) radios the same as the GMRS support for consistency across the whole driver or should I keep them how they currently are in the issue #9551 test driver module?

So give this a test and, most importantly, give me some feedback with how I should support the FRS (and other) drivers.

Thanks,
Jim KC9HI

Updated by Jim Unroe 6 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

A patch has been submitted. Support should be in the next CHIRP daily build following acceptance.

Jim KC9HI

Updated by Jim Unroe 6 months ago

  • Status changed from Resolved to Closed

Support will be in the 3 January 2022 CHIRP daily build.

Jim KC9HI

Also available in: Atom PDF