Bug #9701

Current daily lacks support for my particular DB25-G

Added by Dave T 11 months ago. Updated 11 months ago.

Status:Closed Start date:01/13/2022
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:DB-25G

Description

I have a DB25-G that is identified as "VC7062" and is unrecognized by the current daily. I used the btech_vc9204.py module I found in a similar thread and it works great with: DB25G_fp = "VC7062"

With that tweak I have zero issues.

btech_vc7062.py (158.1 kB) Jim Unroe, 01/13/2022 05:48 pm

Associated revisions

Revision 3651:7a091d4e2dc9
Added by Jim Unroe 11 months ago

[DB25-G] Add additional MCU Version for Radioddity DB25-G

This patch adds an additional MCU version (VC7062) for the
Radioddity DB25-G.

Fixes #9701

History

Updated by Jim Unroe 11 months ago

  • File btech_vc7062.py added
  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily

Hi Dave,

Give this draft driver module a quick test and let me know how it goes.

Jim KC9HI

Updated by Dave T 11 months ago

Jim Unroe wrote:

Hi Dave,

Give this draft driver module a quick test and let me know how it goes.

Jim KC9HI

Works just fine Jim! I was able to download then upload a config without issue using that module.

Updated by Dave T 11 months ago

Interesting to note that even the Radioddity software does not recognize this unit.

Updated by Jim Unroe 11 months ago

Dave T wrote:

Interesting to note that even the Radioddity software does not recognize this unit.

I'm not surprised. The MCU version is a duplicate of a QYT KT8900D variant. Makes me wonder if it has the wrong electronics on the inside, the wrong labeling on the outside or the MCU version was just reused by the factory.

If it was mine, I would program it using Vendor: QYT / Model: KT8900 and see what I could make it do!

Jim KC9HI

Updated by Jim Unroe 11 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Patch submitted. Support for MCU: VC7062 will be in the next CHIRP daily build following acceptance. In the mean time, just continue to use the temporary test driver module. Once CHIRP has been updated you can stop using the test driver module and set Enable Developer Functions back to disabled.

Jim KC9HI

Updated by Anonymous 11 months ago

  • Status changed from Resolved to Closed

Applied in changeset 7a091d4e2dc9.

Also available in: Atom PDF