Bug #9815

mac mouse cursor offset by 1/4-1/2" on chirp screen

Added by Guy Teague 6 months ago. Updated 5 months ago.

Status:New Start date:03/31/2022
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Chirp Version:daily Platform:Windows
Model affected:(All models)

Description

i've run chirp off and on for years on windows and various mac models and invariably on the mac i'll have to aim 1-3 lines or 1/4-1/2" high over a field for the click to register in the field. i just now installed the latest version of chirp now that someone has a workaround for m1 chips and i have the exact same issue. it's why i've always quit using chirp in less than a few hours because it's infuriating and i end up clicking the wrong thing and destroying whatever i was trying to do.

why should this only affect the mac and all macs and all mac os versions and all mice and all radios? can chirp not handle the resolution or what?

signed very frustrated. :) /guy (73 de kg5gt | wqpz784)

Screen Shot 2022-03-31 at 18.16.06.jpg (243.5 kB) Guy Teague, 03/31/2022 11:24 pm

History

Updated by Guy Teague 6 months ago

update: it's much improved since last time i ran chirp. once i uploaded a radio's contents the cursor is in the right places in the memory list view. it seems it's only offset on some buttons and in nearly all the dialogue boxes. offset by nearly exactly one line low it looks like.

on the plus side, chirp for the uv5x let me fix every annoying bug the rt systems mac version introduced except that chirp doesn't export all the fields to a csv file and i was wanting to change all the power fields from /high/ to /low/ and i couldn't figure out how to copy the contents of one field into that field in other rows using chirp alone. oh well, that's an issue for another time i guess. i'm just glad it improved enough i can use it now. /guy

Updated by Tony Fuller 6 months ago

When I worked daily with a mac laptop a few years ago I noticed something like this but it only happened when I enlarged my mouse pointer and stopped happening after I made the mouse cursor normal size.

Have you by chance adjusted the cursor size?

Tony

Updated by Guy Teague 6 months ago

yes, i did. i don't see well and i bumped it up slightly. i'll give it a try .....

... i thought you had it, made perfect sense, but no joy. in the dialogue boxes it's still one line off. when i take a screenshot the actual cursor disappears but you can see the selection is on /Volumes/ but i have to put the cursor over /var to click on /Volumes.

i use steermouse to drive my mx master 3 mouse and i've used steermouse at least as long as chirp. it doesn't have a cursor size setting but it can do things like 'snap to default' in dialogue boxes.

Updated by Guy Teague 6 months ago

nope, not steermouse either. at least it wasn't the 'snap to' function which i disabled. /guy

Updated by Guy Teague 6 months ago

now i think deeper about it, i've used steermouse as long as i've had my mac. and i don't use it or windows or linux. so that could well be the factor but i'd have to give up computing if i had to give up steermouse so if it's a decision whether to run chirp or steermouse chirp is going to lose! :) :) :)

/guy

Updated by Louis Wise 5 months ago

I'm having the same problem on my iMac running 12.3. I have to clip one line above where I want to clip. I'm running the latest download of Chirp.

Updated by Louis Wise 5 months ago

I just changed my mouse size. I had it larger than normal. Putting it back to normal size, now it was right on the line that I needed to click. That fixed the issue for me.

Also available in: Atom PDF