New Model #9827

QYT KT-WP12 / Anysecu WP-9900

Added by John K9JEB Boal 3 months ago. Updated about 1 month ago.

Status:Closed Start date:04/10/2022
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Equipment Loan Offered:No

Description

Great radio! probably similar programming to other QYT radios. available on amazon for a few months now, but requires its own CPS software which is a joke. We need CHIRP for this!! I have a radio that can be used to debug - also am a developer myself and familiar with Python, and debugging. Radio is a control body with the display and all controls in the speaker mic. Also has a water resistant rating, great for limited space mobile installs. Already really popular here in the Pacific NW - Please help us support this radio!

Anysecu-wp9900.jpg - Anysecu WP-9900 software (17 kB) John Boal, 04/17/2022 01:45 am

WP-9900 MCU WP3094 - read test.py (86.4 kB) Jim Unroe, 05/09/2022 07:38 pm

Anysecu_WP-9900_20220509.img - Anysecu WP-9900 image file downloaded (16.2 kB) John Boal, 05/09/2022 11:39 pm

btech_wp-9900_draft_#1.py (178.1 kB) Jim Unroe, 05/16/2022 01:25 am

Anysecu_WP-9900_20220516.img (16.2 kB) Hayden Thring, 05/16/2022 05:22 am

Anysecu_WP-9900_K9JEB.img - Anysecu WP-9900 image uploaded to radio successfully (16.2 kB) John Boal, 05/16/2022 06:25 pm

Anysecu_WP-9900_20220516_SJ.img (16.2 kB) Sam Jones, 05/17/2022 02:24 pm

Capture_AnySecu_Chirp.PNG - Screenshot (38.7 kB) Matt Schnizer, 05/20/2022 11:33 pm

Anysecu_WP-9900_1st_Download_20220520.img (16.2 kB) Matt Schnizer, 05/20/2022 11:34 pm

btech_wp-9900_kt-wp12_draft_#2.py (179 kB) Jim Unroe, 05/21/2022 04:57 pm

btech_wp-9900_kt-wp12_draft_#3.py (169.1 kB) Jim Unroe, 05/24/2022 08:25 pm

Anysecu_WP-9900.img - CHIRP Image for adding to /tests/images (16.2 kB) Jim Unroe, 05/27/2022 01:42 am

QYT_KT-WP12.img - CHIRP Image for adding to /tests/images (16.2 kB) Jim Unroe, 05/27/2022 01:42 am

Associated revisions

Revision 3686:582ba7f01943
Added by Jim Unroe about 1 month ago

New Model: QYT KT-WP12

This patch adds support for the QYT-KT12 mobile radio.

#9827

Revision 3687:74a41b1d24d7
Added by Jim Unroe about 1 month ago

New Model: Anysecu WP-9900

This patch adds support for the Anysecu WP-9900 mobile radio.

Resolves #9827

History

Updated by Jim Unroe 3 months ago

  • Status changed from New to Feedback

Hi John,

I will likely be working on this. I am currently working on some that will make the driver that will eventually support this radio better. Once I get that to where it is available for testing, I will see if I can start on this.

I always get a chuckle when someone mentions that they need CHIRP because the OEM software is so bad. The CHIRP developer has to work very closely and constantly with the OEM software in order to develop the CHIRP driver. ;-)

It would be nice if QYT (or one of their dealers) would donate a radio to the cause. Which radio (vendor/model) do you have?

Jim KC9HI

Updated by John Boal 3 months ago

Hi Jim, sounds good. These are the same radio hardware just rebranded. Both are available on Amazon. I have the Anysecu branded WP-9900. The thing I really need is to be able to transfer all my programs to this new radio without having to key in all of the channels manually. there is no import/export in the crappy software they provide. I know several other people that have these also... Let me know what I can do to help.

Here is the amazon link in case it helps...

https://smile.amazon.com/KT-WP12-Mobile-Channels-Transceiver-Programming/dp/B09K3MNW5K

73

Updated by Jim Unroe 3 months ago

John,

What other radios do you have that use this same driver (QYT KT8900D, KT7900D, KT8900, KT8900R, KT-8R, BTECH UV-2501, UV-2501_220, UV-5001, UV-25X2, UV-25X4, UV-50X2, etc)? I will need some testing done with them as well.

Jim KC9HI

Updated by John Boal 3 months ago

Hi Jim, I also have QYT KT-7900 radios, but the settings tab on this model does not work in Chirp and has been broken for at least one year... but I have them also available for testing if needed. If we can fix that tab as well that would be great, let me know if i should file a separate bug on it.

Updated by Jim Unroe 3 months ago

John Boal wrote:

Hi Jim, I also have QYT KT-7900 radios, but the settings tab on this model does not work in Chirp and has been broken for at least one year... but I have them also available for testing if needed. If we can fix that tab as well that would be great, let me know if i should file a separate bug on it.

That's most likely because the radio has one or more settings that is/are out-of-range. The debug.log file should help to determine which settings are amiss so they can be set to a valid values.

Jim KC9HI

Updated by Hayden Thring 3 months ago

I have this radio too, I noticed you can open the exported .dat file of channels and its in a format that could likely be decoded easily. Anyway, i bought this radio knowing it wasnt supported by chirp, so no hassle. letme know if i can help

I use this software
https://www.qytradio.com/uploadfile/downloads/WP9900_CPS_ENG_PACK.rar

here is an empty channel followed by one configured

0  0  0  255  255  255  255  255  255  255  255  255  255  255  255  255  255  255  255 
0 1 1 0 37 67 20 0 37 67 20 0 0 0 0 0 0 0 4

Updated by Hayden Thring 3 months ago

oh and mine is branded as QYT KT-WP12

Updated by Jim Unroe 3 months ago

Hi all,

One thing that would really be useful would be to have the MCU-Version: from everyone's radio that is available for testing. The MCU-Version: can be found in the status display area at the bottom of the OEM software's main window.

List the following...
Vendor: (QYT, Anysecu, etc.)
Model: (KT-WP12, KT-9900, WP-9900, etc)
MCU-Version: (WP3094, etc)

Thanks,
Jim KC9HI

Updated by John Boal 3 months ago

Hi Jim - you were right on, the MCU version is WP3094. Attached is the screen capture from the WP9900_VIP_CPS.exe software attached to my Anysecu WP-9900 branded radio.

Hope this helps!

Updated by Jim Unroe about 1 month ago

John Boal wrote:

Hi Jim - you were right on, the MCU version is WP3094. Attached is the screen capture from the WP9900_VIP_CPS.exe software attached to my Anysecu WP-9900 branded radio.

Hope this helps!

Well John, I think we've waited patiently long enough. I thought there would have been some others chime in with the MCU version from their radio, but you appear to be the only one that took the time to provide it. Let's get to testing!

I am attaching an experimental driver module to this issue that should allow you to download from your WP-9900 with MCU WP3094. Once you have successfully downloaded from your radio, save the newly created tab to a CHIRP Radio Images (*.img) file. Then please attach the newly saved "image" to this issue so I can use it to assist in the process of developing support for the Anysecu WP-9900.

Here are the instructions for how you use the experimental driver module.

  1. save the test driver (WP-9900 MCU WP3094 - read test.py) to a convenient location on your computer. Note: Do not right-click the link to download. You must left-click the link and then choose the Download link near the top of the page that loads.
  2. load CHIRP
  3. click Help in the menu bar and then enable the Enable Developer Functions setting
  4. click File in the menu bar and then select Load Module in the list that appears
  5. locate and load the experimental driver module that was saved in step #1

At this point CHIRP should have a red background to let you know that it is running with an externally loaded driver module. Attempt to download from your radio choosing Vendor: Anysecu and Model: WP-9900. If successful, save the new tab to a CHIRP *.img file and attach it to this issue. If downloading fails, describe the error and attach a CHIRP debug.log file.

Note: Using this experimental driver module does not permanently change your CHIRP installation in any way. Once you close CHIRP and reopen it later, you will have to load the experimental driver module again before you can do any additional testing.

Jim KC9HI

Updated by John Boal about 1 month ago

Thanks Jim - but am not seeing a link to download a test.py driver... what am I missing?

Updated by Jim Unroe about 1 month ago

John Boal wrote:

Thanks Jim - but am not seeing a link to download a test.py driver... what am I missing?

I forgot to attach it. Sorry. Here it is.

Jim KC9HI

Updated by John Boal about 1 month ago

Success! attached is the image file. Thanks Jim!

Updated by Jim Unroe about 1 month ago

  • File btech_wp-9900_draft_#1.py added
  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe
  • Priority changed from High to Normal
  • Target version set to chirp-daily
  • % Done changed from 0 to 20

Hi Bob,

Before I forget, thank you for attaching the CHIRP "image" downloaded from your radio. It was very useful.

I have attached a draft driver module for you (and anyone else with an ANYSECU WP-9900 with MCU: WP3094) to test.

Things to test...
  • Downloading (be sure to save your first download, unedited, as a CHIRP Radio Images (*.img) file to be kept in a safe place as a backup <-- this is very important since we are testing new code)
  • Check to see that the settings tabs show up
  • Uploading
  • Check that the settings values match up with the corresponding settings of the OEM software (don't worry about 2tone and 5tone settings)

If you have any issues, please describe the details of the problem and attach any debug.log files, "images" file and/or screen captures that might help me to understand and resolve them.

I am looking forward to your feedback.

Jim KC9HI

Updated by Hayden Thring about 1 month ago

Hi, I successfully used the driver to upload 125 channels, inc some with offsets. I also tested the settings tab, they look ok, i did a manual test on the squelch setting which was fine.

attached is my initial img read, also wp3094

Updated by John Boal about 1 month ago

This also worked great for me - I copied and pasted all the memory channels from another radio and uploaded them successfully.

The only thing I found in error was the color "indigo" was spelled "indego"

thanks so much and 73!
John K9JEB

Updated by Jim Unroe about 1 month ago

John Boal wrote:

This also worked great for me - I copied and pasted all the memory channels from another radio and uploaded them successfully.

The only thing I found in error was the color "indigo" was spelled "indego"

thanks so much and 73!
John K9JEB

LOL. That spelling error has been like that for something like 5 years. You are the first to notice and say something about it. I'll have to open another ticket to fix it. Thanks.

Jim KC9HI

Updated by Sam Jones about 1 month ago

I just got my Anysecu branded version of this radio at the end of last week. Attached is my img file downloaded from the radio with the draft driver. Please note that I did add some channels using the QYT software (painfully slow due to no support for import/export and copy/past only works in a single cell...).

Using the draft driver I was quickly able to import all the channels I want and upload to the radio last night.

I only took a small look through the settings tab and it seems to have everything that the factory software has. I did previously use the factory software to update a number of the settings and it looks like all of those settings were correct/the same when I downloaded from the radio last night.

Excellent work and thank you for your help with this radio, Jim!

Updated by Matt Schnizer about 1 month ago

Got one of these radios (QYT KT-WP12). After fighting with original SW I found that chirp has experimental driver.
Using latest version of chirp (20220515) on Windows 10
Loaded WP-9900 MCU WP3094 - read test.py into Chirp
Downloaded image from radio
- can see channels
- NO Settings tab as with my other radios (see screenshot)

Tried to upload a change to channel:
Window pops up to ask for 'COM and VENDOR/MODEL' => click OK
Windows pops up with 'Anysecu-WP-9900 instructions' => click OK
Window pops up with 'Driver is experimental - wanna proceed' => click OK

A small windows pops up and disappears immediately. Unable what it says... thats it - nothing more

Updated by Matt Schnizer about 1 month ago

Here the 1st download from radio.

Anything else I can provide?

Updated by Jim Unroe about 1 month ago

Matt Schnizer wrote:

Got one of these radios (QYT KT-WP12). After fighting with original SW I found that chirp has experimental driver.
Using latest version of chirp (20220515) on Windows 10
Loaded WP-9900 MCU WP3094 - read test.py into Chirp
Downloaded image from radio
- can see channels
- NO Settings tab as with my other radios (see screenshot)

Tried to upload a change to channel:
Window pops up to ask for 'COM and VENDOR/MODEL' => click OK
Windows pops up with 'Anysecu-WP-9900 instructions' => click OK
Window pops up with 'Driver is experimental - wanna proceed' => click OK

A small windows pops up and disappears immediately. Unable what it says... thats it - nothing more

The "read_test.py" was just to test the cloning protocol and to provide me with a CHIRP Radio Images (*.img) that could be used for reverse engineering of the radios settings. There was, by design, no settings tabs or ability to upload to the radio.

So I gather that the QYT KT-WP12 has the same MCU version as the Anysecu WP9900, correct?

Jim KC9HI

Updated by Matt Schnizer about 1 month ago

correct, WP3094
Matt/K0MOS

Updated by Matt Schnizer about 1 month ago

Reading all your posts carefully I found the draft driver and the SETTINGS show up and are looking good and I can upload to the radio - Happy camper.
Thank you so much for the driver.

K0MOS/Matt

Updated by Jim Unroe about 1 month ago

I have added support for the QYT KT-WP12 to the draft driver module.

I am assuming that the settings for the Anysecu WP-9900 and QYT KT-WP12 (and QYT KT-9900) are the same. Let me know if that is not the case. For those with the QYT KT-9900 model, use the Vendor: QYT / Model: KT-WP12 selections.

Jim KC9HI

Updated by Matt Schnizer about 1 month ago

Tnx Jim, working fine here :)

Updated by Jim Unroe about 1 month ago

Found a bug related to the Auto Lock setting. Draft #3 attached.

Other than the very old spelling error, has anyone found anything else that needs addressed?

Jim KC9HI

Updated by Matt Schnizer about 1 month ago

Working fine here, thanks for the updated version.
Matt/K0MOS

Updated by Jim Unroe about 1 month ago

Patches to add support for the Anysecu WP-9900 and QYT KT-WP12 to CHIRP have been submitted. Support will be in the next CHIRP daily build following acceptance.

Thanks to the anonymous donor of the Anysecu WP-9900 that was used for CHIRP development.

The "test" images that are to be added to CHIRP have been attached to this issue. I can no longer submit them as attachments to the patches because Gmail blocks them.

Jim KC9HI

Updated by Jim Unroe about 1 month ago

  • Status changed from Resolved to Closed

Today's build, CHIRP daily-20220531, now has support for the Anysecu WP-9900 and QYT KT-WP12 (for KT-9900 use KT-WP12).

Jim KC9HI

Also available in: Atom PDF