Project

General

Profile

Actions

New Model #10458

closed

RADTEL RT-470-L

Added by JORGE GÓMEZ over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
03/19/2023
Due date:
% Done:

100%

Estimated time:
Equipment Loan/Gift Offered:
I read the instructions above:

Description

Frecuencias admitidas:

1) 136-180 MHz (RX/TX)
2) 200-260 MHz (RX/TX)
3) 350-400 MHz (RX/TX)
4) 400-520 MHz (RX/TX)
5) 108-136 MHz (AM RX) - Solo recepción de banda aérea
6) 66-108 MHz (FM RX) - RADIO FM

Características:

Admite la recepción del canal meteorológico NOAA de EE. UU.
Frecuencia de copia de una tecla (captura automática de frecuencia) sin programación de PC
Potencia de salida 10w para algunas bandas (no para todas las bandas)
Tiempo de espera de transmisión
Función de salto de frecuencia
8 pasos: 2,5k, 5k, 6,25k, 10k, 12,5k, 20k, 25k, 50k
Modo de ahorro de energía
VOX
Admite cifrado de voz.
El canal está ocupado y la transmisión está prohibida
Advertencia de batería baja, pantalla de voltaje de la batería, punto alto y bajo prohibido
Retroiluminación automática
Modos de visualización de tres canales (frecuencia, número de canal, nombre del canal)
Tres métodos de escaneo (tiempo, portador, búsqueda)
La dirección de la diferencia de frecuencia se puede seleccionar en el modo de frecuencia
En el modo de frecuencia, la frecuencia de diferencia de frecuencia se puede seleccionar entre 0-99.9995MHz
Los parámetros del canal se pueden editar y almacenar en modo de frecuencia
256 canales de almacenamiento (128x2 grupos)
Alarma de emergencia
Función de cifrado de voz
función de código DTMF
Admite la personalización de la interfaz de arranque
Radio FM
Programación de computadoras
Punto de espera de doble frecuencia


Files

RADTEL RT-470-L.jpg (353 KB) RADTEL RT-470-L.jpg my configuration handy rt-470-l JORGE GÓMEZ, 03/27/2023 09:57 AM
mml_jc_8810-v0.2.py (18.3 KB) mml_jc_8810-v0.2.py Test driver. Download only. Jim Unroe, 03/28/2023 12:10 PM
IMG202303282246461.jpg (464 KB) IMG202303282246461.jpg JORGE GÓMEZ, 03/28/2023 01:53 PM
IMG202303282247011.jpg (360 KB) IMG202303282247011.jpg JORGE GÓMEZ, 03/28/2023 01:53 PM
ShowDebugLogLocation.png (54.8 KB) ShowDebugLogLocation.png Jim Unroe, 03/29/2023 05:24 AM
chirp_debug-6y1jo0z2.txt (6.32 KB) chirp_debug-6y1jo0z2.txt debug rt470l JORGE GÓMEZ, 03/29/2023 10:07 AM
mml_jc_8810-v0.4.py (18.4 KB) mml_jc_8810-v0.4.py Test driver. Download only. Adds fingerprint for RT-470L. Jim Unroe, 03/29/2023 01:12 PM
chirp_debug-e57qvnuj.txt (5.59 KB) chirp_debug-e57qvnuj.txt JORGE GÓMEZ, 03/30/2023 11:19 AM
radtel-error.jpg (383 KB) radtel-error.jpg JORGE GÓMEZ, 03/30/2023 11:21 AM
chirp_debug-pdjyciu0.txt (397 KB) chirp_debug-pdjyciu0.txt JORGE GÓMEZ, 03/30/2023 12:06 PM
Radtel_RT-470L_20230330.img (44.9 KB) Radtel_RT-470L_20230330.img JORGE GÓMEZ, 03/30/2023 12:08 PM
radtel-ok.jpg (342 KB) radtel-ok.jpg JORGE GÓMEZ, 03/30/2023 12:09 PM
mml_jc_8810-v0.5.py (17.9 KB) mml_jc_8810-v0.5.py Test driver. Download & upload. Jim Unroe, 03/30/2023 12:34 PM
chirp_debug-2nix0rfu.txt (397 KB) chirp_debug-2nix0rfu.txt JORGE GÓMEZ, 03/30/2023 12:59 PM
Radtel_RT-470L_202303301.img (44.9 KB) Radtel_RT-470L_202303301.img JORGE GÓMEZ, 03/30/2023 12:59 PM
mml_jc_8810-v0.7.py (36.4 KB) mml_jc_8810-v0.7.py Test driver. Adds settings tabs. Jim Unroe, 03/31/2023 07:18 PM
mml_jc_8810-v0.8.py (36.5 KB) mml_jc_8810-v0.8.py add my fingerprint Juan Manuel Puñal Bargueño, 04/01/2023 12:58 AM
chirp_debug-phgnvmi5.txt (2.29 KB) chirp_debug-phgnvmi5.txt Juan Manuel Puñal Bargueño, 04/01/2023 12:58 AM
Captura de pantalla 2023-04-01 095336.png (212 KB) Captura de pantalla 2023-04-01 095336.png Juan Manuel Puñal Bargueño, 04/01/2023 12:58 AM
IMG_20230401_102533_copy_835x1856.jpg (326 KB) IMG_20230401_102533_copy_835x1856.jpg Juan Manuel Puñal Bargueño, 04/01/2023 01:29 AM
chirp_debug-1myqxl8p.txt (397 KB) chirp_debug-1myqxl8p.txt JORGE GÓMEZ, 04/01/2023 01:35 AM
Radtel_RT-470L_20230401.img (44.9 KB) Radtel_RT-470L_20230401.img JORGE GÓMEZ, 04/01/2023 01:36 AM
chirp_debug-6o1vfel8.txt (871 KB) chirp_debug-6o1vfel8.txt JORGE GÓMEZ, 04/01/2023 02:11 AM
Radtel_RT-470L_20230401.img (51.5 KB) Radtel_RT-470L_20230401.img JORGE GÓMEZ, 04/01/2023 02:11 AM
RT-470 Menu List (00-50).txt (643 Bytes) RT-470 Menu List (00-50).txt Jim Unroe, 04/01/2023 05:15 AM
RT-470L Menu List (00-56).txt (728 Bytes) RT-470L Menu List (00-56).txt Juan Manuel Puñal Bargueño, 04/01/2023 12:55 PM
IMG_20230401_213944_copy_940x1633_1.jpg (487 KB) IMG_20230401_213944_copy_940x1633_1.jpg Juan Manuel Puñal Bargueño, 04/01/2023 12:57 PM
Radtel_RT-470L_PF3LongPress_Off.img (44.9 KB) Radtel_RT-470L_PF3LongPress_Off.img Juan Manuel Puñal Bargueño, 04/01/2023 04:40 PM
Radtel_RT-470L_PF3LongPress_MONI.img (44.9 KB) Radtel_RT-470L_PF3LongPress_MONI.img Juan Manuel Puñal Bargueño, 04/01/2023 04:40 PM
Radtel_RT-470L_TopKey_Off.img (44.9 KB) Radtel_RT-470L_TopKey_Off.img Juan Manuel Puñal Bargueño, 04/01/2023 04:40 PM
Radtel_RT-470L_TopKey_MONI.img (44.9 KB) Radtel_RT-470L_TopKey_MONI.img Juan Manuel Puñal Bargueño, 04/01/2023 04:40 PM
Radtel_RT-470L_TailFreq_55Hz.img (44.9 KB) Radtel_RT-470L_TailFreq_55Hz.img Juan Manuel Puñal Bargueño, 04/01/2023 04:40 PM
Radtel_RT-470L_TailFreq_62.5Hz.img (44.9 KB) Radtel_RT-470L_TailFreq_62.5Hz.img Juan Manuel Puñal Bargueño, 04/01/2023 04:40 PM
mml_jc_8810-v0.9.py (38.3 KB) mml_jc_8810-v0.9.py Test driver. Adds RT-470L specific settings Jim Unroe, 04/01/2023 06:15 PM
Radtel_RT-470L_20230402.img (44.9 KB) Radtel_RT-470L_20230402.img JORGE GÓMEZ, 04/01/2023 10:37 PM
chirp_debug-zi7yzxwe.txt (398 KB) chirp_debug-zi7yzxwe.txt JORGE GÓMEZ, 04/01/2023 10:37 PM
chirp_debug-4g3h6zra.zip (128 KB) chirp_debug-4g3h6zra.zip Juan Manuel Puñal Bargueño, 04/02/2023 03:54 PM
RT-470L_FM_FM_62.png (464 KB) RT-470L_FM_FM_62.png Juan Manuel Puñal Bargueño, 04/02/2023 03:54 PM
RT-470L_LAMP_LAMP_62.png (476 KB) RT-470L_LAMP_LAMP_62.png Juan Manuel Puñal Bargueño, 04/02/2023 03:54 PM
RT-470L_MONI_MONI_62.png (476 KB) RT-470L_MONI_MONI_62.png Juan Manuel Puñal Bargueño, 04/02/2023 03:54 PM
RT-470L_NOAA_NOAA_55.png (482 KB) RT-470L_NOAA_NOAA_55.png Juan Manuel Puñal Bargueño, 04/02/2023 03:54 PM
RT-470L_OFF_OFF_55.png (462 KB) RT-470L_OFF_OFF_55.png Juan Manuel Puñal Bargueño, 04/02/2023 03:54 PM
RT-470L_SCAN_SCAN_62.png (478 KB) RT-470L_SCAN_SCAN_62.png Juan Manuel Puñal Bargueño, 04/02/2023 03:54 PM
RT-470L_SEARCH_SEARCH_55.png (476 KB) RT-470L_SEARCH_SEARCH_55.png Juan Manuel Puñal Bargueño, 04/02/2023 03:55 PM
RT-470L_TX_TX_55.png (482 KB) RT-470L_TX_TX_55.png Juan Manuel Puñal Bargueño, 04/02/2023 03:55 PM
chirp_debug-0mivqa3u.txt (8.94 KB) chirp_debug-0mivqa3u.txt Aaron McClure, 04/26/2023 08:19 PM
mml_jc_8810-v1.0.py (38.4 KB) mml_jc_8810-v1.0.py Jim Unroe, 04/27/2023 03:35 AM
Radtel_RT-470L_20230427.img (44.9 KB) Radtel_RT-470L_20230427.img .img file with KEYS OFF Aaron McClure, 04/27/2023 08:18 PM
mml_jc_8810-v1.1.py (38.7 KB) mml_jc_8810-v1.1.py Jim Unroe, 04/28/2023 04:21 AM
Radtel_RT-470L_20230428.img (44.9 KB) Radtel_RT-470L_20230428.img Aaron McClure, 04/28/2023 08:23 PM
chirp_debug-19oi082i.txt (743 KB) chirp_debug-19oi082i.txt Aaron McClure, 04/28/2023 08:50 PM
Radtel_RT-470L_20230428.img.txt (44.9 KB) Radtel_RT-470L_20230428.img.txt Aaron McClure, 04/28/2023 08:51 PM
mml_jc_8810-v1.2.py (38.2 KB) mml_jc_8810-v1.2.py Update band limits to match RT-470L Jim Unroe, 05/03/2023 08:22 AM
mml_jc_8810-v1.3.py (38.9 KB) mml_jc_8810-v1.3.py Jim Unroe, 05/05/2023 07:32 PM
Actions #1

Updated by Jim Unroe about 1 year ago

This is basically a duplicate of issue #10354 which I am working on when I can. Do you happen to know what the difference is between the RT-470 and RT-470-L?

Jim KC9HI

Actions #2

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-1:

This is basically a duplicate of issue #10354 which I am working on when I can. Do you happen to know what the difference is between the RT-470 and RT-470-L?

Jim KC9HI

only difference RT-470-L output power 5 wats and RT-470 output power 10 wats.

Actions #3

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-2:

Jim Unroe wrote in #note-1:

This is basically a duplicate of issue #10354 which I am working on when I can. Do you happen to know what the difference is between the RT-470 and RT-470-L?

Jim KC9HI

only difference RT-470-L output power 5 wats and RT-470 output power 10 wats.

Thank you for your reply. This is useful information. The RT-470 has 3 TX power level choices (H, M and L). Does the RT-470-L have 2 or 3 TX power level choices?

Jim KC9HI

Actions #4

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-3:

JORGE GÓMEZ wrote in #note-2:

Jim Unroe wrote in #note-1:

This is basically a duplicate of issue #10354 which I am working on when I can. Do you happen to know what the difference is between the RT-470 and RT-470-L?

Jim KC9HI

only difference RT-470-L output power 5 wats and RT-470 output power 10 wats.

Thank you for your reply. This is useful information. The RT-470 has 3 TX power level choices (H, M and L). Does the RT-470-L have 2 or 3 TX power level choices?

Jim KC9HI

My handy RT-470-L have 3 power level (H, M and L)

Actions #5

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-4:

My handy RT-470-L have 3 power level (H, M and L)

Would you be able to measure the TX power level for each setting? The manual that came with the radio and the one I downloaded only show 2 power levels (2W, 5W). I will try to find time to hook up a watt meter and measure mine today.

Thanks,
Jim KC9HI

Actions #6

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-5:

JORGE GÓMEZ wrote in #note-4:

My handy RT-470-L have 3 power level (H, M and L)

Would you be able to measure the TX power level for each setting? The manual that came with the radio and the one I downloaded only show 2 power levels (2W, 5W). I will try to find time to hook up a watt meter and measure mine today.

Thanks,
Jim KC9HI

i don`t have a power meter, sorry.

Actions #7

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-6:

Jim Unroe wrote in #note-5:

JORGE GÓMEZ wrote in #note-4:

My handy RT-470-L have 3 power level (H, M and L)

Would you be able to measure the TX power level for each setting? The manual that came with the radio and the one I downloaded only show 2 power levels (2W, 5W). I will try to find time to hook up a watt meter and measure mine today.

Thanks,
Jim KC9HI

i don`t have a power meter, sorry.

Not a problem. I measured 10, 8 and 4 watts from my radio. Please follow issue #10354 to keep up with my progress as I continue my work on these radios. Thank you for your help and participation.

Jim KC9HI

Actions #8

Updated by Jim Unroe about 1 year ago

JORGE,

Yesterday I discovered a good reason to keep this issue open and separate for the Radtel RT-470L. I recently noticed that on the Radtel website there was a new version of factory programming software available of the RT-470L model. It has some additional settings for the programmable function keys that the original RT-470 programming software doesn't have.

While testing that software on my RT-470, I have discovered that these additional settings have on affect on my radio. Would you be willing to test this later version on this your radio to see if the work? If you are, I can provide you with a few things that I would like you to test.

Thanks,
Jim

Actions #9

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-8:

JORGE,

Yesterday I discovered a good reason to keep this issue open and separate for the Radtel RT-470L. I recently noticed that on the Radtel website there was a new version of factory programming software available of the RT-470L model. It has some additional settings for the programmable function keys that the original RT-470 programming software doesn't have.

While testing that software on my RT-470, I have discovered that these additional settings have on affect on my radio. Would you be willing to test this later version on this your radio to see if the work? If you are, I can provide you with a few things that I would like you to test.

Thanks,
Jim

of course my friend¡¡¡¡

Actions #10

Updated by Jim Unroe about 1 year ago

When it is convenient would you download the latest factory software (if you don't already have it - see link below) and perform the listed tests.

Download software number 28-3 from the Radtel software download page: https://www.radtels.com/pages/software-download

This new programming software has 2 settings that do nothing on my radio (RT-470 firmware v1.15). I am interested in knowing if they work on your radio. If they do, then I will provide you with so additional things to test.

  1. Skey3 Long: No matter what I set this setting to, a long press only performs the MONI function (opens squelch and overrides any RX CTCSS tone or DCS code). Probably the simplest thing to do would be to set it to Tx Power and then long press the bottom side key to see if the selected TX power level changes.

  2. Top Key: Similar situation. No matter what I change this setting to, a short press of the top (orange) button does nothing. Again I would suggest setting this setting to Tx Power and then short press this top button to see if the TX Power level changes.

  3. The Tail Code setting is the third setting that is not on the RT-470 software. I'm not clear on a good way to test this setting so I don't know if it does anything on my radio or not.

Thanks,
Jim KC9HI

Actions #11

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-10:

When it is convenient would you download the latest factory software (if you don't already have it - see link below) and perform the listed tests.

Download software number 28-3 from the Radtel software download page: https://www.radtels.com/pages/software-download

This new programming software has 2 settings that do nothing on my radio (RT-470 firmware v1.15). I am interested in knowing if they work on your radio. If they do, then I will provide you with so additional things to test.

  1. Skey3 Long: No matter what I set this setting to, a long press only performs the MONI function (opens squelch and overrides any RX CTCSS tone or DCS code). Probably the simplest thing to do would be to set it to Tx Power and then long press the bottom side key to see if the selected TX power level changes.

  2. Top Key: Similar situation. No matter what I change this setting to, a short press of the top (orange) button does nothing. Again I would suggest setting this setting to Tx Power and then short press this top button to see if the TX Power level changes.

  3. The Tail Code setting is the third setting that is not on the RT-470 software. I'm not clear on a good way to test this setting so I don't know if it does anything on my radio or not.

Thanks,
Jim KC9HI

Short press upper orange button, scan VFO , long press activates loud audible alarm.
PF2 button each press changes the emission power, H, M and L.
pressing the PF3 button activates the flashlight and a long press removes the squelch momentaril.
Jorge EA4HPW

Actions #12

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-11:

Short press upper orange button, scan VFO , long press activates loud audible alarm.
PF2 button each press changes the emission power, H, M and L.
pressing the PF3 button activates the flashlight and a long press removes the squelch momentaril.
Jorge EA4HPW

Thank you. Are you able to change PF3 key long and Top key short to something else using the programming software ( Skey3 Long and Top Key )?

Jim KC9HI

Actions #13

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-12:

JORGE GÓMEZ wrote in #note-11:

Short press upper orange button, scan VFO , long press activates loud audible alarm.
PF2 button each press changes the emission power, H, M and L.
pressing the PF3 button activates the flashlight and a long press removes the squelch momentaril.
Jorge EA4HPW

Thank you. Are you able to change PF3 key long and Top key short to something else using the programming software ( Skey3 Long and Top Key )?

Jim KC9HI

if these buttons are programmable on the RT-470-L, this functionality is described in the handy user manual
Jorge EA4HPW

Actions #14

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-13:

if these buttons are programmable on the RT-470-L, this functionality is described in the handy user manual

I am trying to determine if they are actually programmable. Just because a setting is in the software (or mentioned in the manual) does not always mean the setting is implemented in the radio. That is why I am trying to find someone willing to physically test the function of these settings before I waste my time trying to implement settings that don't work. If it is not possible for you to test them, then I will just leave them out until I can find someone that can test them.

Thanks,
Jim KC9HI

Actions #15

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-14:

JORGE GÓMEZ wrote in #note-13:

if these buttons are programmable on the RT-470-L, this functionality is described in the handy user manual

I am trying to determine if they are actually programmable. Just because a setting is in the software (or mentioned in the manual) does not always mean the setting is implemented in the radio. That is why I am trying to find someone willing to physically test the function of these settings before I waste my time trying to implement settings that don't work. If it is not possible for you to test them, then I will just leave them out until I can find someone that can test them.

Thanks,
Jim KC9HI

Actions #16

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-15:

Jim Unroe wrote in #note-14:

JORGE GÓMEZ wrote in #note-13:

if these buttons are programmable on the RT-470-L, this functionality is described in the handy user manual

I am trying to determine if they are actually programmable. Just because a setting is in the software (or mentioned in the manual) does not always mean the setting is implemented in the radio. That is why I am trying to find someone willing to physically test the function of these settings before I waste my time trying to implement settings that don't work. If it is not possible for you to test them, then I will just leave them out until I can find someone that can test them.

Here I send you the configuration of the handy buttons, it has more options but for me this is the correct one, they can be changed to your liking and in my case they take effect when saving the configuration.
Jorge EA4HPW

Thanks,
Jim KC9HI

Actions #17

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-16:

JORGE GÓMEZ wrote in #note-15:

Jim Unroe wrote in #note-14:

JORGE GÓMEZ wrote in #note-13:

if these buttons are programmable on the RT-470-L, this functionality is described in the handy user manual

I am trying to determine if they are actually programmable. Just because a setting is in the software (or mentioned in the manual) does not always mean the setting is implemented in the radio. That is why I am trying to find someone willing to physically test the function of these settings before I waste my time trying to implement settings that don't work. If it is not possible for you to test them, then I will just leave them out until I can find someone that can test them.

Here I send you the configuration of the handy buttons, it has more options but for me this is the correct one, they can be changed to your liking and in my case they take effect when saving the configuration.
Jorge EA4HPW

Thanks,
Jim KC9HI

I am apparently not explaining what I am wanting sufficiently for you to understand. Sorry.

See where it shows Skey3 Long = MONI in the picture that you attached. I want you to temporarily change it to TX Power and upload it to your radio and then confirm that a long press of the PF3 key will actually switch the selected TX Power level. In my radio it won't change, a long press of PF3 is always MONI, no matter what. I am trying to to make sure that your radio is not the same way.

Then I was a similar test for the Top Key to make sure it can be changed in your radio. In my radio a short press of the Top Key is always OFF.

If the changes don't take effect in your radio, there is no reason to implement the settings. But if they do work, I want CHIRP to be able to edit the settings.

Jim KC9HI

Actions #18

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-17:

JORGE GÓMEZ wrote in #note-16:

JORGE GÓMEZ wrote in #note-15:

Jim Unroe wrote in #note-14:

JORGE GÓMEZ wrote in #note-13:

if these buttons are programmable on the RT-470-L, this functionality is described in the handy user manual

I am trying to determine if they are actually programmable. Just because a setting is in the software (or mentioned in the manual) does not always mean the setting is implemented in the radio. That is why I am trying to find someone willing to physically test the function of these settings before I waste my time trying to implement settings that don't work. If it is not possible for you to test them, then I will just leave them out until I can find someone that can test them.

Here I send you the configuration of the handy buttons, it has more options but for me this is the correct one, they can be changed to your liking and in my case they take effect when saving the configuration.
Jorge EA4HPW

Thanks,
Jim KC9HI

I am apparently not explaining what I am wanting sufficiently for you to understand. Sorry.

See where it shows Skey3 Long = MONI in the picture that you attached. I want you to temporarily change it to TX Power and upload it to your radio and then confirm that a long press of the PF3 key will actually switch the selected TX Power level. In my radio it won't change, a long press of PF3 is always MONI, no matter what. I am trying to to make sure that your radio is not the same way.

Then I was a similar test for the Top Key to make sure it can be changed in your radio. In my radio a short press of the Top Key is always OFF.

If the changes don't take effect in your radio, there is no reason to implement the settings. But if they do work, I want CHIRP to be able to edit the settings.

Jim KC9HI
I'll have to wait until tomorrow to do it, I don't have the handy here with me, don't worry tomorrow we'll clear up any doubts, my friend.
Jorge EA4HPW

Actions #19

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-18:

I'll have to wait until tomorrow to do it, I don't have the handy here with me, don't worry tomorrow we'll clear up any doubts, my friend.
Jorge EA4HPW

No rush. Whenever it is convenient for you. I still have plenty to do! ;-)

Jim KC9HI

Actions #20

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-19:

JORGE GÓMEZ wrote in #note-18:

I'll have to wait until tomorrow to do it, I don't have the handy here with me, don't worry tomorrow we'll clear up any doubts, my friend.
Jorge EA4HPW

No rush. Whenever it is convenient for you. I still have plenty to do! ;-)

Jim KC9HI

Hello friend, I just tested the programming functions of the side buttons of the handy, both the short skey2 and the long skey2 and the short skey3 are programmable with the functions OFF, FM, TX POWER, SCAN, SEARCH, LAMP, WEATHER, MONI , ETC ETC.
The only skey3 long button is not programmable, it only has the MONITOR function, I have tried this key with all the modalities and it does not record them.
As I told you, skey3 long only acts as a MONITOR.
I hope it is of your help, greetings from Spain.
Jorge EA4HPW

Actions #21

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-20:

Hello friend, I just tested the programming functions of the side buttons of the handy, both the short skey2 and the long skey2 and the short skey3 are programmable with the functions OFF, FM, TX POWER, SCAN, SEARCH, LAMP, WEATHER, MONI , ETC ETC.
The only skey3 long button is not programmable, it only has the MONITOR function, I have tried this key with all the modalities and it does not record them.
As I told you, skey3 long only acts as a MONITOR.
I hope it is of your help, greetings from Spain.
Jorge EA4HPW

Thank you so much for testing this. Your findings with your RT-470L and my findings with my RT-470 are identical. Either the new RT-470L programming software is incorrect or Radtel intends to, or already has, release a firmware version that supports those settings. So for the time being I will leave those setting out of CHIRP. I don't want to confuse anybody adding settings will not work.

I will be attaching a driver module soon for you to test. Thank you again for your valuable testing.

Jim KC9HI

Actions #22

Updated by Jim Unroe about 1 year ago

Let's see if the attached test driver module can read your radio. To use it follow the instructions here: LoadingTestModules.

Vendor: Radtel
Model: RT-470L

If a download is successful, please attach the downloaded image to this issue. In the Optional Description field include the actual Vendor/Model of your radio and its firmware version (menu 50).

Thank you,
Jim KC9HI

Actions #23

Updated by Jim Unroe about 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-py3
  • % Done changed from 0 to 10

Jim Unroe wrote in #note-22:

Let's see if the attached test driver module can read your radio. To use it follow the instructions here: LoadingTestModules.

Vendor: Radtel
Model: RT-470L

If a download is successful, please attach the downloaded image to this issue. In the Optional Description field include the actual Vendor/Model of your radio and its firmware version (menu 50).

Thank you,
Jim KC9HI

Actions #24

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-23:

Jim Unroe wrote in #note-22:

Let's see if the attached test driver module can read your radio. To use it follow the instructions here: LoadingTestModules.

Vendor: Radtel
Model: RT-470L

If a download is successful, please attach the downloaded image to this issue. In the Optional Description field include the actual Vendor/Model of your radio and its firmware version (menu 50).

Thank you,
Jim KC9HI

Actions #25

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-24:

Jim Unroe wrote in #note-23:

Jim Unroe wrote in #note-22:

Let's see if the attached test driver module can read your radio. To use it follow the instructions here: LoadingTestModules.

Vendor: Radtel
Model: RT-470L

If a download is successful, please attach the downloaded image to this issue. In the Optional Description field include the actual Vendor/Model of your radio and its firmware version (menu 50).

my freind, not read handy :(

Thank you,
Jim KC9HI

Actions #26

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-25:

JORGE GÓMEZ wrote in #note-24:

Jim Unroe wrote in #note-23:

Jim Unroe wrote in #note-22:

Let's see if the attached test driver module can read your radio. To use it follow the instructions here: LoadingTestModules.

Vendor: Radtel
Model: RT-470L

If a download is successful, please attach the downloaded image to this issue. In the Optional Description field include the actual Vendor/Model of your radio and its firmware version (menu 50).

my freind, not read handy :(

Thank you,
Jim KC9HI

Try the test driver v0.3 that is available from issue #10354. It adds support for an additional "identification string". If that still doesn't work, then you must create the error and then attach the debug log so I can "see" what "identification string" your radio returns.

Jim

Actions #27

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-26:

JORGE GÓMEZ wrote in #note-25:

JORGE GÓMEZ wrote in #note-24:

Jim Unroe wrote in #note-23:

Jim Unroe wrote in #note-22:

Let's see if the attached test driver module can read your radio. To use it follow the instructions here: LoadingTestModules.

Vendor: Radtel
Model: RT-470L

If a download is successful, please attach the downloaded image to this issue. In the Optional Description field include the actual Vendor/Model of your radio and its firmware version (menu 50).

my freind, not read handy :(

Thank you,
Jim KC9HI

Try the test driver v0.3 that is available from issue #10354. It adds support for an additional "identification string". If that still doesn't work, then you must create the error and then attach the debug log so I can "see" what "identification string" your radio returns.

Jim

Actions #28

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-27:

Jim Unroe wrote in #note-26:

JORGE GÓMEZ wrote in #note-25:

JORGE GÓMEZ wrote in #note-24:

Jim Unroe wrote in #note-23:

Jim Unroe wrote in #note-22:

Let's see if the attached test driver module can read your radio. To use it follow the instructions here: LoadingTestModules.

Vendor: Radtel
Model: RT-470L

If a download is successful, please attach the downloaded image to this issue. In the Optional Description field include the actual Vendor/Model of your radio and its firmware version (menu 50).

my freind, not read handy :(

Thank you,
Jim KC9HI

Try the test driver v0.3 that is available from issue #10354. It adds support for an additional "identification string". If that still doesn't work, then you must create the error and then attach the debug log so I can "see" what "identification string" your radio returns.

Jim

hello, no read walkie anyway :( send you debug archive.

Actions #29

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

Jim KC9HI

Actions #30

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Actions #31

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Actions #32

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-31:

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Thank you for the new debug.log file. Unlike from your previous debug.log file, there is no response at all from your radio. This would indicate a problem with you programming cable and/or computer. If this is the case, the factory programming software would also fail.

Double check to make sure the programming cable is fully plugged into the radio. Sometimes the port cover can get in the way and interfere with the plug.

Make sure you can read from your radio using the factory software and if successful switch to CHIRP to see what happens.

Jim KC9HI

Actions #33

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-32:

JORGE GÓMEZ wrote in #note-31:

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

SORRY
i dont conect

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Thank you for the new debug.log file. Unlike from your previous debug.log file, there is no response at all from your radio. This would indicate a problem with you programming cable and/or computer. If this is the case, the factory programming software would also fail.

Double check to make sure the programming cable is fully plugged into the radio. Sometimes the port cover can get in the way and interfere with the plug.

Make sure you can read from your radio using the factory software and if successful switch to CHIRP to see what happens.

Jim KC9HI

Jim Unroe wrote in #note-32:

JORGE GÓMEZ wrote in #note-31:

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Thank you for the new debug.log file. Unlike from your previous debug.log file, there is no response at all from your radio. This would indicate a problem with you programming cable and/or computer. If this is the case, the factory programming software would also fail.

Double check to make sure the programming cable is fully plugged into the radio. Sometimes the port cover can get in the way and interfere with the plug.

Make sure you can read from your radio using the factory software and if successful switch to CHIRP to see what happens.

Jim KC9HI

sorry dont conect cable on to walkie talkie

Actions #34

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-33:

Jim Unroe wrote in #note-32:

JORGE GÓMEZ wrote in #note-31:

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

SORRY
i dont conect

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Thank you for the new debug.log file. Unlike from your previous debug.log file, there is no response at all from your radio. This would indicate a problem with you programming cable and/or computer. If this is the case, the factory programming software would also fail.

Double check to make sure the programming cable is fully plugged into the radio. Sometimes the port cover can get in the way and interfere with the plug.

Make sure you can read from your radio using the factory software and if successful switch to CHIRP to see what happens.

Jim KC9HI

Jim Unroe wrote in #note-32:

JORGE GÓMEZ wrote in #note-31:

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Thank you for the new debug.log file. Unlike from your previous debug.log file, there is no response at all from your radio. This would indicate a problem with you programming cable and/or computer. If this is the case, the factory programming software would also fail.

Double check to make sure the programming cable is fully plugged into the radio. Sometimes the port cover can get in the way and interfere with the plug.

Make sure you can read from your radio using the factory software and if successful switch to CHIRP to see what happens.

Jim KC9HI

sorry dont conect cable on to walkie talkie

Actions #35

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-34:

JORGE GÓMEZ wrote in #note-33:

Jim Unroe wrote in #note-32:

JORGE GÓMEZ wrote in #note-31:

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

SORRY
i dont conect

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Thank you for the new debug.log file. Unlike from your previous debug.log file, there is no response at all from your radio. This would indicate a problem with you programming cable and/or computer. If this is the case, the factory programming software would also fail.

Double check to make sure the programming cable is fully plugged into the radio. Sometimes the port cover can get in the way and interfere with the plug.

Make sure you can read from your radio using the factory software and if successful switch to CHIRP to see what happens.

Jim KC9HI

Jim Unroe wrote in #note-32:

JORGE GÓMEZ wrote in #note-31:

JORGE GÓMEZ wrote in #note-30:

Jim Unroe wrote in #note-29:

JORGE GÓMEZ wrote in #note-28:

hello, no read walkie anyway :( send you debug archive.

Thank you for the debug.log file. It would appear that the RT-470L has its own "identification string". When it is convenient, would you give test driver v0.4 a try.

Jim KC9HI

hello
send you new archive debug from test driver v0.4

Thank you for the new debug.log file. Unlike from your previous debug.log file, there is no response at all from your radio. This would indicate a problem with you programming cable and/or computer. If this is the case, the factory programming software would also fail.

Double check to make sure the programming cable is fully plugged into the radio. Sometimes the port cover can get in the way and interfere with the plug.

Make sure you can read from your radio using the factory software and if successful switch to CHIRP to see what happens.

Jim KC9HI

sorry dont conect cable on to walkie talkie

Actions #36

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-35:

sorry dont conect cable on to walkie talkie

I have done that myself many times! I am grateful that you have now successfully downloaded from your radio. I am now attaching v0.5 for you to test. It has latest code and should work for both download and upload.

Before trying to do any uploading, be sure to make a fresh download from your radio and save it, unedited, to a CHIRP Radio Images (*.img) file to be kept in a safe place as a back up.

Thank you for your testing.
Jim KC9HI

Actions #37

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-36:

JORGE GÓMEZ wrote in #note-35:

sorry dont conect cable on to walkie talkie

I have done that myself many times! I am grateful that you have now successfully downloaded from your radio. I am now attaching v0.5 for you to test. It has latest code and should work for both download and upload.

Before trying to do any uploading, be sure to make a fresh download from your radio and save it, unedited, to a CHIRP Radio Images (*.img) file to be kept in a safe place as a back up.

Thank you for your testing.
Jim KC9HI
send you new arcive debug from v0.5 and archive (img) radtel chirp.

Actions #38

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-37:

Jim Unroe wrote in #note-36:

JORGE GÓMEZ wrote in #note-35:

sorry dont conect cable on to walkie talkie

I have done that myself many times! I am grateful that you have now successfully downloaded from your radio. I am now attaching v0.5 for you to test. It has latest code and should work for both download and upload.

Before trying to do any uploading, be sure to make a fresh download from your radio and save it, unedited, to a CHIRP Radio Images (*.img) file to be kept in a safe place as a back up.

Thank you for your testing.
Jim KC9HI
send you new arcive debug from v0.5 and archive (img) radtel chirp.

Success? Yes/No?

Actions #39

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-38:

JORGE GÓMEZ wrote in #note-37:

Jim Unroe wrote in #note-36:

JORGE GÓMEZ wrote in #note-35:

sorry dont conect cable on to walkie talkie

I have done that myself many times! I am grateful that you have now successfully downloaded from your radio. I am now attaching v0.5 for you to test. It has latest code and should work for both download and upload.

Before trying to do any uploading, be sure to make a fresh download from your radio and save it, unedited, to a CHIRP Radio Images (*.img) file to be kept in a safe place as a back up.

Thank you for your testing.
Jim KC9HI
send you new arcive debug from v0.5 and archive (img) radtel chirp.

Success? Yes/No?

yes¡¡¡

Actions #40

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-39:

Jim Unroe wrote in #note-38:

JORGE GÓMEZ wrote in #note-37:

Jim Unroe wrote in #note-36:

JORGE GÓMEZ wrote in #note-35:

sorry dont conect cable on to walkie talkie

I have done that myself many times! I am grateful that you have now successfully downloaded from your radio. I am now attaching v0.5 for you to test. It has latest code and should work for both download and upload.

Before trying to do any uploading, be sure to make a fresh download from your radio and save it, unedited, to a CHIRP Radio Images (*.img) file to be kept in a safe place as a back up.

Thank you for your testing.
Jim KC9HI
send you new arcive debug from v0.5 and archive (img) radtel chirp.

Success? Yes/No?

yes¡¡¡

my friend, tomorrow we continue with the test, here it is already late to go to work.
good night here from Spain.
Jorge EA4HPW

Actions #41

Updated by Jim Unroe about 1 year ago

JORGE GÓMEZ wrote in #note-40:

Success? Yes/No?

yes¡¡¡

my friend, tomorrow we continue with the test, here it is already late to go to work.
good night here from Spain.
Jorge EA4HPW

Good night. Thank you for your valuable testing.

Jim KC9HI

Actions #42

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-41:

JORGE GÓMEZ wrote in #note-40:

Success? Yes/No?

yes¡¡¡

my friend, tomorrow we continue with the test, here it is already late to go to work.
good night here from Spain.
Jorge EA4HPW

hello i am here

Good night. Thank you for your valuable testing.

Jim KC9HI

Actions #43

Updated by Jim Unroe about 1 year ago

Hi Jorge,

I am trying to program the last of the settings right now. Maybe I will have an opportunity get some of them added later today. That might be too late for you, so maybe you will see them tomorrow (Saturday). For now you can program some test channels with different frequencies, tones, names and things to see if you can discover any bugs. Thank you for your testing.

Jim KC9HI

Actions #44

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-43:

Hi Jorge,

I am trying to program the last of the settings right now. Maybe I will have an opportunity get some of them added later today. That might be too late for you, so maybe you will see them tomorrow (Saturday). For now you can program some test channels with different frequencies, tones, names and things to see if you can discover any bugs. Thank you for your testing.

Jim KC9HI

ok Jim,see you tomorrow
Jorge EA4HPW

Actions #45

Updated by Jim Unroe about 1 year ago

I am now attaching v0.7 for all to test.

This test driver...

  • fixes some issues when programming repeaters
  • adds settings tabs

Jim KC9HI

Actions #46

Updated by Juan Manuel Puñal Bargueño about 1 year ago

Jim Unroe wrote in #note-45:

I am now attaching v0.7 for all to test.

This test driver...

  • fixes some issues when programming repeaters
  • adds settings tabs

Jim KC9HI

I test this version and return 'radio returned unknown identification string' my radio is a RT-470L. For only test it (i try only the download), i add the id to fingerprint array of RT-470L and download ok.

I attach the log if you need any test i can do it.

Regards.

Actions #47

Updated by Juan Manuel Puñal Bargueño about 1 year ago

Juan Manuel Puñal Bargueño wrote in #note-46:

I test this version and return 'radio returned unknown identification string' my radio is a RT-470L. For only test it (i try only the download), i add the id to fingerprint array of RT-470L and download ok.

I attach the log if you need any test i can do it.

Regards.

The upload work fine too.

Actions #48

Updated by Juan Manuel Puñal Bargueño about 1 year ago

Attach version of firmware and hardware of my radio.

Actions #49

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-45:

I am now attaching v0.7 for all to test.

This test driver...

  • fixes some issues when programming repeaters
  • adds settings tabs

Jim KC9HI

Actions #50

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-49:

Jim Unroe wrote in #note-45:

I am now attaching v0.7 for all to test.

This test driver...

  • fixes some issues when programming repeaters
  • adds settings tabs

Jim KC9HI

good morning from spain, send you new img archive and debug archive version v0.7 test.

Actions #51

Updated by JORGE GÓMEZ about 1 year ago

JORGE GÓMEZ wrote in #note-50:

JORGE GÓMEZ wrote in #note-49:

Jim Unroe wrote in #note-45:

I am now attaching v0.7 for all to test.

This test driver...

  • fixes some issues when programming repeaters
  • adds settings tabs

Jim KC9HI

good morning from spain, send you new img archive and debug archive version v0.7 test.

send you new debug file and img file test upload with repeater programming that i have in the other walkies.
repeaters works fine regards Jim.
Jorge EA4HPW

Actions #52

Updated by Jim Unroe about 1 year ago

Juan Manuel Puñal Bargueño wrote in #note-48:

Attach version of firmware and hardware of my radio.

Hi Juan. Thank you for you participation. I want to confirm that you have the Radtel RT-470L radio model and not the RT-470, right?

Also from the picture that you have attached, I see that the VERSION menu is #55 in your radio. It is number #50 in my RT-470 so that would indicate that some additional menus may need to be supported for your particular radio/firmware version.

Would you be willing to provide a list of the menu numbers and menu names from your radio? I just created a list of the menus from my RT-470 and attached it to this issue. A list of just the differences would be OK if you don't want to provide a full list.

Jim KC9HI

Actions #53

Updated by Juan Manuel Puñal Bargueño about 1 year ago

Jim Unroe wrote in #note-52:

Hi Juan. Thank you for you participation. I want to confirm that you have the Radtel RT-470L radio model and not the RT-470, right?

Also from the picture that you have attached, I see that the VERSION menu is #55 in your radio. It is number #50 in my RT-470 so that would indicate that some additional menus may need to be supported for your particular radio/firmware version.

Would you be willing to provide a list of the menu numbers and menu names from your radio? I just created a list of the menus from my RT-470 and attached it to this issue. A list of just the differences would be OK if you don't want to provide a full list.

Jim KC9HI

This it's my menu list and a photo of the radio label.

I have the firmware update tool and the update for this radio, if you need it write me.

Regards and thanks.

Actions #54

Updated by Jim Unroe about 1 year ago

Juan Manuel Puñal Bargueño wrote in #note-53:

Jim Unroe wrote in #note-52:

Hi Juan. Thank you for you participation. I want to confirm that you have the Radtel RT-470L radio model and not the RT-470, right?

Also from the picture that you have attached, I see that the VERSION menu is #55 in your radio. It is number #50 in my RT-470 so that would indicate that some additional menus may need to be supported for your particular radio/firmware version.

Would you be willing to provide a list of the menu numbers and menu names from your radio? I just created a list of the menus from my RT-470 and attached it to this issue. A list of just the differences would be OK if you don't want to provide a full list.

Jim KC9HI

This it's my menu list and a photo of the radio label.

I have the firmware update tool and the update for this radio, if you need it write me.

Regards and thanks.

Thank you. When it is convenient for you, would you please provide the available choices for the following menus? I have provided what I think they are based on the RT-470L factory software but the software isn't always correct. So please update/correct them to match the actual choices in your RT-470L.

24 PF3 LONG PRESS         [OFF, FM, Tx Power, Scan, Search, LAMP, Weather, MONI]
25 TOP KEY {short press}  [OFF, FM, Tx Power, Scan, Search, LAMP, Weather, MONI]
52 TAIL FREQ              [55 Hz, 62.5 Hz]

Please test menus 24 and 25 to validate that they actually do something. On my radio, PF3 long press is always MONI and TOP KEY short press does nothing. Do something like setting menu 24 and 25 to Tx Power and see if a short press of menu 24 toggles through the H/M/L power levels on the display and then long press menu 25 to see if it does the same.

If they do function in your radio, then would you please download and save images of menus 24, 25 and 52 with at least the following settings as shown below. I have provided example file names. If these menus don't appear to make any functional changes, then you can skip making the images.

Menu 24 = Off (Radtel_RT-470L_PF3LongPress_Off.img)
Menu 24 = MONI (Radtel_RT-470L_PF3LongPress_MONI.img)
Menu 25 = Off (Radtel_RT-470L_TopKey_Off.img)
Menu 25 = MONI (Radtel_RT-470L_TopKey_MONI.img)
Menu 52 = 55 Hz (Radtel_RT-470L_TailFreq_55Hz.img)
Menu 52 = 62.5 Hz (Radtel_RT-470L_TailFreq_62.5Hz.img)

Thanks,
Jim KC9HI

Actions #55

Updated by Juan Manuel Puñal Bargueño about 1 year ago

Hi Jim,

I confirm this choices are correct for this menu entries:

24 PF3 LONG PRESS         [OFF, FM, Tx Power, Scan, Search, LAMP, Weather, MONI]
25 TOP KEY {short press}  [OFF, FM, Tx Power, Scan, Search, LAMP, Weather, MONI]
52 TAIL FREQ              [55 Hz, 62.5 Hz]

I upload the images if you need something write me.

Regards,
Juan Manuel EA4HSN

Actions #56

Updated by Jim Unroe about 1 year ago

Juan Manuel Puñal Bargueño wrote in #note-55:

I upload the images if you need something write me.

Regards,
Juan Manuel EA4HSN

Thank you for the images. I'm sort of skeptical about the "Off" being stored as a different value for PF3 Long Press and Top Key Short Press, but lets find out if that it truly the case. Please try v0.9.

At a minimum, please test the PF3 Key (Long Press) , Top Key (Short Press) and Tail Code settings by uploading each choice, one-by-one to the radio and verify that the corresponding menu (24, 25 & 52) has the matching choice selected. Let me know if there are any choices are incorrect so we can work to get them corrected.

Jim KC9HI

Actions #57

Updated by JORGE GÓMEZ about 1 year ago

Jim Unroe wrote in #note-56:

Juan Manuel Puñal Bargueño wrote in #note-55:

I upload the images if you need something write me.

Regards,
Juan Manuel EA4HSN

Thank you for the images. I'm sort of skeptical about the "Off" being stored as a different value for PF3 Long Press and Top Key Short Press, but lets find out if that it truly the case. Please try v0.9.

At a minimum, please test the PF3 Key (Long Press) , Top Key (Short Press) and Tail Code settings by uploading each choice, one-by-one to the radio and verify that the corresponding menu (24, 25 & 52) has the matching choice selected. Let me know if there are any choices are incorrect so we can work to get them corrected.

Jim KC9HI

Hi Jim, send news debug file and img file test v0.9.

Jorge EA4HPW

Actions #58

Updated by Juan Manuel Puñal Bargueño about 1 year ago

Jim Unroe wrote in #note-56:

Thank you for the images. I'm sort of skeptical about the "Off" being stored as a different value for PF3 Long Press and Top Key Short Press, but lets find out if that it truly the case. Please try v0.9.

At a minimum, please test the PF3 Key (Long Press) , Top Key (Short Press) and Tail Code settings by uploading each choice, one-by-one to the radio and verify that the corresponding menu (24, 25 & 52) has the matching choice selected. Let me know if there are any choices are incorrect so we can work to get them corrected.

Jim KC9HI

Hi Jim,

i test all options and the choice OFF of PF3 KEY (Long press) not work fine.

I attach the debug file compressed.

P.D: I add my fingerprint for work with my radio.

Regards,
Juan Manuel EA4HSN

Actions #59

Updated by Jim Unroe about 1 year ago

Juan Manuel Puñal Bargueño wrote in #note-58:

Hi Jim,

i test all options and the choice OFF of PF3 KEY (Long press) not work fine.

I attach the debug file compressed.

P.D: I add my fingerprint for work with my radio.

Regards,
Juan Manuel EA4HSN

I suspected that OFF for either PF3 KEY (Long press) or TOP KEY was wrong since they were not the same in supplied images. Would you provide a set of replacement images for PF3 KEY (Long press) for me to review (OFF and MONI)?

I thought I added your fingerprint to v0.9 but I see that it is not there. Thanks for letting me know it was missing.

Do you have a way to measure the TX power of RT-470L (H/M/L)? I measured my RT-470 and then just divided by 2 for RT-470L.

Thank you for testing.

Jim

Actions #60

Updated by Aaron McClure about 1 year ago

Hi Jim,
I loaded mml_jc_8810-v0.9.py. When attempting to DL it immediately generated "Radio returned unknown identification string". Please note that the firmware V1.17
Hardware 11-V02
The debug file is attached.
-Aaron WD0FAA

Actions #61

Updated by Jim Unroe about 1 year ago

Aaron McClure wrote in #note-60:

Hi Jim,
I loaded mml_jc_8810-v0.9.py. When attempting to DL it immediately generated "Radio returned unknown identification string". Please note that the firmware V1.17
Hardware 11-V02
The debug file is attached.
-Aaron WD0FAA

Hi Aaron,
Apparently I had uploaded the mml_jc_8810-v1.0.py driver with the additional identification string to the RT-470 ticket instead of the RT-470L ticket. It is now available here.

Jim KC9HI

Actions #62

Updated by Aaron McClure about 1 year ago

HI Jim,
v1.0 worked. Attached is the .img with:
TOP KEY: OFF
PF3 LONG PRESS: OFF
PF3: OFF
PF2 LONG PRESS: OFF
PF2: OFF

-Aaron

Actions #63

Updated by Jim Unroe about 1 year ago

I believe that I now have the PF keys all sorted out and working. Test driver v1.1 is now available for all to test. Please test and provide feedback.

Jim KC9HI

Actions #64

Updated by Aaron McClure about 1 year ago

Hi Jim,
Attached is the reset rig image file.

-Aaron

Actions #65

Updated by Aaron McClure about 1 year ago

Hi Jim,
Regarding PF2 = PTT B
Attached is the image file with PF2 set and the other buttons off.
Attached is the debug file.

-Aaron

Actions #66

Updated by Jim Unroe about 1 year ago

I have been patiently waiting for feedback. Is nobody participating in the testing of them? I was hoping to have other bug fixes to add to v1.2 but none have been reported. I know that v1.1 isn't perfect.

Here is v1.2 with the updated/corrected band limits. Don't add a debug.log file unless you are reporting a bug. And if you are reporting a bug, please mention what it is so I would know what to look for in the log.

Jim KC9HI

Actions #67

Updated by ALFRED BORYSEWICZ about 1 year ago

The file works very well for RT470. I don't see a change in band limits.
Alfred SP3DRY

Actions #68

Updated by Jim Unroe about 1 year ago

ALFRED BORYSEWICZ wrote in #note-67:

The file works very well for RT470. I don't see a change in band limits.
Alfred SP3DRY

You are correct. I noticed this bug while working on another variant and will have it corrected in v1.3.

Jim KC9HI

Actions #69

Updated by ALFRED BORYSEWICZ about 1 year ago

It will be fun when you do with updated/improved bandwidth limits.
Pozdrawaim Alfred SP3DRY

Actions #70

Updated by Jim Unroe about 1 year ago

I have attached v1.3 driver. I have also submitted it as a patch to be included with CHIRP. Once the patch is approved, next CHIRP-next build will have support for the Radtel RT-470L.

Jim KC9HI

Actions #71

Updated by ALFRED BORYSEWICZ about 1 year ago

After testing, everything works OK, only updated/corrected band limits
Alfred SP3DRY

Actions #72

Updated by Anonymous about 1 year ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF