Project

General

Profile

Actions

Bug #10744

closed

Yaesu FT-4XR does not complete clone and read errors

Added by Ray Torella 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/21/2023
Due date:
% Done:

100%

Estimated time:
Chirp Version:
next
Model affected:
Yaesu FT-4XR
Platform:
Windows
Debug Log:
I read the instructions above:

Description

My Yaesu FT-4XR originally was programmed with Legacy with no problems. I noticed that I could transmit on a channel I wanted monitor only. Every version of NEXT, I import to CHIRP. Every SIMPLEX channel is changed to OFF in CHIRP NEXT. This causes the Simplex Not To Transmit. Legacy had a drop down that said - + simplex off as options. On my FT-4XR with NEXT, the "simplex" is not there, so I picked the BLANK option. Then on the channel I wanted monitor only, I changed it to OFF. I then downloaded changes to the FT-4XR which showed full progress. After completed, my FT-4XR is stuck with full bars and the word CLONE, does not reboot. Does not matter how long I let it sit in clone mode. Eventually I have to remove cable and turn off radio with zero changes to the radio after completing the downoad.


Files

NEXT debug.log (34.5 KB) NEXT debug.log Ray Torella, 07/21/2023 12:23 PM
Legacy debug.log (49.6 KB) Legacy debug.log Ray Torella, 07/21/2023 12:23 PM
debug.log (8.75 KB) debug.log Next debug file Ray Torella, 07/21/2023 02:32 PM
Add Screenshot 2023-07-21 142331.jpg (280 KB) Add Screenshot 2023-07-21 142331.jpg Added new channel and downloaded to radio Ray Torella, 07/21/2023 02:32 PM
Upload After Screenshot 2023-07-21 142808.jpg (272 KB) Upload After Screenshot 2023-07-21 142808.jpg Uploaded Radio after channel add. Not there Ray Torella, 07/21/2023 02:32 PM
ft4.py (52.7 KB) ft4.py 645dc8d6 Dan Smith, 07/24/2023 02:37 PM
ft4.py (52.7 KB) ft4.py 17d5790b Dan Smith, 07/30/2023 08:23 AM
chirp_debug-ab3s_zch copy.txt (5.84 KB) chirp_debug-ab3s_zch copy.txt Pete Fontneau, 07/30/2023 10:20 AM
Screenshot 2023-07-30 at 1.11.23 PM.png (159 KB) Screenshot 2023-07-30 at 1.11.23 PM.png Pete Fontneau, 07/30/2023 10:20 AM
Actions #1

Updated by Dan Smith 11 months ago

We need a debug log to do anything with this, per How_To_Report_Issues.

If you can successfully clone both directions with legacy, please include a debug log from legacy so we can compare. I don't know any developers that still have an FT-4 to test with so I'm not sure who will be able to address this, but we need debug logs before we can even try.

Actions #2

Updated by Ray Torella 11 months ago

Dan. I installed Legacy in C:\Program Files in order to run that and Next. I had no problem adding a new frequency to the FT-4XR. Uploaded radio, added new channel, downloaded successfully with latest Legacy on website. Cloned new info to radio no problem. Then grabbed the debug log and called it Legacy debug. Then removed the test channel in Legacy and downloaded to radio. Successfully matched and removed the test channel. Next I uploaded radio to NEXT and added same test channel. Downloaded to radio and watched the FT-4R screen flashing RCV (correct). When it is finished it will go back to clone without radio rebooting (just found out). However, NEXT is not actually writing to the radio memory as the added test channel was not there. Tried 3 times where there should have been the channel with name "TEST" #31. Works in Legacy but not in NEXT. Again the radio does show receiving CHIRP data but is not writing to the mems. After that I copied the debug again which is labeled "NEXT Debug", Thanks, Ray KF6OJE

Actions #3

Updated by Dan Smith 11 months ago

  • Target version set to chirp-py3

Ray, both of those logs are identical and from legacy. Next and Legacy store their logs in the same place and they get overwritten at each start. So please re-reproduce with next, capture the log and attach here.

Actions #4

Updated by Dan Smith 11 months ago

Sorry, they're not identical, but they are both from legacy so my request is still the same.

Actions #5

Updated by Ray Torella 11 months ago

Dan do I delete the current debug file first?

Actions #6

Updated by Dan Smith 11 months ago

No, chirp deletes and re-creates it every time it starts.

Actions #7

Updated by Ray Torella 11 months ago

Here you go Dan. I opened NEXT, added a channel, uploaded to radio. Closed NEXT, turned off radio, new channel #31 not on radio. Uploaded into NEXT that is not writing to mem. Screenshots and NEXT debug attached

Actions #8

Updated by Dan Smith 11 months ago

Ray, can you attach a .img of your radio? I need that to figure out the out of range issue.

Also, your next debug log does not include a reproduction of the cloning issue that I can see. So please try:

  1. Open chirp
  2. Download from your radio
  3. Upload right back to the radio
  4. Capture and attach a debug log right then per How_To_Report_Issues
Actions #9

Updated by Dan Smith 11 months ago

I still want an image of your radio and the debug log per the instructions I provided earlier. However, here's a module to test with that may resolve your simplex and the other out of range issue. See LoadingTestModules for procedures. Please report how the behavior is better or worse with this and include the other two items when you can.

I'm also not sure I'm understanding all the issues you're reporting in the original message. You say you have some cloning error, but is that only when you're unsuccessfully able to select duplex=off or something like that? Are you ever able to clone back to the radio?

Actions #10

Updated by Ray Torella 11 months ago

Hi Dan,

The issue is I upload the radio into NEXT, add a channel, say #31. Download to radio which flashes RX (correct) then CLONE when complete. When I turn radio off, remove cord, turn radio on, no additional channels written to radio. No channel #31 as sent from NEXT. Same situation works perfect with Legacy. Read, add, write, turn off, turn on and any changes and new channel added. That was the last log that I sent you was strickly uploading, adding channel, writing to radio, close NEXT. So the issue is although the FT4XR shows RX (receiving) nothing is being written to memory. Only with NEXT....

Actions #11

Updated by Dan Smith 11 months ago

Okay, I think you have your terminology reversed there - I assume you mean download the radio into chirp and upload the changes back to the radio.

And your issue happens all the time? Unless you show me a debug log of that and I can spot a problem, I won't be able to help without access to a radio. But if there's something exposed in that log I can probably fix it.

Please also test the module and attach a copy of your image so I can try to resolve the out of range issue with loading the contents.

Actions #12

Updated by Dan Smith 11 months ago

Okay, try this for the clone issue where no settings are actually uploaded.

Actions #13

Updated by Pete Fontneau 11 months ago

Hello Dan and thank you!

I think I see what the issue is. The changes I’m making are not saving to the image file.

I didn’t see a place for me to add a comment to ticket 10744 below so adding my answers. I do appreciate the help. After spending time this morning downloading, making changes and documenting my steps, I was about to answer your questions below when I noticed your “save and re-open” step. I was saving the file, but not re-opening the file.

To answer your other questions from below:

1) radio works exactly as expected but doesn't actually upload any changes? Radio works as expected including TX/RX progress bar and “Clone OK”
2) No changes are made; NO error messages.

I have the documentation from today’s session if you’re interested but didn’t attach them here as they seem moot at this point if the changes are being saved.

Pete Fontneau

Actions #14

Updated by Pete Fontneau 11 months ago

Hello Dan,

I was able to export the image file as a CSV file with the changes intact but still not able to save the tab as an image file.

Pete Fontneau

Actions #15

Updated by Dan Smith 11 months ago

Not able to save... at all? That's not what I meant by "changes were not saved" although that does fall in line with the problem as I think it is.

Make sure you've loaded the latest module I attached with LoadingTestModules . Then do your download, make changes, save the file, try your upload, and then capture a debug log per How_To_Report_Issues and attach it here.

I don't have one of these radios, so I can't do the download/upload step and as such, I have to have the debug log from your attempt to see what's going on.

Actions #16

Updated by Pete Fontneau 11 months ago

Thank you very much! That was successful. I was able to save the changes out to the desktop, re-open the image file and upload to the radio without incident. I'm going to add some additional channels and try again. I'll report back if I encounter any problems. In the interim, I've attached the log file and a screen shot

Actions #17

Updated by Pete Fontneau 11 months ago

Working well. Added several more channels to memory and moved them into a separate bank.

Actions #18

Updated by Dan Smith 11 months ago

Great, I'll get this change queued up for the regular build then. Thanks for your help!

Actions #19

Updated by Dan Smith 11 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
Actions #20

Updated by Pete Fontneau 11 months ago

Hi Dan, I just wanted to come full circle and confirm the latest build is working on the FT-65. Thank you once again.

Actions #21

Updated by Dan Smith 11 months ago

Glad to hear it, thanks!

Actions

Also available in: Atom PDF