Bug #1113

IC-2100H

Added by Jean Renomeron almost 7 years ago. Updated about 1 month ago.

Status:Feedback Start date:09/05/2013
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:Icom IC-2100H

Description

Program will not recognize radio...."An error has occurred. Failed to communicate with the radio. Unexpected response from radio. In detect mode, "Unable to get radio model"

debug.log (3.8 kB) Jean Renomeron, 09/05/2013 05:55 pm


Related issues

duplicated by Bug #2409: Icom IC-2100H says "Unexpected response from radio" Closed 03/12/2015
duplicated by Bug #4045: ICOM Serial Cable to USB Closed 09/20/2016
duplicated by Bug #5051: IC-2100H Unexpected response from radio Closed 08/10/2017

History

Updated by Bernhard Hailer 5 months ago

  • Status changed from New to Feedback
  • Assignee deleted (Dan Smith)
  • Priority changed from Urgent to Normal
  • Target version changed from 0.3.1 to chirp-daily
  • Chirp Version changed from 0.3.0 to daily

Have you tried with a recent version since you submitted this?

Updated by peter richards 3 months ago

Re Bug # 1113

I too have an Icom 2100H 2m transceiver and I also get the message "Unexpected response from radio" when I try to upload/download from the radio. This is under Linux Mint with the most recent version of Chirp.

I set the environment variable DEBUG=30, try Chirp and get the error.

The laptop is dual boot, Linux Mint and Windows7.

Last lines of debug.log when Chirp (Linux Mint)was tried to 'detect' radio:
...
[2020-04-17 13:23:02,391] chirp.ui.reporting - DEBUG: Server reports version daily-20200409 is latest
[2020-04-17 13:23:51,102] chirp.ui.reporting - DEBUG: Reporting exception
[2020-04-17 13:23:51,103] chirp.ui.inputdialog - ERROR: --- Exception Dialog: 'Serial' object has no attribute 'get_payload' ---
[2020-04-17 13:23:51,105] chirp.ui.inputdialog - ERROR: Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/chirp/ui/clone.py", line 175, in run
cs.radio_class = detect.DETECT_FUNCTIONS[vendor](cs.port)
File "/usr/lib/python2.7/dist-packages/chirp/detect.py", line 76, in detect_icom_radio
result = _detect_icom_radio(ser)
File "/usr/lib/python2.7/dist-packages/chirp/detect.py", line 43, in _detect_icom_radio
md = icf.get_model_data(ser)
File "/usr/lib/python2.7/dist-packages/chirp/drivers/icf.py", line 140, in get_model_data
send_clone_frame(radio, 0xe0, mdata, raw=True)
File "/usr/lib/python2.7/dist-packages/chirp/drivers/icf.py", line 174, in send_clone_frame
payload = radio.get_payload(data, raw, checksum)
AttributeError: 'Serial' object has no attribute 'get_payload'

[2020-04-17 13:23:51,107] chirp.ui.inputdialog - ERROR: ----------------------------

So then I retry, putting in the values for the port ttyUSB0, choose the vendor as Icom and model 2100 and when I click clone from radio, I get this error report:

last lines of debug file
[2020-04-17 13:27:51,235] chirp.ui.mainapp - INFO: Skipping existing stock config
[2020-04-17 13:27:51,238] chirp.ui.reporting - DEBUG: Checking for updates
[2020-04-17 13:27:51,483] chirp.ui.reporting - DEBUG: Server reports version daily-20200409 is latest
[2020-04-17 13:28:02,317] chirp.ui.mainapp - DEBUG: User selected Icom IC-2100H on port /dev/ttyUSB0
[2020-04-17 13:28:02,324] chirp.ui.clone - DEBUG: Clone thread started
[2020-04-17 13:28:02,578] chirp.ui.reporting - DEBUG: Reporting exception
[2020-04-17 13:28:02,579] chirp.ui.common - ERROR: -- Exception: --
[2020-04-17 13:28:02,581] chirp.ui.common - ERROR: Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/chirp/ui/clone.py", line 256, in run
self.__radio.sync_in()
File "/usr/lib/python2.7/dist-packages/chirp/drivers/icf.py", line 657, in sync_in
self._mmap = clone_from_radio(self)
File "/usr/lib/python2.7/dist-packages/chirp/drivers/icf.py", line 318, in clone_from_radio
raise errors.RadioError("Failed to communicate with the radio: %s" % e)
RadioError: Failed to communicate with the radio: Unexpected response from radio

[2020-04-17 13:28:02,581] chirp.ui.common - ERROR: ----------------
[2020-04-17 13:28:02,581] chirp.ui.clone - ERROR: Clone failed: Failed to communicate with the radio: Unexpected response from radio
[2020-04-17 13:28:02,587] chirp.ui.clone - DEBUG: Clone thread ended
[2020-04-17 13:28:02,598] chirp.ui.reporting - DEBUG: Reporting model usage: Icom_IC-2100H,download,True
[2020-04-17 13:28:02,612] chirp.ui.inputdialog - ERROR: --- Exception Dialog: Failed to communicate with the radio: Unexpected response from radio ---
[2020-04-17 13:28:02,613] chirp.ui.inputdialog - ERROR: None

[2020-04-17 13:28:02,614] chirp.ui.inputdialog - ERROR: ----------------------------
[2020-04-17 13:28:02,614] chirp.ui.reporting - DEBUG: Reporting exception

And yes, I am a member of the dialout group. There is only one USB port connected to the usb-serial cable.

So, then I reboot into Windows7, no change in cable or usb port, and it all works!

I prefer to work in Linux so any suggestions would be welcome!

Peter, VE3BBN

Updated by Bernhard Hailer 2 months ago

  • Model affected changed from IC-2100H to Icom IC-2100H

Hopefully this will be looked at by someone experienced with Icom radios.

Updated by Bernhard Hailer about 1 month ago

More feedback:
Some Icom radios are known to deny cooperation with FTDI cables (even genuine ones). Please try a cable with a genuine Prolific chip.
Unfortunately cables with fake "Prolific" chips make the vast majority of cables on the market; genuine Prolific cables are on the more expensive side.

Also available in: Atom PDF