Project

General

Profile

Actions

Feature #1269

closed

Linux documentation for connection permission-denied

Added by Bruce MacAlister about 9 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/23/2013
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
(All models)

Description

I suggest an addition to Linux documentation to simplify solving a problem I and others have had connecting our devices (radios) to apps (Chirp). It's a problem I solved with help from Ubuntu volunteer community. It's pretty simple but puzzling if you don't know Linux-Ubuntu in depth. I'll not go into the details here. If you are interested in adding this to your documentation, let me know and I will document the issue and solution.

BTW, great piece of software. Good inventing!

Actions #1

Updated by Mike Storke about 9 years ago

I can't speak for Ubuntu-specifics (I won't touch that windows-y POS), but the problem is more of a UNIX one in that your device simply doesn't have permissions set for it. There are two ways around this: manually go in and use "chmod a+w /dev/ttyxxx" your device, or change how your device permissions are set in the first place. Since Ubuntu uses Systemd now, I can't help you, as I run Slackware its creator agrees (and so do I) that Systemd is is against the "UNIX-way".

Ultimately, you need to learn how to use your chosen OS: since it's (relatively, for Ubuntu) open, documentation is very easy to come by.

Actions #2

Updated by Bernhard Hailer almost 3 years ago

  • Status changed from New to Closed
  • Chirp Version changed from 0.3.0 to daily

You could always post it on the mailing list.

Actions

Also available in: Atom PDF